Author Topic: Linux Mint with Win 10 dual boot  (Read 14964 times)

0 Members and 1 Guest are viewing this topic.

Offline Hayder

  • Full Member
  • ***
  • Posts: 146
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Linux Mint with Win 10 dual boot
« Reply #30 on: March 19, 2016, 12:41:26 am »
The machine crashed after reboot, it says that there is error in X server


Sent from my iPhone using Tapatalk

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 17261
  • Karma: 436
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Linux Mint with Win 10 dual boot
« Reply #31 on: March 19, 2016, 01:03:48 am »
Considering you haven't a load of data on there, the quickest thing for you to do at this point is reinstall .. once reinstalled, run:
Code: [Select]
echo "options rtl8723be fwlps=0 ips=0"| sudo tee /etc/modprobe.d/rtl8723be.conf
and tomorrow I'll write up how to switch to WiCD from networkmanager.

I'm a little surprised you're having all this trouble though, as I said I have 2 HP 15's and they give me no trouble at all.
« Last Edit: March 19, 2016, 01:05:45 am by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline Hayder

  • Full Member
  • ***
  • Posts: 146
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Linux Mint with Win 10 dual boot
« Reply #32 on: March 19, 2016, 01:05:53 am »
But I'm afraid it's not a trust system and I have study with a lot of work


Sent from my iPhone using Tapatalk

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 17261
  • Karma: 436
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Linux Mint with Win 10 dual boot
« Reply #33 on: March 19, 2016, 01:08:19 am »
I don't understand that response ?

I'm trying to tell you what would be "quickest" .. debugging X will take longer than a reinstall ??
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline Hayder

  • Full Member
  • ***
  • Posts: 146
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Linux Mint with Win 10 dual boot
« Reply #34 on: March 19, 2016, 01:10:24 am »
Appreciate your help, but if the repair of wifi take all this time !!!


Sent from my iPhone using Tapatalk

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 17261
  • Karma: 436
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Linux Mint with Win 10 dual boot
« Reply #35 on: March 19, 2016, 01:18:28 am »
Okay just found this about your particular laptop G50-80
http://ubuntuforums.org/showthread.php?t=2297603
which seems to suggest
Code: [Select]
echo "options rtl8723be fwlps=0 ips=0"| sudo tee /etc/modprobe.d/rtl8723be.conf
and
Code: [Select]
echo "options iwlwifi 11n_disable=1"| sudo tee /etc/modprobe.d/iwlwifi-opt.conf
but hey it's your call whether to continue or not .. up to you.

I'll help if you want to continue .. but at the end of the day its your decision.
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline Hayder

  • Full Member
  • ***
  • Posts: 146
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Linux Mint with Win 10 dual boot
« Reply #36 on: March 19, 2016, 01:19:16 am »
I finished reinstalling Mint, and wait till tomorrow , I'm sorry for bothering you my friend


Sent from my iPhone using Tapatalk

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 17261
  • Karma: 436
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Linux Mint with Win 10 dual boot
« Reply #37 on: March 19, 2016, 01:29:00 am »
see if the above 2 commands make a difference .. but remember to reboot after you've run them
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline Hayder

  • Full Member
  • ***
  • Posts: 146
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Linux Mint with Win 10 dual boot
« Reply #38 on: March 19, 2016, 01:31:02 am »
Ok dear, let me check and see you tomorrow


Sent from my iPhone using Tapatalk

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 17261
  • Karma: 436
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Linux Mint with Win 10 dual boot
« Reply #39 on: March 19, 2016, 01:37:50 am »
Yeah no problem, I need to do a little homework before I switch you to wicd anyway .. I just tried it, and though it worked, it stopped my system shutting down properly, so I need to figure that out first.

anyway, catch you tomorrow :)
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline Hayder

  • Full Member
  • ***
  • Posts: 146
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Linux Mint with Win 10 dual boot
« Reply #40 on: March 19, 2016, 10:58:21 am »
Good morning
i try to download my program again
its download about 1Gb then wifi drop two times from 1 G to 1.1 G !!

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 17261
  • Karma: 436
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Linux Mint with Win 10 dual boot
« Reply #41 on: March 19, 2016, 03:59:36 pm »
Okay I take it Mint is now reinstalled, and you have already applied these 2 fixes and rebooted:
Code: [Select]
echo "options rtl8723be fwlps=0 ips=0"| sudo tee /etc/modprobe.d/rtl8723be.conf
and
Code: [Select]
echo "options iwlwifi 11n_disable=1"| sudo tee /etc/modprobe.d/iwlwifi-opt.conf
Am i correct ?

If so, can you post the output from:
Code: [Select]
dpkg -l | grep network-manager
and
Code: [Select]
sudo apt-get install -s wicd
« Last Edit: March 19, 2016, 04:04:53 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline Hayder

  • Full Member
  • ***
  • Posts: 146
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Linux Mint with Win 10 dual boot
« Reply #42 on: March 19, 2016, 04:30:01 pm »
i'm sorry my friend , i bothering you even in weekend..

ii  network-manager                             0.9.8.8-0ubuntu7.2                                  amd64        network management framework (daemon and userspace tools)
ii  network-manager-gnome                       0.9.8.8-0ubuntu4.1-mint1                            amd64        network management framework (GNOME frontend)
ii  network-manager-openvpn                     0.9.8.2-1ubuntu4                                    amd64        network management framework (OpenVPN plugin core)
ii  network-manager-openvpn-gnome               0.9.8.2-1ubuntu4                                    amd64        network management framework (OpenVPN plugin GNOME GUI)
ii  network-manager-pptp                        0.9.8.2-1ubuntu2                                    amd64        network management framework (PPTP plugin core)
ii  network-manager-pptp-gnome                  0.9.8.2-1ubuntu2                                    amd64        network management framework (PPTP plugin GNOME GUI)



[sudo] password for hayder:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  python-wicd wicd-daemon wicd-gtk
The following NEW packages will be installed:
  python-wicd wicd wicd-daemon wicd-gtk
0 upgraded, 4 newly installed, 0 to remove and 4 not upgraded.
Inst python-wicd (1.7.2.4-4.1ubuntu1 Ubuntu:14.04/trusty [all])
Inst wicd-daemon (1.7.2.4-4.1ubuntu1 Ubuntu:14.04/trusty [all])
Inst wicd-gtk (1.7.2.4-4.1ubuntu1 Ubuntu:14.04/trusty [all])
Inst wicd (1.7.2.4-4.1ubuntu1 Ubuntu:14.04/trusty [all])
Conf python-wicd (1.7.2.4-4.1ubuntu1 Ubuntu:14.04/trusty [all])
Conf wicd-daemon (1.7.2.4-4.1ubuntu1 Ubuntu:14.04/trusty [all])
Conf wicd-gtk (1.7.2.4-4.1ubuntu1 Ubuntu:14.04/trusty [all])
Conf wicd (1.7.2.4-4.1ubuntu1 Ubuntu:14.04/trusty [all])


Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 17261
  • Karma: 436
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Linux Mint with Win 10 dual boot
« Reply #43 on: March 19, 2016, 05:45:22 pm »
That's not a problem Hayder, I wouldn't be here if I didn't *want* to be :)

Anyway, open a terminal and run these commands in sequence:
Code: [Select]
sudo rm /etc/modprobe.d/iwlwifi-opt.conf
then
Code: [Select]
mkdir ~/networkmanager-backup
then
Code: [Select]
cd ~/networkmanager-backup
then
Code: [Select]
apt-get download network-manager network-manager-gnome network-manager-openvpn network-manager-openvpn-gnome network-manager-pptp network-manager-pptp-gnome
(be sure to get all that last command .. it may scroll off screen on this forum)

okay, that's a backup of the packages we'd need to reinstall network-manager if we find you can't connect via wicd.

Now to install wicd, and uninstall network-manager .. run:
Code: [Select]
sudo apt-get install wicd
then
Code: [Select]
sudo apt-get remove network-manager network-manager-gnome network-manager-openvpn network-manager-openvpn-gnome network-manager-pptp network-manager-pptp-gnome
(be sure to get all that last command .. it may scroll off screen on this forum)

once that's done REBOOT<-- IMPORTANT (but see note at the bottom of this posting)

When you reboot, you should see wicd on your panel where networkmanager used to be .. click it, select your network from the list, and click "connect" .. it'll probably say it requires a key and throw u a window where you change to "wpa 1/2 (passphrase)" and enter your key .. click OK and click "connect again" .. you'll probably also see a box for "connect automatically", tick that too.

you should be connected .. so test the stability of the connection



To UNDO

Instructions for if things go wrong, and you need to get back to networkmanager instead

Open a terminal and run:
Code: [Select]
cd ~/networkmanager-backup
then
Code: [Select]
sudo dpkg -i *.deb
then
Code: [Select]
sudo apt-get remove wicd wicd-gtk wicd-daemon python-wicd
then REBOOT

wicd should be gone, and networkmanager back


NOTE:- If the reboot hangs, the correct way to reboot without damage to the file system is to hold Ctrl+Alt+PrtSc, and whilst holding them type r e i s u b in sequence.

PrtSc is often marked as SysReq

and on *some* laptops it needs to be Ctrl+AltGR+PrtSc whilst typing r e i s u b

It's also a good idea to leave a second or two between the reisub keystrokes.
« Last Edit: March 19, 2016, 05:58:06 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline Hayder

  • Full Member
  • ***
  • Posts: 146
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Linux Mint with Win 10 dual boot
« Reply #44 on: March 19, 2016, 09:44:40 pm »
its way better, but still there is disconnect but it  connect automatically few seconds...

if the problem in wifi driver how can i know if there is new driver available and how can i install it?

 


SimplePortal 2.3.3 © 2008-2010, SimplePortal