Author Topic: [SOLVED] Unable to print  (Read 2002 times)

0 Members and 1 Guest are viewing this topic.

Offline pooky2483

  • Hero Member
  • *****
  • Posts: 2101
  • Karma: 0
  • Gender: Male
  • Slowly getting the hang of it.
    • View Profile
    • Get your FREE Ubuntu stickers here. I'm the UK address
    • Awards
[SOLVED] Unable to print
« on: April 28, 2016, 09:42:24 pm »
I have been having problems printing, my printer only prints half a page (top half) and then... nothing.
I am using an HP OfficeJetPro 6830.

I have uninstalled ALL printers (including FAX) via CUPS and then tried to reinstall them, printer and FAX, via CUPS but that does not solve the problem. I am also not able to complete the printer install using HPLIP 3.16.3 as I get a message telling me that I have not got libtools installed, yet, I HAVE.
I have HPLIP 3.15.9 installed.

« Last Edit: May 06, 2016, 10:21:48 pm by pooky2483 »

Kubuntu 16.04LTS 64bit|KDE 5.36.0|QT 5.6.1|Linux 4.15.0-39-generic|M5A78L-M USB3|BIOS 2101|AMD PhenomII X4 965 3400+|P8H77-I Motherboard NIC|32.0GB PC3-10600 1333Mhz CL9 ( 9-9-9-24 ) DDR3

Online Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 18231
  • Karma: 476
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Unable to print
« Reply #1 on: April 29, 2016, 01:49:24 am »
That's not the default hplip version for 14.04 .. have you installed it manually ? .. if so did the stock version not work or something ?

or are you no longer on 14.04 ?
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline pooky2483

  • Hero Member
  • *****
  • Posts: 2101
  • Karma: 0
  • Gender: Male
  • Slowly getting the hang of it.
    • View Profile
    • Get your FREE Ubuntu stickers here. I'm the UK address
    • Awards
Re: Unable to print
« Reply #2 on: April 29, 2016, 04:31:03 pm »
That's not the default hplip version for 14.04 .. have you installed it manually ? .. if so did the stock version not work or something ?

Yes, I did a manual install of 3.15.9 (I think, what's the version that installs on fresh install?). And what do you mean by 'the stock version'?

Quote
or are you no longer on 14.04 ?

I'm still using 14.04
« Last Edit: April 29, 2016, 04:34:22 pm by pooky2483 »

Kubuntu 16.04LTS 64bit|KDE 5.36.0|QT 5.6.1|Linux 4.15.0-39-generic|M5A78L-M USB3|BIOS 2101|AMD PhenomII X4 965 3400+|P8H77-I Motherboard NIC|32.0GB PC3-10600 1333Mhz CL9 ( 9-9-9-24 ) DDR3

Offline pooky2483

  • Hero Member
  • *****
  • Posts: 2101
  • Karma: 0
  • Gender: Male
  • Slowly getting the hang of it.
    • View Profile
    • Get your FREE Ubuntu stickers here. I'm the UK address
    • Awards
Re: Unable to print
« Reply #3 on: April 29, 2016, 09:24:18 pm »
Just tried to re-install hplip 3.15.9 and I get the same error as when trying to install the latest version, libtool not installed...
It IS though!

Kubuntu 16.04LTS 64bit|KDE 5.36.0|QT 5.6.1|Linux 4.15.0-39-generic|M5A78L-M USB3|BIOS 2101|AMD PhenomII X4 965 3400+|P8H77-I Motherboard NIC|32.0GB PC3-10600 1333Mhz CL9 ( 9-9-9-24 ) DDR3

Offline pooky2483

  • Hero Member
  • *****
  • Posts: 2101
  • Karma: 0
  • Gender: Male
  • Slowly getting the hang of it.
    • View Profile
    • Get your FREE Ubuntu stickers here. I'm the UK address
    • Awards
Re: Unable to print
« Reply #4 on: April 29, 2016, 10:14:18 pm »
Just thought I'd have another try...
Managed to get the printer working.
The only difference this time was, I didn't tick 'share Printer'.

Kubuntu 16.04LTS 64bit|KDE 5.36.0|QT 5.6.1|Linux 4.15.0-39-generic|M5A78L-M USB3|BIOS 2101|AMD PhenomII X4 965 3400+|P8H77-I Motherboard NIC|32.0GB PC3-10600 1333Mhz CL9 ( 9-9-9-24 ) DDR3

Online Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 18231
  • Karma: 476
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Unable to print
« Reply #5 on: April 30, 2016, 01:51:45 pm »
Glad you got it sorted pooky2483 .. What I meant by "stock" was "standard/default" ;)
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline pooky2483

  • Hero Member
  • *****
  • Posts: 2101
  • Karma: 0
  • Gender: Male
  • Slowly getting the hang of it.
    • View Profile
    • Get your FREE Ubuntu stickers here. I'm the UK address
    • Awards
Re: Unable to print
« Reply #6 on: May 06, 2016, 10:21:26 pm »
I had the same problem on the fresh install of Kubuntu 14.04 I did yesterday.
Same problem with HPLIP, so I used CUPS to completely remove all printers and installed them using CUPS and again, unticked 'share printer' and it worked.
No idea what the cause of the problem is/was.

Kubuntu 16.04LTS 64bit|KDE 5.36.0|QT 5.6.1|Linux 4.15.0-39-generic|M5A78L-M USB3|BIOS 2101|AMD PhenomII X4 965 3400+|P8H77-I Motherboard NIC|32.0GB PC3-10600 1333Mhz CL9 ( 9-9-9-24 ) DDR3

Online Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 18231
  • Karma: 476
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: [SOLVED] Unable to print
« Reply #7 on: May 07, 2016, 03:24:47 pm »
Cool, at least you figured a way around it :)
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

 


SimplePortal 2.3.3 © 2008-2010, SimplePortal