Author Topic: computer start up slow (Solved)  (Read 6089 times)

0 Members and 1 Guest are viewing this topic.

Offline donwatson

  • Hero Member
  • *****
  • Posts: 901
  • Karma: 8
  • Gender: Male
  • Getting older
    • View Profile
    • Awards
computer start up slow (Solved)
« on: August 19, 2016, 05:22:24 pm »
Hi Mark,
My computer is quite slow in starting up. I have attached the bottom of the results I got from dmesg.txt.

[   23.390556] audit: type=1400 audit(1471620033.694:5): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/connman/scripts/dhclient-script" pid=2228 comm="apparmor_parser"
[   23.391106] audit: type=1400 audit(1471620033.698:6): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/lightdm/lightdm-guest-session" pid=2227 comm="apparmor_parser"
[   23.391116] audit: type=1400 audit(1471620033.698:7): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/lightdm/lightdm-guest-session//chromium" pid=2227 comm="apparmor_parser"
[   23.397794] audit: type=1400 audit(1471620033.702:8): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/sbin/cups-browsed" pid=2231 comm="apparmor_parser"
[   23.401158] audit: type=1400 audit(1471620033.706:9): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/cups/backend/cups-pdf" pid=2232 comm="apparmor_parser"
[   23.401168] audit: type=1400 audit(1471620033.706:10): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/sbin/cupsd" pid=2232 comm="apparmor_parser"
[   23.401175] audit: type=1400 audit(1471620033.706:11): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/sbin/cupsd//third_party" pid=2232 comm="apparmor_parser"
[   27.803750] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   27.803754] Bluetooth: BNEP filters: protocol multicast
[   27.803760] Bluetooth: BNEP socket layer initialized
[   31.348058] IPv6: ADDRCONF(NETDEV_UP): enp3s0f2: link is not ready
[   31.497601] r8169 0000:03:00.2 enp3s0f2: link down
[   31.497701] IPv6: ADDRCONF(NETDEV_UP): enp3s0f2: link is not ready
[   31.594932] IPv6: ADDRCONF(NETDEV_UP): wlp2s0: link is not ready
[   31.976223] IPv6: ADDRCONF(NETDEV_UP): wlp2s0: link is not ready
[   32.401313] IPv6: ADDRCONF(NETDEV_UP): wlp2s0: link is not ready
[   41.401431] wlp2s0: authenticate with 20:0c:c8:7d:08:18
[   41.776636] wlp2s0: send auth to 20:0c:c8:7d:08:18 (try 1/3)
[   41.778530] wlp2s0: authenticated
[   41.780193] wlp2s0: associate with 20:0c:c8:7d:08:18 (try 1/3)
[   41.784401] wlp2s0: RX AssocResp from 20:0c:c8:7d:08:18 (capab=0x411 status=0 aid=2)
[   41.784591] wlp2s0: associated
[   41.784634] IPv6: ADDRCONF(NETDEV_CHANGE): wlp2s0: link becomes ready
[   41.832620] cfg80211: Regulatory domain changed to country: GB
[   41.832624] cfg80211:  DFS Master region: ETSI
[   41.832626] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[   41.832629] cfg80211:   (2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[   41.832631] cfg80211:   (5170000 KHz - 5250000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (N/A)
[   41.832634] cfg80211:   (5250000 KHz - 5330000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (0 s)
[   41.832636] cfg80211:   (5490000 KHz - 5710000 KHz @ 160000 KHz), (N/A, 2700 mBm), (0 s)
[   41.832638] cfg80211:   (57000000 KHz - 66000000 KHz @ 2160000 KHz), (N/A, 4000 mBm), (N/A)
[  938.389088] r8169 0000:03:00.2 enp3s0f2: link up
[  938.389102] IPv6: ADDRCONF(NETDEV_CHANGE): enp3s0f2: link becomes ready
[ 1435.559193] wlp2s0: deauthenticated from 20:0c:c8:7d:08:18 (Reason: 6=CLASS2_FRAME_FROM_NONAUTH_STA)
[ 1435.610257] wlp2s0: authenticate with 20:0c:c8:7d:08:18
[ 1435.623953] wlp2s0: send auth to 20:0c:c8:7d:08:18 (try 1/3)
[ 1435.625830] wlp2s0: authenticated
[ 1435.629614] wlp2s0: associate with 20:0c:c8:7d:08:18 (try 1/3)
[ 1435.633816] wlp2s0: RX AssocResp from 20:0c:c8:7d:08:18 (capab=0x411 status=0 aid=1)
[ 1435.634050] wlp2s0: associated
[ 1435.654658] cfg80211: World regulatory domain updated:
[ 1435.654663] cfg80211:  DFS Master region: unset
[ 1435.654665] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[ 1435.654668] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[ 1435.654670] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[ 1435.654672] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (N/A, 2000 mBm), (N/A)
[ 1435.654675] cfg80211:   (5170000 KHz - 5250000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (N/A)
[ 1435.654678] cfg80211:   (5250000 KHz - 5330000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (0 s)
[ 1435.654680] cfg80211:   (5490000 KHz - 5730000 KHz @ 160000 KHz), (N/A, 2000 mBm), (0 s)
[ 1435.654682] cfg80211:   (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
[ 1435.654684] cfg80211:   (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0 mBm), (N/A)
[ 1435.721485] cfg80211: Regulatory domain changed to country: GB
[ 1435.721490] cfg80211:  DFS Master region: ETSI
[ 1435.721492] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[ 1435.721495] cfg80211:   (2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[ 1435.721497] cfg80211:   (5170000 KHz - 5250000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (N/A)
[ 1435.721500] cfg80211:   (5250000 KHz - 5330000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (0 s)
[ 1435.721502] cfg80211:   (5490000 KHz - 5710000 KHz @ 160000 KHz), (N/A, 2700 mBm), (0 s)
[ 1435.721504] cfg80211:   (57000000 KHz - 66000000 KHz @ 2160000 KHz), (N/A, 4000 mBm), (N/A)

Is there a problem here ? and can I fix it ?
« Last Edit: September 14, 2016, 04:11:37 pm by donwatson »
Novatech build
Intel Celeron CPU 1.80 Ghz   Memory 4.00GB (3.71GB usable)
Peppermint 7    64 bit     500 GB HD        496 GB Ext 4
4.0GB Swap Partition    4.0GB Extended Partition   1.1Mb Free Space

Offline SeZo

  • Hero Member
  • *****
  • Posts: 1814
  • Karma: 138
  • Gender: Male
    • View Profile
    • Awards
Re: computer start up slow
« Reply #1 on: August 19, 2016, 06:01:51 pm »
This is where most of that time is spent:
Quote
[   41.832638] cfg80211:   (57000000 KHz - 66000000 KHz @ 2160000 KHz), (N/A, 4000 mBm), (N/A)
[  938.389088] r8169 0000:03:00.2 enp3s0f2: link up
[  938.389102] IPv6: ADDRCONF(NETDEV_CHANGE): enp3s0f2: link becomes ready
[ 1435.559193] wlp2s0: deauthenticated from 20:0c:c8:7d:08:18 (Reason: 6=CLASS2_FRAME_FROM_NONAUTH_STA)
[ 1435.610257] wlp2s0: authenticate with 20:0c:c8:7d:08:18
[ 1435.623953] wlp2s0: send auth to 20:0c:c8:7d:08:18 (try 1/3)
[ 1435.625830] wlp2s0: authenticated

It may be something to do with the delay caused by trying to connect with IPV6.
Try booting with your wireless disabled and see if hat makes the difference.
If it does (it should) the re-enable the wireless and then try disabling IPV6 in your router and/or your machine and see if it is improved the boot.


Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 17312
  • Karma: 439
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: computer start up slow
« Reply #2 on: August 19, 2016, 10:22:10 pm »
Can you also define "slow to boot", and post the output from
Code: [Select]
inxi -F
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline donwatson

  • Hero Member
  • *****
  • Posts: 901
  • Karma: 8
  • Gender: Male
  • Getting older
    • View Profile
    • Awards
Re: computer start up slow
« Reply #3 on: August 20, 2016, 11:57:54 am »
Hi Mark,
I get this

don@ldwatson ~ $ inxi -F
System:    Host: ldwatson Kernel: 4.4.0-34-generic x86_64 (64 bit) Desktop: N/A Distro: Peppermint Seven
Machine:   System: Notebook (portable) product: W24xCZ
           Mobo: Notebook model: W24xCZ v: V3.0 Bios: American Megatrends v: 4.6.5 date: 11/18/2013
CPU:       Dual core Intel Celeron 1037U (-MCP-) cache: 2048 KB
           clock speeds: max: 1800 MHz 1: 799 MHz 2: 800 MHz
Graphics:  Card: Intel 3rd Gen Core processor Graphics Controller
           Display Server: X.Org 1.18.3 drivers: intel (unloaded: fbdev,vesa) Resolution: 1366x768@60.06hz
           GLX Renderer: Mesa DRI Intel Ivybridge Mobile GLX Version: 3.0 Mesa 11.2.0
Audio:     Card Intel 7 Series/C210 Series Family High Definition Audio Controller driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.4.0-34-generic
Network:   Card-1: Realtek RTL8723AE PCIe Wireless Network Adapter driver: rtl8723ae
           IF: wlp2s0 state: up mac: a4:db:30:c7:44:e8
           Card-2: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller driver: r8169
           IF: enp3s0f2 state: down mac: 00:90:f5:f3:67:bf
Drives:    HDD Total Size: 500.1GB (6.8% used) ID-1: /dev/sda model: HGST_HTS545050A7 size: 500.1GB
Partition: ID-1: / size: 455G used: 29G (7%) fs: ext4 dev: /dev/sda2
           ID-2: swap-1 size: 3.98GB used: 0.00GB (0%) fs: swap dev: /dev/sda3
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 48.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 192 Uptime: 4 min Memory: 640.3/3656.3MB Client: Shell (bash) inxi: 2.2.35
don@ldwatson ~ $
Novatech build
Intel Celeron CPU 1.80 Ghz   Memory 4.00GB (3.71GB usable)
Peppermint 7    64 bit     500 GB HD        496 GB Ext 4
4.0GB Swap Partition    4.0GB Extended Partition   1.1Mb Free Space

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 17312
  • Karma: 439
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: computer start up slow
« Reply #4 on: August 20, 2016, 01:20:46 pm »
Did you try what SeZo suggested and boot with wireless disabled to see if that made a difference ? .. as a diagnostic test.

and how about my other question ? .. can you define "slow to boot" ?
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline donwatson

  • Hero Member
  • *****
  • Posts: 901
  • Karma: 8
  • Gender: Male
  • Getting older
    • View Profile
    • Awards
Re: computer start up slow
« Reply #5 on: August 20, 2016, 01:53:26 pm »
Hi Mark,
Before I shut down last night I disabled the WiFi connection.
When I started this morning I switched the machine on and it took 45 seconds to show the login screen. I thought this was a bit long to be sat staring at a blank monitor.
I ticked the box and enabled the WiFi connection, I then shut down.
I have just restarted the computer and it took the same 45 seconds to get to the login screen.
I haven't been to disable the IPV6 yet as I am unsure of the best way to do it.
Sorry to be such a nuisance.

take care
Don W
Novatech build
Intel Celeron CPU 1.80 Ghz   Memory 4.00GB (3.71GB usable)
Peppermint 7    64 bit     500 GB HD        496 GB Ext 4
4.0GB Swap Partition    4.0GB Extended Partition   1.1Mb Free Space

Offline SeZo

  • Hero Member
  • *****
  • Posts: 1814
  • Karma: 138
  • Gender: Male
    • View Profile
    • Awards
Re: computer start up slow
« Reply #6 on: August 20, 2016, 03:25:46 pm »
Try disabling the WiFi with the hardware switch rather than software (as that will only come into effect after you log in).
Also if you could post the dmesg extract with the WiFi disabled for comparison.

Offline donwatson

  • Hero Member
  • *****
  • Posts: 901
  • Karma: 8
  • Gender: Male
  • Getting older
    • View Profile
    • Awards
Re: computer start up slow
« Reply #7 on: August 20, 2016, 03:56:51 pm »
OK SeZo,
I will unplug the router before I power up. Is that ok?
I will need to wait as my grandson is using his machine on the WiFi to keep up with the football. lol
Novatech build
Intel Celeron CPU 1.80 Ghz   Memory 4.00GB (3.71GB usable)
Peppermint 7    64 bit     500 GB HD        496 GB Ext 4
4.0GB Swap Partition    4.0GB Extended Partition   1.1Mb Free Space

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 17312
  • Karma: 439
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: computer start up slow
« Reply #8 on: August 20, 2016, 04:27:16 pm »
@ SeZo

I don't think the bit of dmesg you're concentrating on is part of the boot sequence .. I think that's where the system dropped wifi after the PC had been on for some time, and then reconnected (a known issue with RTL8723xx cards without a driver tweak).

I think the boot sequence ends here

[   41.832638] cfg80211:   (57000000 KHz - 66000000 KHz @ 2160000 KHz), (N/A, 4000 mBm), (N/A)

and besides a 9 second wait for wireless to come up here:-

[   32.401313] IPv6: ADDRCONF(NETDEV_UP): wlp2s0: link is not ready
[   41.401431] wlp2s0: authenticate with 20:0c:c8:7d:08:18

I'm not really seeing anything stupidly excessive

41 seconds isn't a fast boot by any means, but neither is it WAY excessive for a hard drive.



@ donwatson

Has the PC always taken 41 seconds, or is this a new thing ?

turning off the router probably won't make a difference as the wirless in your PC is still going to look for the connection .. in fat it may evenslow booting further .. does your BIOS have an option to disable wireless entirely, or if it's a laptop is there a key cobo to disable wifi ?
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline donwatson

  • Hero Member
  • *****
  • Posts: 901
  • Karma: 8
  • Gender: Male
  • Getting older
    • View Profile
    • Awards
Re: computer start up slow
« Reply #9 on: August 20, 2016, 07:27:06 pm »
Thanks for the info. Mark,
I think it 'may' have booted faster when first I installed Pep 7. I suppose the addition of all the programmes, Google and a pile of games may make it run a little slower ?
The machine is a Novatech and I 'think' there is a Fn+F12 that connects with the WiFi.
I have a folder on my machine that I saved from Pep 6, it is named rtlwifi-lwfinger and it had something to do with the wifi connection, I think.
Novatech build
Intel Celeron CPU 1.80 Ghz   Memory 4.00GB (3.71GB usable)
Peppermint 7    64 bit     500 GB HD        496 GB Ext 4
4.0GB Swap Partition    4.0GB Extended Partition   1.1Mb Free Space

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 17312
  • Karma: 439
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: computer start up slow
« Reply #10 on: August 20, 2016, 11:44:42 pm »
Try turning off wireless with your Fn+F12 .. then reboot (hopefully wireless will stay off).

Did wireless stay off when you rebooted .. ie, did you need to turn it back on after the reboot ?

If so, did the PC boot any faster ?
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline donwatson

  • Hero Member
  • *****
  • Posts: 901
  • Karma: 8
  • Gender: Male
  • Getting older
    • View Profile
    • Awards
Re: computer start up slow
« Reply #11 on: August 21, 2016, 09:43:26 am »
Hi Mark,
I tried Fn+F12 but there is nothing to indicate that anything is happening. The WiFi bars stay full up and left clicking shows the WiFi Enabled is still ticked. I rebooted and it still took around 45 seconds to boot.
I am not sure that 'ALL' the Fn keys work on this machine. I bought the machine as a bare bones machine and installed Peppermint 5. Any problems were resolved on here by you and other members as Novatech 'only worked with MS Windows' ?
I know the Fn+F8,F9 increases/decreases the screen brightness the rest of the Fn keys are a mystery. I think I asked Novatech about Fn+F12 before when I had a wireless problem and that was when they said they only fixed Windows.?

take care
Don W
Novatech build
Intel Celeron CPU 1.80 Ghz   Memory 4.00GB (3.71GB usable)
Peppermint 7    64 bit     500 GB HD        496 GB Ext 4
4.0GB Swap Partition    4.0GB Extended Partition   1.1Mb Free Space

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 17312
  • Karma: 439
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: computer start up slow
« Reply #12 on: August 21, 2016, 11:32:42 am »
I'm getting reports from a "few" other people of slow boot times compared to Peppermint 6 .. this only seems to affect a ery small number of people, most reporting that if anything systemd seems to have made booting FASTER.

In a topic on the Peppermint forum I've just asked if anyone wants to attempt switching back to upstart-sysv to see if that helps.

Wanna give it a shot ? .. or do you want to wait and see what happens in the Peppermint forum ?

Reason I ask - this would be totally experimental so I cannot guarantee it's reliability, in fact I can't guarantee it won't screw your system .. all I can say is I've switched between upstart-sysv and systemd-sysv (and back again) a few times without issue.
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline donwatson

  • Hero Member
  • *****
  • Posts: 901
  • Karma: 8
  • Gender: Male
  • Getting older
    • View Profile
    • Awards
Re: computer start up slow
« Reply #13 on: August 21, 2016, 07:19:27 pm »
Hi Mark,
I will give it a try. This is a fairly new install of Peppermint 7 so there is nothing to lose.
Novatech build
Intel Celeron CPU 1.80 Ghz   Memory 4.00GB (3.71GB usable)
Peppermint 7    64 bit     500 GB HD        496 GB Ext 4
4.0GB Swap Partition    4.0GB Extended Partition   1.1Mb Free Space

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 17312
  • Karma: 439
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: computer start up slow
« Reply #14 on: August 22, 2016, 02:36:40 am »
Let's see if switching to WiCD helps first .. you're propbably going to need to do this for upstart-sysv anyway.

Open a terminal and run:
Code: [Select]
sudo apt-get install wicd
then
Code: [Select]
sudo apt-get remove network-manager
then reboot to test.

If there's no wicd tray icon for configuring your network, run:
Code: [Select]
nohup wicd-gtk -t
then close the terminal

There should be a tray icon now .. you'll probably need to configure your network again there .. be aware it IS different to the previous network-manager, but I'm sure you can figure it out.

Does your PC boot any faster now ?
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

 


SimplePortal 2.3.3 © 2008-2010, SimplePortal