Author Topic: back light keyboard problem [Solved}  (Read 4584 times)

0 Members and 1 Guest are viewing this topic.

Offline Hayder

  • Full Member
  • ***
  • Posts: 146
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
back light keyboard problem [Solved}
« on: August 23, 2016, 07:35:36 pm »
Hello
i know this is a silly question, but i'm very new to linux and this place is great.
my backlight keyboard dosn't turn off automatically,like my screen,  i can just turn it on and off manually  by function key.... how can i fix that
thanks
« Last Edit: August 27, 2016, 09:59:12 pm by Hayder »

Online Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 17312
  • Karma: 439
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: back light keyboard problem
« Reply #1 on: August 26, 2016, 02:23:50 am »
Quote
like my screen

What exactly do you mean by this (what/when is blanking the screen) ..

when you put the PC into suspend/hibernate ?

when the power manager kicks in and blanks the screen ?

when the screensaver kicks in and blanks the screen ?

etc ?
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline Hayder

  • Full Member
  • ***
  • Posts: 146
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: back light keyboard problem
« Reply #2 on: August 26, 2016, 02:09:46 pm »
Hello
Sorry for my bad English.
i mean after some time the screen  brightness be less until it go off, but the keyboard light still on all the time, until i turned it off manually.in Windows the keyboard turned off automatically...

Online Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 17312
  • Karma: 439
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: back light keyboard problem
« Reply #3 on: August 26, 2016, 02:45:55 pm »
Which Linux distro/version/architecture are we talking about ?
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline Hayder

  • Full Member
  • ***
  • Posts: 146
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: back light keyboard problem
« Reply #4 on: August 26, 2016, 03:00:23 pm »
Peppermint 7

Online Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 17312
  • Karma: 439
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: back light keyboard problem
« Reply #5 on: August 27, 2016, 02:21:39 am »
I take it you mean you've set the powermanager to suspend your PC, but when it enters supsend the keyboard stays light ?

Have you tried setting the powermanager to hibernate instead of suspend ?
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline Hayder

  • Full Member
  • ***
  • Posts: 146
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: back light keyboard problem
« Reply #6 on: August 27, 2016, 09:50:12 am »
Hello
No, I mean the screen turned off after 120 sec but the keyboard is not !
the pc still works

Online Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 17312
  • Karma: 439
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: back light keyboard problem
« Reply #7 on: August 27, 2016, 01:47:27 pm »
Yeah but WHAT is turning the screen off after 120 seconds ?

Peppermint 7 is not set to screen blank out of the box, so you must have set this behaviour somewhere ?

what's the output from:
Code: [Select]
xset -q
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline Hayder

  • Full Member
  • ***
  • Posts: 146
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: back light keyboard problem
« Reply #8 on: August 27, 2016, 02:14:23 pm »
Keyboard Control:
  auto repeat:  on    key click percent:  0    LED mask:  00000000
  XKB indicators:
    00: Caps Lock:   off    01: Num Lock:    off    02: Scroll Lock: off
    03: Compose:     off    04: Kana:        off    05: Sleep:       off
    06: Suspend:     off    07: Mute:        off    08: Misc:        off
    09: Mail:        off    10: Charging:    off    11: Shift Lock:  off
    12: Group 2:     off    13: Mouse Keys:  off
  auto repeat delay:  500    repeat rate:  33
  auto repeating keys:  00ffffffdffffbbf
                        fadfffefffedffff
                        9fffffffffffffff
                        fff7ffffffffffff
  bell percent:  50    bell pitch:  400    bell duration:  100
Pointer Control:
  acceleration:  20/10    threshold:  10
Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  600    cycle:  0
Colors:
  default colormap:  0x22    BlackPixel:  0x0    WhitePixel:  0xffffff
Font Path:
  /usr/share/fonts/X11/misc,built-ins
DPMS (Energy Star):
  Standby: 300    Suspend: 0    Off: 600
  DPMS is Enabled
  Monitor is On

Online Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 17312
  • Karma: 439
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: back light keyboard problem
« Reply #9 on: August 27, 2016, 08:05:16 pm »
You currently appear to have the power manager set to put the system to "sleep" after 5 minutes (300 seconds), and to power off after 10 minutes.

I'm betting you have "Sleep" mode set to "Suspend" in the xfce4-power-manager ?

Do you have the option to change the system sleep mode to "Hibernate" instead ?
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline Hayder

  • Full Member
  • ***
  • Posts: 146
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: back light keyboard problem
« Reply #10 on: August 27, 2016, 08:45:55 pm »
I just have Suspend, Hibernate operation not  permitted 

Online Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 17312
  • Karma: 439
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: back light keyboard problem
« Reply #11 on: August 27, 2016, 09:10:00 pm »
Okay, we can enable hibernate, but first we need to test it works.

Open an application such as your web browser .. leave it open and also open a terminal (Ctrl+Alt+T) .. in the terminal run:
Code: [Select]
sudo pm-hibernate
did your system appear to shut down ? .. but when you restart it the web browser and terminal are still open.

If so, we can move on to enabling hibernation.
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline Hayder

  • Full Member
  • ***
  • Posts: 146
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: back light keyboard problem
« Reply #12 on: August 27, 2016, 09:27:16 pm »
its ok after hibernate just the web page is halted, not responding

Online Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 17312
  • Karma: 439
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: back light keyboard problem
« Reply #13 on: August 27, 2016, 09:35:27 pm »
is it wireless that's disabled after a hibernate, or just the web browser .. eg. does restarting the browser make it work again ?

hibernate again, then when you awake the PC run:
Code: [Select]
ping -c 5 google.com
and post the output
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline Hayder

  • Full Member
  • ***
  • Posts: 146
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: back light keyboard problem
« Reply #14 on: August 27, 2016, 09:42:31 pm »
just the web page that left before hibernate, the rest web page is ok

 


SimplePortal 2.3.3 © 2008-2010, SimplePortal