Author Topic: fresh install WIFI extremely slow  (Read 15860 times)

0 Members and 2 Guests are viewing this topic.

Offline matt_mccarron

  • Jr. Member
  • **
  • Posts: 11
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
fresh install WIFI extremely slow
« on: February 11, 2017, 07:16:24 pm »
Hello!  Thanks for having me!
I am Linux illiterate.

(Please don't assume I have 2 friggen clues what I or you are saying)

Installed MATE 16.04 and wifi is extremely slow.

The wifi adaptor is a Realtek, RT3090 Wireless 802.11n 1T/1R PCIe

Could someone please spoon feed me a solution?

I have tried this:

@BlackBox:~$ sudo modprobe -r rt2800pci [sudo] password for god: @BlackBox:~$ sudo modprobe -v rt2800pci nohwcrypt=1
Code: [Select]
insmod /lib/modules/4.4.0-31-generic/kernel/lib/crc-ccitt.ko insmod /lib/modules/4.4.0-31-generic/kernel/drivers/misc/eeprom/eeprom_93cx6.ko insmod /lib/modules/4.4.0-31-generic/kernel/net/wireless/cfg80211.ko insmod /lib/modules/4.4.0-31-generic/kernel/net/mac80211/mac80211.ko insmod /lib/modules/4.4.0-31-generic/kernel/drivers/net/wireless/rt2x00/rt2x00lib.ko insmod /lib/modules/4.4.0-31-generic/kernel/drivers/net/wireless/rt2x00/rt2x00mmio.ko insmod /lib/modules/4.4.0-31-generic/kernel/drivers/net/wireless/rt2x00/rt2x00pci.ko insmod /lib/modules/4.4.0-31-generic/kernel/drivers/net/wireless/rt2x00/rt2800lib.ko insmod /lib/modules/4.4.0-31-generic/kernel/drivers/net/wireless/rt2x00/rt2800mmio.ko insmod /lib/modules/4.4.0-31-generic/kernel/drivers/net/wireless/rt2x00/rt2800pci.ko nohwcrypt=1

The first command turned off the wifi, the second command reconnected it. There was no improvement in speed.

Then I tried this:

echo "options rt2800pci nohwcrypt=1" | sudo tee /etc/modprobe.d/rt2800pci.conf

Then did a reboot, no change in speed.


Then I went to "edit connections" in the network manager, seclect Ipv6 and selected "Ignore" That definitely caused an increase in download speed, from .4 up to 7.5. Still pretty slow, but not glacier slow.


Some previous people in another forum have asked for some outputs, so here they are:

@BlackBox:~$ lspci -nn
Code: [Select]
 00:00.0 Host bridge [0600]: Advanced Micro Devices, Inc. [AMD] Family 14h Processor Root Complex [1022:1510] 00:01.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Wrestler [Radeon HD 6310] [1002:9802] 00:01.1 Audio device [0403]: Advanced Micro Devices, Inc. [AMD/ATI] Wrestler HDMI Audio [1002:1314] 00:11.0 SATA controller [0106]: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 SATA Controller [AHCI mode] [1002:4391] 00:12.0 USB controller [0c03]: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI0 Controller [1002:4397] 00:12.2 USB controller [0c03]: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB EHCI Controller [1002:4396] 00:13.0 USB controller [0c03]: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI0 Controller [1002:4397] 00:13.2 USB controller [0c03]: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB EHCI Controller [1002:4396] 00:14.0 SMBus [0c05]: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 SMBus Controller [1002:4385] (rev 42) 00:14.2 Audio device [0403]: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 Azalia (Intel HDA) [1002:4383] (rev 40) 00:14.3 ISA bridge [0601]: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 LPC host controller [1002:439d] (rev 40) 00:14.4 PCI bridge [0604]: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 PCI to PCI Bridge [1002:4384] (rev 40) 00:14.5 USB controller [0c03]: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI2 Controller [1002:4399] 00:15.0 PCI bridge [0604]: Advanced Micro Devices, Inc. [AMD/ATI] SB700/SB800/SB900 PCI to PCI bridge (PCIE port 0) [1002:43a0] 00:15.2 PCI bridge [0604]: Advanced Micro Devices, Inc. [AMD/ATI] SB900 PCI to PCI bridge (PCIE port 2) [1002:43a2] 00:18.0 Host bridge [0600]: Advanced Micro Devices, Inc. [AMD] Family 12h/14h Processor Function 0 [1022:1700] (rev 43) 00:18.1 Host bridge [0600]: Advanced Micro Devices, Inc. [AMD] Family 12h/14h Processor Function 1 [1022:1701] 00:18.2 Host bridge [0600]: Advanced Micro Devices, Inc. [AMD] Family 12h/14h Processor Function 2 [1022:1702] 00:18.3 Host bridge [0600]: Advanced Micro Devices, Inc. [AMD] Family 12h/14h Processor Function 3 [1022:1703] 00:18.4 Host bridge [0600]: Advanced Micro Devices, Inc. [AMD] Family 12h/14h Processor Function 4 [1022:1704] 00:18.5 Host bridge [0600]: Advanced Micro Devices, Inc. [AMD] Family 12h/14h Processor Function 6 [1022:1718] 00:18.6 Host bridge [0600]: Advanced Micro Devices, Inc. [AMD] Family 12h/14h Processor Function 5 [1022:1716] 00:18.7 Host bridge [0600]: Advanced Micro Devices, Inc. [AMD] Family 12h/14h Processor Function 7 [1022:1719] 02:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 06) 03:00.0 Network controller [0280]: Ralink corp. RT3090 Wireless 802.11n 1T/1R PCIe [1814:3090]

BlackBox:~$ lshw -C network
Code: [Select]
WARNING: you should run this program as super-user. *-network
description: Ethernet interface product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller vendor: Realtek Semiconductor Co., Ltd. physical id: 0 bus info: pci@0000:02:00.0 logical name: enp2s0 version: 06 serial: f0:de:f1:6f:85:e8 size: 10Mbit/s capacity: 1Gbit/s width: 64 bits clock: 33MHz capabilities: bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl_nic/rtl8168e-2.fw latency=0 link=no multicast=yes port=MII speed=10Mbit/s resources: irq:26 ioport:1000(size=256) memory:e0004000-e0004fff memory:e0000000-e0003fff *-network description: Wireless interface product: RT3090 Wireless 802.11n 1T/1R PCIe vendor: Ralink corp. physical id: 0 bus info: pci@0000:03:00.0 logical name: wlp3s0 version: 00 serial: cc:af:78:40:61:cc width: 32 bits clock: 33MHz capabilities: bus_master cap_list ethernet physical wireless configuration: broadcast=yes driver=rt2800pci driverversion=4.4.0-31-generic firmware=0.34 ip=192.168.2.31 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn resources: irq:18 memory:e0100000-e010ffff WARNING: output may be incomplete or inaccurate, you should run this program as super-user.

BlackBox:~$ iwconfig
Code: [Select]
lo no wireless extensions.

enp2s0 no wireless extensions.

wlp3s0 IEEE 802.11bgn ESSID:"GET OFF MY LAN!!!"
Mode:Managed Frequency:2.462 GHz Access Point: 90:72:82:FE:49:06
Bit Rate=39 Mb/s Tx-Power=20 dBm
Retry short limit:7 RTS thr:off Fragment thr:off Power Management:on Link Quality=70/70 Signal level=-35 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0 Tx excessive retries:86 Invalid misc:1625 Missed beacon:0

« Last Edit: February 27, 2017, 11:26:47 pm by matt_mccarron »

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 17312
  • Karma: 439
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: 16.04 MATE fresh install WIFI extremely slow
« Reply #1 on: February 11, 2017, 07:35:34 pm »
What's the output from:
Code: [Select]
iwlist scan
and please don't post the output as a block of text like above .. nobody's going to go through that.rough that

Post it how it is returned in the terminal and surround it with CODE tags, as in
(code)text goes here(/code)

except replace the () with []
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline matt_mccarron

  • Jr. Member
  • **
  • Posts: 11
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: 16.04 MATE fresh install WIFI extremely slow
« Reply #2 on: February 11, 2017, 07:58:25 pm »
Code: [Select]
lo        Interface doesn't support scanning.

enp2s0    Interface doesn't support scanning.

wlp3s0    Scan completed :
          Cell 01 - Address: 90:72:82:FE:49:06
                    Channel:11
                    Frequency:2.462 GHz (Channel 11)
                    Quality=67/70  Signal level=-43 dBm 
                    Encryption key:on
                    ESSID:"GET OFF MY LAN!!!"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s
                    Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master
                    Extra:tsf=0000017ede2f5042
                    Extra: Last beacon: 53064ms ago
                    IE: Unknown: 0011474554204F4646204D59204C414E212121
                    IE: Unknown: 010882848B960C121824
                    IE: Unknown: 03010B
                    IE: Unknown: 0706434120010B1E
                    IE: Unknown: 2A0100
                    IE: Unknown: 32043048606C
                    IE: Unknown: 2D1AAD011BFFFFFF0000000000000000000100000000000000000000
                    IE: Unknown: 3D160B080400000000000000000000000000000000000000
                    IE: Unknown: 4A0E14000A002C01C800140005001900
                    IE: Unknown: 7F080100000000000040
                    IE: Unknown: DD180050F2020101800003A4000027A4000042435E0062322F00
                    IE: Unknown: DD0900037F01010000FF7F
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK
                    IE: Unknown: DDA70050F204104A0001101044000102103B00010310470010D044986996F453EA810E89CCE5E9706C10210008536167656D636F6D10230011536167656D636F6D353235305F42656C6C1024000D3235333535353138372D312E301042000F4E51533136313237363030353234331054000800060050F204000110110016536167656D636F6D353235305F42656C6C2D4E515331100800020000103C0001011049000600372A000120

Offline matt_mccarron

  • Jr. Member
  • **
  • Posts: 11
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: 16.04 MATE fresh install WIFI extremely slow
« Reply #3 on: February 11, 2017, 07:59:26 pm »
thanks for telling me how to do that.

i was getting grief from other forum moderators.  code tags have been added to OP
« Last Edit: February 11, 2017, 08:02:19 pm by matt_mccarron »

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 17312
  • Karma: 439
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: 16.04 MATE fresh install WIFI extremely slow
« Reply #4 on: February 11, 2017, 08:29:39 pm »
Have you tried changing wireless channel in the router to say 6 ?
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline matt_mccarron

  • Jr. Member
  • **
  • Posts: 11
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: 16.04 MATE fresh install WIFI extremely slow
« Reply #5 on: February 11, 2017, 08:52:25 pm »
i'm looking into how to do that now.

it was not first guess, as the problem seemed driver related as it only occurred immediately after a new OS installation.

Offline matt_mccarron

  • Jr. Member
  • **
  • Posts: 11
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: 16.04 MATE fresh install WIFI extremely slow
« Reply #6 on: February 11, 2017, 09:05:38 pm »
Hi Mark Greaves

First of all, thanks for taking the time to help me.  People like you are why I love Linux.

So, I changed to channel 6 and the speed bumped up from 7.4 Mbps (with Ipv6 set to IGNORE, I think that this change won't survive a reboot, but i'm not sure (selecting ignore bumped my speed from .47 to 7.4)) to now over 20 Mbps.

Should I put the IPv6 back to auto?

Speedtest is showing downloads over 50 Mbps on the LAN desktop, just by comparison.

Offline matt_mccarron

  • Jr. Member
  • **
  • Posts: 11
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: 16.04 MATE fresh install WIFI extremely slow
« Reply #7 on: February 11, 2017, 09:20:42 pm »
Well,

I rebooted, and went back to .46 dnld speed.
Changed IPv6 back to automatic, got 7Mbps...

Now i'm back to totally terrible download speeds.
Yeah, i don't know what I did, but i'm getting 0.4 Mbps download again...
 
another iwlist scan:
Code: [Select]
lo        Interface doesn't support scanning.

enp2s0    Interface doesn't support scanning.

wlp3s0    Scan completed :
          Cell 01 - Address: 90:72:82:FE:49:06
                    Channel:6
                    Frequency:2.437 GHz (Channel 6)
                    Quality=70/70  Signal level=-33 dBm 
                    Encryption key:on
                    ESSID:"GET OFF MY LAN!!!"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s
                    Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master
                    Extra:tsf=00000000841b9952
                    Extra: Last beacon: 46232ms ago
                    IE: Unknown: 0011474554204F4646204D59204C414E212121
                    IE: Unknown: 010882848B960C121824
                    IE: Unknown: 030106
                    IE: Unknown: 0706434120010B1E
                    IE: Unknown: 2A0100
                    IE: Unknown: 32043048606C
                    IE: Unknown: 2D1AAD011BFFFFFF0000000000000000000100000000000000000000
                    IE: Unknown: 3D1606080400000000000000000000000000000000000000
                    IE: Unknown: 4A0E14000A002C01C800140005001900
                    IE: Unknown: 7F080100000000000040
                    IE: Unknown: DD180050F2020101800003A4000027A4000042435E0062322F00
                    IE: Unknown: DD0900037F01010000FF7F
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK
                    IE: Unknown: DDA70050F204104A0001101044000102103B00010310470010D044986996F453EA810E89CCE5E9706C10210008536167656D636F6D10230011536167656D636F6D353235305F42656C6C1024000D3235333535353138372D312E301042000F4E51533136313237363030353234331054000800060050F204000110110016536167656D636F6D353235305F42656C6C2D4E515331100800020000103C0001011049000600372A000120
« Last Edit: February 11, 2017, 09:37:57 pm by matt_mccarron »

Offline matt_mccarron

  • Jr. Member
  • **
  • Posts: 11
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: 16.04 MATE fresh install WIFI extremely slow
« Reply #8 on: February 12, 2017, 10:28:04 pm »
So, i'm in a hotel using their wifi, and the same problem.  Non-existent wifi, it's so slow.

Edit connections, "Ignore" iPv6, and boom, 10Mbps download.

Not super fast, but fast enough to write and post this message.

Any ideas, anyone?

Should I just reinstall a different flavour of linux?  Could this be a driver issue?


Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 17312
  • Karma: 439
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: 16.04 MATE fresh install WIFI extremely slow
« Reply #9 on: February 14, 2017, 01:24:44 am »
You could try, but you're gonna get the same driver ;)

If you can give me a couple of days I'll see what I can dig up, just stupid busy ATM .. meanwhile have you got a USB wireless adapter you can use ?
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline matt_mccarron

  • Jr. Member
  • **
  • Posts: 11
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: 16.04 MATE fresh install WIFI extremely slow
« Reply #10 on: February 16, 2017, 03:18:44 am »
No, Mark, it's not a really essential laptop, I'm in Montreal for 2 weeks, until I get home, and this speed is actually suitable for the hotel WIFI, it will stream video, so it's not that slow.

You think if I put linux Mint back on it I will have the same problem? 

I just happen to like Ubuntu MATE, but it's not critical that I keep it.  I should probably put Lubuntu or something elso really lightweight...

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 17312
  • Karma: 439
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: 16.04 MATE fresh install WIFI extremely slow
« Reply #11 on: February 16, 2017, 02:54:05 pm »
If you're using Ubuntu 16.04 it will have EXACTLY the same drivers as Mint 18 .. so theoretically there should be no difference as far as wireless goes.

I say "theoretically" because I've seen differences before where there should be non .. eg. Wireless not working in say Mint 18 but working perfectly in Peppermint on the same hardware .. this shouldn't happen because they both use the same kernel, and yet occasionally it does.

This is the world of computing .. weird s**t happens sometimes ;)

Quote
I should probably put Lubuntu or something elso really lightweight...

Maybe try Peppermint 7 ;)
« Last Edit: February 16, 2017, 02:55:40 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline matt_mccarron

  • Jr. Member
  • **
  • Posts: 11
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: 16.04 MATE fresh install WIFI extremely slow
« Reply #12 on: February 16, 2017, 11:28:53 pm »
Ok,

I'll give Peppermint a go.

I take it you are (one of) the developer(s)?

I'll post back with the results of the install with respect to WIFI speeds.  Just have to find a USB drive or blank DVD somewhere...

Thanks

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 17312
  • Karma: 439
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: 16.04 MATE fresh install WIFI extremely slow
« Reply #13 on: February 18, 2017, 08:53:23 pm »
I take it you are (one of) the developer(s)?

Who me ? .. good gracious no .. well okay a little bit, you got me :)
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline matt_mccarron2

  • Jr. Member
  • **
  • Posts: 6
  • Karma: 1
  • I've just joined!
    • View Profile
    • Awards
Re: 16.04 MATE fresh install WIFI extremely slow
« Reply #14 on: February 27, 2017, 11:11:45 pm »
don't know why i couldn't log back into my last registered account... but anyway, Mr. Greaves, I'm writing from my laptop with Peppermint freshly installed.

It's a slick OS, but i'm still having shit WIFI speeds...

the wired speeds a wicked fast, but the browser is still very slow despite wired download speeds of 164 mbps...

I'm currently doing the apt-get update... taking forever.  had to plug into LAN as wifi was giving me .46 mbps from speedtest.net

I obviously need help.  beginning to suspect hardware...

 


SimplePortal 2.3.3 © 2008-2010, SimplePortal