Author Topic: CUPS not running - [SOLVED]  (Read 63536 times)

0 Members and 1 Guest are viewing this topic.

Offline Keith

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1355
  • Karma: 20
  • Gender: Male
  • Linux Novice
    • View Profile
    • Awards
CUPS not running - [SOLVED]
« on: September 19, 2017, 07:40:24 pm »
I am running Ubuntu 16.04 on a Thinkpad T500. 
When attempting to print to my HP 7610 it didn't appear on the printer list so I checked System-Settings/Printers but there was nothing listed and the Add button was greyed out.  Clicking on Help/Troubleshooting produced the message:
CUPS Service Stopped The CUPS print spooler does not appear to be running. To correct this, choose System->Administration->Services from the main menu and look for the 'cups' service. 
However, I see no Administration->Services option.

Browsing the web I found several other queries about this problem and tried a couple of the suggested solutions:
[email protected]:~$ sudo /etc/init.d/cups start
[sudo] password for keith:
[email protected]:~$ sudo service cups restart
Failed to restart cups.service: Unit cups.service is masked.

But all to no effect.
I tried visiting http://localhost:631/printers/ but it wasn't available. 

I have made no changes to the system other than the usual updates, and would be very grateful for suggestions. 
« Last Edit: September 21, 2017, 07:31:21 pm by Keith »

Offline Mark Greaves (PCNetSpec)

  • Hero Member
  • *****
  • Posts: 18277
  • Karma: 479
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • Awards
Re: CUPS not running
« Reply #1 on: September 19, 2017, 11:42:18 pm »
Try unmasking the service:
Code: [Select]
service unmask cups.service
then start the cups service with
Code: [Select]
service cups start



If that still doesn't work, try
Code: [Select]
sudo apt-get install --reinstall cups cups-browsed cups-client cups-common cups-daemon cups-server-common
then:
Code: [Select]
sudo systemctl daemon-reload



If that still doesn't work, post the output from:
Code: [Select]
service cups status
and:
Code: [Select]
file /lib/systemd/system/cups.service
« Last Edit: September 20, 2017, 12:15:37 am by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

The Linux Community Forum

Re: CUPS not running
« Reply #1 on: September 19, 2017, 11:42:18 pm »

Offline Keith

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1355
  • Karma: 20
  • Gender: Male
  • Linux Novice
    • View Profile
    • Awards
Re: CUPS not running
« Reply #2 on: September 20, 2017, 05:40:00 pm »
Thank you, Mark.  Here is the output....

[email protected]:~$ service unmask cups.service
unmask: unrecognized service
[email protected]:~$ service cups start
Job for cups.socket failed. See "systemctl status cups.socket" and "journalctl -xe" for details.
[email protected]:~$
--------------------------------------------------------------------
[email protected]:~$ sudo apt-get install --reinstall cups cups-browsed cups-client cups-common cups-daemon cups-server-common
[sudo] password for keith:
Reading package lists... Done
Building dependency tree       
.
.
.
Setting up cups-client (2.1.3-4ubuntu0.3) ...
Setting up cups (2.1.3-4ubuntu0.3) ...
Updating PPD files for cups ...
[email protected]:~$ sudo systemctl daemon-reload
[email protected]:~$
--------------------------------------------------------------------
Then I tried: 
System-settings/printers:  Tried to print test page but:
Printer state:  “Idle - File "/usr/lib/cups/filter/hpcups" not available: No such file or directory”
----------------------------------------------------------------------

[email protected]:~$ service cups status
? cups.service - CUPS Scheduler
   Loaded: loaded (/lib/systemd/system/cups.service; enabled; vendor preset: enabled)
   Active: active (running) since Wed 2017-09-20 17:25:29 BST; 8min ago
     Docs: man:cupsd(8)
 Main PID: 8930 (cupsd)
   CGroup: /system.slice/cups.service
           ??8930 /usr/sbin/cupsd -l
           ??9361 /usr/lib/cups/notifier/dbus dbus://

Sep 20 17:25:29 T500 systemd[1]: Started CUPS Scheduler.
Sep 20 17:25:31 T500 systemd[1]: Started CUPS Scheduler.
Sep 20 17:25:31 T500 systemd[1]: Started CUPS Scheduler.
Sep 20 17:25:52 T500 systemd[1]: Started CUPS Scheduler.
[email protected]:~$ file /lib/systemd/system/cups.service
/lib/systemd/system/cups.service: ASCII text
[email protected]:~$
-----------------------------------------------------------------
Is the missing file /usr/lib/cups/filter/hpcups the problem? 

Offline Mark Greaves (PCNetSpec)

  • Hero Member
  • *****
  • Posts: 18277
  • Karma: 479
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • Awards
Re: CUPS not running
« Reply #3 on: September 20, 2017, 05:45:33 pm »
Try:
Code: [Select]
sudo apt-get install --reinstall printer-driver-hpcups



But really I don't understand why you're not just using hplip-gui to install your HP printer:
Code: [Select]
sudo apt-get install hplip-gui
Then look for the HPLIP Toolbox in your menu.
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline Keith

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1355
  • Karma: 20
  • Gender: Male
  • Linux Novice
    • View Profile
    • Awards
Re: CUPS not running
« Reply #4 on: September 20, 2017, 09:11:51 pm »
sudo apt-get install --reinstall printer-driver-hpcups  had no effect but your comment re hplip GUI caused me to check that it was still installed - which of course it wasn't since my catastrophic computer crash a while ago, when I clearly had forgotten to re-install it, although the printer has been working flawlessly up to yesterday.  It's interesting, though, that that last command didn't supply the missing file. 

I've installed HPLIP it now and all is well.  Very many thanks for your advice, Mark.  As usual!
  Keith

The Linux Community Forum

Re: CUPS not running
« Reply #4 on: September 20, 2017, 09:11:51 pm »

Offline Mark Greaves (PCNetSpec)

  • Hero Member
  • *****
  • Posts: 18277
  • Karma: 479
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • Awards
Re: CUPS not running
« Reply #5 on: September 21, 2017, 12:08:30 am »
No problem my mate :)
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline Ph3arr3t

  • Jr. Member
  • **
  • Posts: 2
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: CUPS not running - [SOLVED]
« Reply #6 on: June 06, 2019, 03:26:01 pm »
My issue seems to be a tad different..
using mint tara
hp dj 3634
printer was working about 1 month ago, then cups updated to 2.0.0 from 1.7x
now cups won't start, hplip doesn't think cups is even installed so it fails.
tried updating hplip to newest as of post time, still same issue.

$ service cups status
? cups.service - CUPS Scheduler
   Loaded: loaded (/lib/systemd/system/cups.service; enabled; vendor preset: ena
   Active: failed (Result: start-limit-hit) since Thu 2019-06-06 10:01:29 EDT; 1
     Docs: man:cupsd(8)
  Process: 14953 ExecStart=/usr/sbin/cupsd -l (code=killed, signal=TERM)
 Main PID: 14953 (code=killed, signal=TERM)

Jun 06 10:01:29 ph3arr3tus systemd[1]: cups.service: Service hold-off time over,
Jun 06 10:01:29 ph3arr3tus systemd[1]: cups.service: Scheduled restart job, rest
Jun 06 10:01:29 ph3arr3tus systemd[1]: Stopped CUPS Scheduler.
Jun 06 10:01:29 ph3arr3tus systemd[1]: cups.service: Start request repeated too
Jun 06 10:01:29 ph3arr3tus systemd[1]: cups.service: Failed with result 'start-l
Jun 06 10:01:29 ph3arr3tus systemd[1]: Failed to start CUPS Scheduler.

$ file /lib/systemd/system/cups.service
[Unit]
Description=CUPS Scheduler
Documentation=man:cupsd(8)
After=sssd.service

[Service]
ExecStart=/usr/sbin/cupsd -l
Type=simple
Restart=always

[Install]
Also=cups.socket cups.path
WantedBy=printer.target

Offline Mark Greaves (PCNetSpec)

  • Hero Member
  • *****
  • Posts: 18277
  • Karma: 479
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • Awards
Re: CUPS not running - [SOLVED]
« Reply #7 on: June 07, 2019, 02:44:26 pm »
do you get any output from
Code: [Select]
ps aux | grep [c]upsd
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline Ph3arr3t

  • Jr. Member
  • **
  • Posts: 2
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: CUPS not running - [SOLVED]
« Reply #8 on: February 21, 2021, 02:43:54 am »
Sorry about the delay, thanks for getting back to me, I finally was able to log into this site after finding password.. and still having same issue.
output is "root       795  0.1  0.0 103376  9116 ?        Ss   21:33   0:00 /usr/sbin/cupsd -l "

 as a side note if relevant
Mint sees the Canon Pixma TS3320 printer as Device URI: usb://Canon/TS3300%20series?serial=9354
Knoppix sees it as Dev URl - usb://Canon/TS3300%20series?serial=935489&interface=1
printer does work in Knoppix

Actually got back in.. changed printer url to knoppix settings & works again for now, now for the scanner...
that problem stems from something about libc6 needs a major version update...
« Last Edit: February 21, 2021, 03:37:22 am by Ph3arr3t »

The Linux Community Forum

Re: CUPS not running - [SOLVED]
« Reply #8 on: February 21, 2021, 02:43:54 am »

Offline Keith

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1355
  • Karma: 20
  • Gender: Male
  • Linux Novice
    • View Profile
    • Awards
Re: CUPS not running - [SOLVED]
« Reply #9 on: February 21, 2021, 10:20:01 am »
I'm sorry to tell you that Mark died about a year ago.  But we're glad that you have resolved at least part of your difficulties. 

Keith

 


SimplePortal 2.3.3 © 2008-2010, SimplePortal