Author Topic: HDMI quandry  (Read 3332 times)

0 Members and 3 Guests are viewing this topic.

Offline wishbone

  • Jr. Member
  • **
  • Posts: 43
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
HDMI quandry
« on: November 29, 2017, 08:31:00 pm »
Hi all,
I have just downloaded the latest Mint Cinnamon and installed it onto a USB stick using unetbootin.

When I plug the HDMI cable into my PC I lose all my desktop icons and no menu bar at the bottom of the screen on the TV. I just see the desktop background & the Mint logo. The laptop screen is OK.

I am puzzled as to why this is happening. Any help would be appreciated. Peppermint, which is installed on the PC works fine.

Is the following of any use to help.

mint@mint ~ $ inxi -Fx
System:    Host: mint Kernel: 4.10.0-38-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.6 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.3 Sylvia
Machine:   System: TOSHIBA (portable) product: SATELLITE PRO L850-1DP v: PSKDHE-00H004EN
           Mobo: Type2 - Board Vendor Name1 model: Type2 - Board Product Name1 v: Type2 - Board Version
           Bios: Insyde v: 6.10 date: 09/24/2012
CPU:       Dual core Intel Core i3-2328M (-HT-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 8779
           clock speeds: max: 2200 MHz 1: 799 MHz 2: 800 MHz 3: 799 MHz
           4: 799 MHz
Graphics:  Card: Intel 2nd Generation Core Processor Family Integrated Graphics Controller
           bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.04hz, 1360x768@60.37hz
           GLX Renderer: Mesa DRI Intel Sandybridge Mobile
           GLX Version: 3.0 Mesa 17.0.7 Direct Rendering: Yes
Audio:     Card Intel 7 Series/C210 Series Family High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.10.0-38-generic
Network:   Card-1: Qualcomm Atheros AR9462 Wireless Network Adapter
           driver: ath9k bus-ID: 02:00.0
           IF: wlp2s0 state: down mac: 20:68:9d:14:69:6f
           Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: 2000 bus-ID: 03:00.0
           IF: enp3s0 state: down mac: 4c:72:b9:9c:66:9a
Drives:    HDD Total Size: 782.2GB (6.5% used)
           ID-1: /dev/sda model: TOSHIBA_MQ01ABD0 size: 750.2GB temp: 20C
           ID-2: USB /dev/sdb model: USB_Flash_Drive size: 32.0GB temp: 0C
Partition: ID-1: swap-1 size: 7.50GB used: 0.00GB (0%) fs: swap dev: /dev/sda6
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 39.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 215 Uptime: 4 min Memory: 558.4/5854.8MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35


mint@mint ~ $ xrandr
Screen 0: minimum 8 x 8, current 2726 x 768, maximum 32767 x 32767
LVDS1 connected primary 1366x768+0+0 (normal left inverted right x axis y axis) 344mm x 193mm
   1366x768      60.04*+
   1360x768      59.80    59.96 
   1280x720      60.00 
   1024x768      60.00 
   1024x576      60.00 
   960x540       60.00 
   800x600       60.32    56.25 
   864x486       60.00 
   640x480       59.94 
   720x405       60.00 
   680x384       60.00 
   640x360       60.00 
DP1 disconnected (normal left inverted right x axis y axis)
HDMI1 connected 1360x768+1366+0 (normal left inverted right x axis y axis) 1600mm x 900mm
   1360x768      60.37*+
   1920x1080     60.00    50.00    59.94 
   1920x1080i    60.00    60.00    50.00    59.94 
   1280x1024     60.02 
   1280x720      60.61    60.00    50.00    59.94 
   1024x768      60.00 
   800x600       60.32 
   720x576       50.00 
   720x576i      50.00 
   720x480       60.00    59.94 
   720x480i      60.00    59.94 
   640x480       60.00    59.94 
VGA1 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)

Thank you.

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 17351
  • Karma: 442
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: HDMI quandry
« Reply #1 on: November 29, 2017, 10:29:54 pm »
Whilst I'm not well versed with Mint I think this is normal because you haven't added either any icons or a panel to the second desktop yet.

It would only display the icons and panel if it were set to MIRROR the laptop screen .. you've likely got it set as NEXT TO the laptop screen, so it's really a second desktop that's currently empty.

When you move the mouse past the edge of the laptop screen, does it move to the second screen ? .. or is the mouse cursor on both ?
« Last Edit: November 29, 2017, 10:32:24 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline wishbone

  • Jr. Member
  • **
  • Posts: 43
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: HDMI quandry
« Reply #2 on: November 30, 2017, 09:30:03 am »
Thanks for the reply Mark.

Yes, it does move to the second screen from the first one, but to get the icons on the second screen I have to change the desktop to "show icons on non-primary monitor only". The menu bar still isn`t there, but the icons are. If I choose to show icons on all monitors then they disappear off the second screen again.

I think I`ll give it a miss and stick with Peppermint which is doing the job as it`s meant to.

Thanks again Mark.

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 17351
  • Karma: 442
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: HDMI quandry
« Reply #3 on: November 30, 2017, 02:11:58 pm »
Any idea which version of the Nemo file manager Mint 18.3 uses ?

I'm asking because we're updating Nemo in the Peppermint 8 respin so it'd be handy to know if I need to check if this'll affect us too.

.
« Last Edit: November 30, 2017, 02:14:32 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline wishbone

  • Jr. Member
  • **
  • Posts: 43
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: HDMI quandry
« Reply #4 on: November 30, 2017, 07:26:16 pm »
Hi Mark,

Nemo is 3.6.4 in Mint 18.3.

Hope this helps.

This problem was the same in 18 also 17.2.

Peppermint 7 works OK, no problem at all. When is the respin due?

All the best
Tony

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 17351
  • Karma: 442
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: HDMI quandry
« Reply #5 on: November 30, 2017, 09:49:13 pm »
Hopefully a week or so, but it could still get postponed if anything comes up during the final week of testing .. we release only when it's deemed "ready" ;)

This problem was the same in 18 also 17.2.

Hopefully we'll be okay then as it now seems less likely it's a nemo issue .. PM7 and 8 used a more recent version of nemo that 17.2 :)
« Last Edit: November 30, 2017, 09:54:24 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

 


SimplePortal 2.3.3 © 2008-2010, SimplePortal