Author Topic: Very slow boot Mint 19 Mate  (Read 3482 times)

0 Members and 1 Guest are viewing this topic.

Offline mikeg

  • Jr. Member
  • **
  • Posts: 6
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Very slow boot Mint 19 Mate
« on: August 20, 2018, 03:35:15 pm »
Greetings all.
I have an oldish Acer laptop which I use as a backup when my other machines fail me.  It started life with Windows Vista and has had a number of Mint versions dropped in.  The Windows dual boot was broken during an earlier Mint update but Mint continued to run OK. As I was starting to get out of space warnings, I eventually decided to upgrade to Mint 19 (Mate, because of the machine´s age) as the sole operating system, with everything else wiped.  It seemed to go alright, but it now takes an age to boot up. Having read several other posts on similar subjects, I´ve uploaded the following files and hope some kind person will be able to help me improve things (the ´mg´ at the beginning of these files is simply my initials).  I´m pretty much a Linux novice, as you may have guessed.

Thanks in advance.
« Last Edit: August 20, 2018, 03:47:47 pm by Mark Greaves (PCNetSpec) »

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 18148
  • Karma: 473
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Very slow boot Mint 19 Mate
« Reply #1 on: August 20, 2018, 03:49:21 pm »
Can you upload those files to a service that doesn't require people to enter their email address please .. such as:
http://www.tinyupload.com/
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk


Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 18148
  • Karma: 473
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Very slow boot Mint 19 Mate
« Reply #3 on: August 20, 2018, 09:31:44 pm »
For clarity, here's the contents of the files

Code: [Select]
systemd-analyze blame:

         12.008s systemd-journal-flush.service
         10.898s dev-mapper-mint\x2d\x2dvg\x2droot.device
          8.885s lvm2-monitor.service
          8.014s systemd-tmpfiles-setup-dev.service
          7.281s systemd-sysctl.service
          5.526s networkd-dispatcher.service
          4.792s udisks2.service
          4.723s NetworkManager.service
          4.586s ubuntu-system-adjustments.service
          4.059s ModemManager.service
          4.009s accounts-daemon.service
          3.147s thermald.service
          2.991s grub-common.service
          2.198s keyboard-setup.service
          1.860s polkit.service
          1.777s wpa_supplicant.service
          1.726s systemd-modules-load.service
          1.517s rsyslog.service
          1.466s lightdm.service
          1.463s plymouth-quit-wait.service
          1.260s lvm2-pvscan@8:1.service
          1.228s avahi-daemon.service
          1.106s bluetooth.service
          1.082s systemd-random-seed.service
          1.075s networking.service
          1.071s apport.service
           965ms apparmor.service
           771ms systemd-tmpfiles-setup.service
           762ms lm-sensors.service
           745ms kerneloops.service
           709ms systemd-udevd.service
           678ms dev-hugepages.mount
           632ms dns-clean.service
           628ms systemd-remount-fs.service
           597ms sys-kernel-debug.mount
           591ms gpu-manager.service
           590ms dev-mqueue.mount
           567ms systemd-logind.service
           543ms systemd-resolved.service
           397ms geoclue.service
           386ms upower.service
           333ms systemd-journald.service
           325ms packagekit.service
           302ms systemd-rfkill.service
           295ms rtkit-daemon.service
           288ms setvtrgb.service
           272ms kmod-static-nodes.service
           234ms blk-availability.service
           229ms ntp.service
           197ms dev-mapper-mint\x2d\x2dvg\x2dswap_1.swap
           181ms user@1000.service
           179ms systemd-timesyncd.service
           162ms hddtemp.service
           150ms systemd-update-utmp-runlevel.service
           147ms speech-dispatcher.service
           133ms systemd-udev-trigger.service
           105ms systemd-tmpfiles-clean.service
            94ms motd-news.service
            85ms systemd-update-utmp.service
            34ms ufw.service
            22ms alsa-restore.service
            19ms pppd-dns.service
            16ms ureadahead-stop.service
            16ms plymouth-start.service
            16ms openvpn.service
            13ms systemd-user-sessions.service
            12ms plymouth-read-write.service
            10ms systemd-backlight@backlight:acpi_video0.service
             7ms console-setup.service
             7ms sys-fs-fuse-connections.mount
             3ms sys-kernel-config.mount
Code: [Select]
systemd-analyze critical-chain:

The time after the unit is active or started is printed after the "@" character.
The time the unit takes to start is printed after the "+" character.

graphical.target @23.815s
??multi-user.target @23.815s
  ??getty.target @23.815s
    ??getty@tty1.service @23.814s
      ??system-getty.slice @23.813s
        ??setvtrgb.service @23.524s +288ms
          ??systemd-user-sessions.service @22.034s +13ms
            ??network.target @22.026s
              ??NetworkManager.service @17.302s +4.723s
                ??dbus.service @17.068s
                  ??basic.target @17.067s
                    ??sockets.target @17.067s
                      ??cups.socket @17.067s
                        ??sysinit.target @17.044s
                          ??systemd-timesyncd.service @16.865s +179ms
                            ??systemd-tmpfiles-setup.service @16.078s +771ms
                              ??systemd-journal-flush.service @4.067s +12.008s
                                ??systemd-remount-fs.service @3.436s +628ms
                                  ??systemd-journald.socket @3.357s
                                    ??system.slice @3.355s
                                      ??-.slice @3.340s
Code: [Select]
blkid:

/dev/sda1: UUID="tC64N9-pkWV-oQ2c-55Qb-xzvh-BcUy-wH5536" TYPE="LVM2_member" PARTUUID="12a0df2d-01"
/dev/mapper/mint--vg-root: UUID="b1318e92-ec1c-4b24-afa7-3e2a36829efd" TYPE="ext4"
/dev/mapper/mint--vg-swap_1: UUID="d49ba2e3-4b49-41dc-9b34-586150dfa505" TYPE="swap"
Code: [Select]
fstab:

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
/dev/mapper/mint--vg-root /               ext4    errors=remount-ro 0       1
/dev/mapper/mint--vg-swap_1 none            swap    sw              0       0
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 18148
  • Karma: 473
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Very slow boot Mint 19 Mate
« Reply #4 on: August 20, 2018, 09:34:15 pm »
How much customisation have you done ? .. are you up for reinstalling, but this time don't select LVM (or encryption) during the install.
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline mikeg

  • Jr. Member
  • **
  • Posts: 6
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Very slow boot Mint 19 Mate
« Reply #5 on: August 21, 2018, 08:23:02 am »
Having done no customisation, I´m happy to reinstall.  However, I don´t recall selecting encryption last time.

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 18148
  • Karma: 473
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Very slow boot Mint 19 Mate
« Reply #6 on: August 21, 2018, 10:23:20 am »
First I'd try a reinstall without LVM, then if you're still having a slow boot please post the output from:
Code: [Select]
sudo dmesg | grep -i "error\|warn\|fail"
or even better, run:
Code: [Select]
dmesg > ~/Desktop/dmesg.txt
then upload the dmesg.txt file on your desktop to:-
http://www.tinyupload.com/
and provide a link.
« Last Edit: August 21, 2018, 10:25:10 am by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline mikeg

  • Jr. Member
  • **
  • Posts: 6
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Very slow boot Mint 19 Mate
« Reply #7 on: August 21, 2018, 09:53:40 pm »
Well, I reinstalled as per yours, from a new download, just in case.  If anything, boot seems even slower.  I also note that shut down is slow, preceded by a display of code.

Anyhow, here´s the link:

http://s000.tinyupload.com/index.php?file_id=18830689849083894275

Thanks for your patience and assistence.

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 18148
  • Karma: 473
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Very slow boot Mint 19 Mate
« Reply #8 on: August 22, 2018, 02:20:33 am »
Your dmesg output contains a lot of instances of:-

Quote
<timestamp>] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [CRTC:41:pipe B] flip_done timed out

followed by a call trace listing

This appears to be a regression in the 4.15 kernel series (intel video drivers), the workaround is to disable the SVIDEO-1 port (which you're unlikely to be using anyway) at the kernel level at boot time.

Try this...

Open a terminal and run:
Code: [Select]
sudo pluma /etc/default/grub
Look for the line that contains "quiet splash" and add the kernel boot parameter video=SVIDEO-1:d (after splash, but still inside the quotation marks).

so that line now reads something like:
Code: [Select]
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash video=SVIDEO-1:d"
SAVE the file and exit the text editor.

Back in the terminal run:
Code: [Select]
sudo update-grub
Now reboot to test.
« Last Edit: August 22, 2018, 09:08:42 am by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline mikeg

  • Jr. Member
  • **
  • Posts: 6
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Very slow boot Mint 19 Mate
« Reply #9 on: August 22, 2018, 04:34:38 pm »
That seems to have cracked it.

After 'pluma' was not recognised, I found out that the new text editor is 'xed' and used that to add the code you suggested. Previously the elapsed time was 379.830069 (excluding the last line resetting USB 1).  Now the total time is 45.528331, which would be much shorter but for a series of events at the end involving Bluetooth and IPv6. If you'd care to look at this, the link to the new dmesg file is http://s000.tinyupload.com/?file_id=00522869324592571317

Thanks again  :D

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 18148
  • Karma: 473
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Very slow boot Mint 19 Mate
« Reply #10 on: August 23, 2018, 01:21:41 am »
You could disable IPv6 in network manager (and bluetooth in the BIOS if you don't use it) .. but I doubt either of those are actually slowing the desktop from coming up, so I doubt you'd notice any difference.



Oddly when I first typed the instructions I originally used "xed" in that command (which is the default Cinnamon text editor) .. then I noticed you're using MATE who's default text editor is **usually** pluma, so I changed it .. Mint must use the non-default "xed" even in their MATE DE version (as do we at Peppermint) :)
« Last Edit: August 23, 2018, 01:27:46 am by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline mikeg

  • Jr. Member
  • **
  • Posts: 6
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Very slow boot Mint 19 Mate
« Reply #11 on: August 23, 2018, 08:09:54 am »
Time to leave it alone, I think. It's already a massive improvement, for which I thank you. I've now committed 2 out of three laptops in our house completely to Mint - the other is on 64 bit Cinnamon - and hope to learn a little more about the innards of the system.

Best wishes

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 18148
  • Karma: 473
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Very slow boot Mint 19 Mate
« Reply #12 on: August 23, 2018, 02:26:55 pm »
No worries mikeg, give us a shout if you have any questions .. that's what the forum is for :)
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

 


SimplePortal 2.3.3 © 2008-2010, SimplePortal