Author Topic: Starting maximised (SOLVED)  (Read 1516 times)

0 Members and 1 Guest are viewing this topic.

Offline Zorba61

  • Jr. Member
  • **
  • Posts: 97
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Starting maximised (SOLVED)
« on: September 10, 2018, 09:49:44 am »
Hello everybody,
I'm new to Linux and hoping to make the switch from Windows and currently duel booting w8 pro with Mint cinnamon and so far I like the look of it.The first problem i've encounted  is that Opera browser won't open maximised unless I leave it maximised when closing it and then it has to open on the last page I was on.
I know it can be done but being a complete novice I need to be talked through the whole process of opening the terminal and inserting/editing command lines.
Can anybody help?
thanks.
« Last Edit: September 12, 2018, 06:13:34 am by Zorba61 »

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 18268
  • Karma: 477
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Starting maximised
« Reply #1 on: September 10, 2018, 02:54:51 pm »
Does running this in a terminal
Code: [Select]
opera --start-maximized
start Opera maximised ?

Note the American spelling of maximized in the command .. NOT the British maximised.
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline Zorba61

  • Jr. Member
  • **
  • Posts: 97
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Starting maximised
« Reply #2 on: September 10, 2018, 04:35:00 pm »
Thanks for speedy reply.
Yes it does open it maximised.

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 18268
  • Karma: 477
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Starting maximised
« Reply #3 on: September 11, 2018, 12:12:35 am »
Well theoretically you could edit the launcher(s) for Opera so the "Exec=" line reads
Code: [Select]
Exec=opera --start-maximized %U
instead of the default
Code: [Select]
Exec=opera %U
If you don't know how to do this, just ask :)



[EDIT]

Open a terminal and run:
Code: [Select]
sudo xed /usr/share/applications/opera.desktop
when the text editor opens, find the 3 lines
Code: [Select]
Exec=opera %U
and
Code: [Select]
Exec=opera --new-window
and
Code: [Select]
Exec=opera --private
and change them so they now read:-
Code: [Select]
Exec=opera --start-maximized %U
and
Code: [Select]
Exec=opera --new-window --start-maximized
and
Code: [Select]
Exec=opera --private --start-maximized
SAVE the file.

Now try launching Opera from the main menu .. did it start maximised ?
« Last Edit: September 11, 2018, 12:19:46 am by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline Zorba61

  • Jr. Member
  • **
  • Posts: 97
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Starting maximised
« Reply #4 on: September 11, 2018, 07:49:12 am »
Thanks for your efforts ....no it didn't open maximised so rechecked and noticed when I save it I get this message in terminal.....


** (xed:10371): WARNING **: 07:47:13.828: Set document metadata failed: Setting attribute metadata::xed-spell-language not supported

** (xed:10371): WARNING **: 07:47:13.828: Set document metadata failed: Setting attribute metadata::xed-encoding not supported

I am saving it but should I be using 'save as'?
« Last Edit: September 11, 2018, 12:11:29 pm by Zorba61 »

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 18268
  • Karma: 477
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Starting maximised
« Reply #5 on: September 11, 2018, 12:30:30 pm »
Run
Code: [Select]
xed /usr/share/applications/opera.desktop
and post the contents here.

also post any output from:
Code: [Select]
ls -a ~/.local/share/applications | grep opera
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline Zorba61

  • Jr. Member
  • **
  • Posts: 97
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Starting maximised
« Reply #6 on: September 11, 2018, 12:52:38 pm »
xed /usr/share/applications/opera.desktop....produces this

[Desktop Entry]
Version=1.0
Name=Opera
GenericName=Web browser
Comment=Fast and secure web browser
TryExec=opera
Exec=opera --start-maximized %U
Terminal=false
Icon=opera
Type=Application
Categories=Network;WebBrowser;
MimeType=text/html;text/xml;application/xhtml_xml;x-scheme-handler/http;x-scheme-handler/https;x-scheme-handler/ftp;application/x-opera-download;
Actions=NewWindow;NewPrivateWindow;

[Desktop Action NewWindow]
Name=New Window
Exec=opera --new-window --start-maximized
TargetEnvironment=Unity

[Desktop Action NewPrivateWindow]
Name=New Private Window
Exec=opera --private --start-maximized
TargetEnvironment=Unity

and

ls -a ~/.local/share/applications | grep opera....produces this

opera.desktop
« Last Edit: September 11, 2018, 12:54:47 pm by Zorba61 »

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 18268
  • Karma: 477
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Starting maximised
« Reply #7 on: September 11, 2018, 01:01:40 pm »
Okay run:
Code: [Select]
xed ~/.local/share/applications/opera.desktop
and make the same changes to that file .. then SAVE it .. then test.
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline Zorba61

  • Jr. Member
  • **
  • Posts: 97
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Starting maximised
« Reply #8 on: September 11, 2018, 05:18:32 pm »
Still not opening maximised......... ???

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 18268
  • Karma: 477
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Starting maximised
« Reply #9 on: September 12, 2018, 01:37:18 am »
As a test, run:
Code: [Select]
xed ~/Desktop/opera.desktop
when a BLANK file opens, make it read
Code: [Select]
[Desktop Entry]
Version=1.0
Name=Opera
GenericName=Web browser
Comment=Fast and secure web browser
TryExec=opera
Exec=opera --start-maximized %U
Terminal=false
Icon=opera
Type=Application
Categories=Network;WebBrowser;
MimeType=text/html;text/xml;application/xhtml_xml;x-scheme-handler/http;x-scheme-handler/https;x-scheme-handler/ftp;application/x-opera-download;
Actions=NewWindow;NewPrivateWindow;

[Desktop Action NewWindow]
Name=New Window
Exec=opera --new-window --start-maximized
TargetEnvironment=Unity

[Desktop Action NewPrivateWindow]
Name=New Private Window
Exec=opera --private --start-maximized
TargetEnvironment=Unity
SAVE the file and exit the text editor.

You should now have a new "Opera" icon on the desktop .. if you close ALL instances of Opera, then relaunch it from that new desktop launcher, does it start maximised ?

And can you explain exactly where you've been trying to launch Opera from ? (in the main menu ?, in a dockbar ?, from a panel shortcut ?, etc.)
« Last Edit: September 12, 2018, 01:39:58 am by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline Zorba61

  • Jr. Member
  • **
  • Posts: 97
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Starting maximised
« Reply #10 on: September 12, 2018, 06:12:54 am »
I have been launching it from the desktop icon.However I copied and pasted all the text you posted up above and now it opens maximised  ;D ;D
Thank you very much for your patience and efforts, your a star.
Maybe this old dog (56) can learn new tricks and stick with Linux. ;D
« Last Edit: September 12, 2018, 06:15:35 am by Zorba61 »

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 18268
  • Karma: 477
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Starting maximised (SOLVED)
« Reply #11 on: September 12, 2018, 04:21:30 pm »
No problem my friend, glad I could help :)
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline jrgsampaio

  • Jr. Member
  • **
  • Posts: 1
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Starting maximised (SOLVED)
« Reply #12 on: December 03, 2019, 06:18:52 am »
Come on, you don't need all these coding and editing to get that behavior.  If it does not open in full screen, just click and hold on the top of the window and drag to the top of the screen until it turns full screen. Close Opera and open again. It should start in full screen. Now click&hold and drag it back, close and re-open.

JS

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 18268
  • Karma: 477
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Starting maximised (SOLVED)
« Reply #13 on: December 03, 2019, 11:15:09 am »
Did you actually read the OP ?

Quote from: Zorba61
The first problem i've encounted  is that Opera browser won't open maximised unless I leave it maximised when closing it

so he obviously knew that, he then continued...

Quote from: Zorba61
I know it can be done but being a complete novice I need to be talked through the whole process of opening the terminal and inserting/editing command lines.
Can anybody help?

So as the title of the topic wasn't specifically about Opera, I answered what was asked.

Where's the problem (specially considering the OP was happy with the result) ?
« Last Edit: December 03, 2019, 11:19:43 am by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

 


SimplePortal 2.3.3 © 2008-2010, SimplePortal