Author Topic: Starting maximised (revisited) solved  (Read 638 times)

0 Members and 1 Guest are viewing this topic.

Offline Zorba61

  • Jr. Member
  • **
  • Posts: 64
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Starting maximised (revisited) solved
« on: September 26, 2018, 08:28:26 am »
I have an Opera icon on desktop that opens opera maximised but I can't add it to the panel and if I click on the Icon in the menu list (internet) it doesn't open maximised,is the a way to get this to open maximised from the panel?
« Last Edit: September 28, 2018, 08:10:17 am by Zorba61 »

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 17940
  • Karma: 461
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Starting maximised (revisited)
« Reply #1 on: September 26, 2018, 01:06:13 pm »
Run
Code: [Select]
sudo xed /usr/share/applications/opera.desktop
make it read
Code: [Select]
[Desktop Entry]
Version=1.0
Name=Opera
GenericName=Web browser
Comment=Fast and secure web browser
TryExec=opera
Exec=opera --start-maximized %U
Terminal=false
Icon=opera
Type=Application
Categories=Network;WebBrowser;
MimeType=text/html;text/xml;application/xhtml_xml;x-scheme-handler/http;x-scheme-handler/https;x-scheme-handler/ftp;application/x-opera-download;
Actions=NewWindow;NewPrivateWindow;

[Desktop Action NewWindow]
Name=New Window
Exec=opera --new-window --start-maximized
TargetEnvironment=Unity

[Desktop Action NewPrivateWindow]
Name=New Private Window
Exec=opera --private --start-maximized
TargetEnvironment=Unity
SAVE the file.

Now the menu item in your main menu will also open maximised.

As for the panel .. which panel are you using ?

You may now need to remove Opera from the panel, and re-add it.
« Last Edit: September 27, 2018, 07:51:22 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline Zorba61

  • Jr. Member
  • **
  • Posts: 64
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Starting maximised (revisited)
« Reply #2 on: September 27, 2018, 06:57:12 pm »
Cheers Mark will give it a go.Panel I'm using is the default one that came with Cinnamon Tara
         Thanks
« Last Edit: September 27, 2018, 07:51:38 pm by Mark Greaves (PCNetSpec) »

Offline Zorba61

  • Jr. Member
  • **
  • Posts: 64
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Starting maximised (revisited)(solved )
« Reply #3 on: September 28, 2018, 08:09:56 am »
Yep that sorted it thanks Mark.

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 17940
  • Karma: 461
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Starting maximised (revisited) solved
« Reply #4 on: September 28, 2018, 11:24:43 pm »
Great stuff :)
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline Zorba61

  • Jr. Member
  • **
  • Posts: 64
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Starting maximised (revisited) solved
« Reply #5 on: November 03, 2018, 08:14:07 am »
Mark Opera  has now stopped opening maximised after update,I normally just re edit after an update with above text but now getting this message

** (xed:9810): WARNING **: 08:09:58.974: Set document metadata failed: Setting attribute metadata::xed-spell-language not supported

** (xed:9810): WARNING **: 08:09:58.975: Set document metadata failed: Setting attribute metadata::xed-encoding not supported

** (xed:9810): WARNING **: 08:10:10.399: Set document metadata failed: Setting attribute metadata::xed-position not supported
 Any ideas mate.

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 17940
  • Karma: 461
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Starting maximised (revisited) solved
« Reply #6 on: November 03, 2018, 11:48:44 pm »
those are Gtk warnings for the xed text editor .. nothing to worry about.

Why Opera has stopped working with the --start-maximized option is beyond me .. they must have disabled the option, though god only knows why ::)
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline Zorba61

  • Jr. Member
  • **
  • Posts: 64
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Starting maximised (revisited) solved
« Reply #7 on: November 07, 2018, 03:49:15 pm »
Well  it's back working again,don't know what happened there but thanks for replying Mark.

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 17940
  • Karma: 461
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Starting maximised (revisited) solved
« Reply #8 on: November 07, 2018, 04:09:23 pm »
Great news :)

I guess Opera must have fixed something.
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

 


SimplePortal 2.3.3 © 2008-2010, SimplePortal