Author Topic: Printrer compatibility  (Read 701 times)

0 Members and 1 Guest are viewing this topic.

Offline Alfred96

  • Jr. Member
  • **
  • Posts: 5
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Printrer compatibility
« on: October 09, 2018, 08:07:05 am »
I have been using Ubuntu for a few months now but always have problems with printer compatibilities. Is there a list of Ubuntu recommended printers, preferably HP. I was told my Canon MX420 is compatible. I downloaded the driver but but I always have to call in an engineer to connect it. I need a printer without this hassle which Ubuntu will find automatically

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 17820
  • Karma: 459
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Printrer compatibility
« Reply #1 on: October 09, 2018, 12:38:37 pm »
Most HP Printers will just work out of the box (with hplip and hplip-gui) .. but for a list of supported printers
http://www.openprinting.org/driver/hplip
dunno how up to date that is, so this (directly from HP) may be better
https://developers.hp.com/hp-linux-imaging-and-printing/supported_devices/index
that should tell you the minimum version of hplip you require .. then check your distro has at least that version (or higher).

In Ubuntu you can check the hplip version by running
Code: [Select]
hp-info
in a terminal .. you should then see output similar to

Quote
HP Linux Imaging and Printing System (ver. 3.17.10)

« Last Edit: October 09, 2018, 12:44:47 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

 


SimplePortal 2.3.3 © 2008-2010, SimplePortal