Updates:

Similar topics mod installed, currently shown at the end of a topic

Can't enable wifi on Novatech laptop after new mint 19 install

Started by ZapDog5, November 02, 2018, 09:12:20 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

ZapDog5


Mark Greaves (PCNetSpec)

What happens if you run:
sudo rfkill block bluetooth
then
sudo rfkill unblock wlan
now what's the output from
rfkill list
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk


ZapDog5

0: phy0: Wireless LAN
   Soft blocked: no
   Hard blocked: yes
1: hci0: Bluetooth
   Soft blocked: yes
   Hard blocked: no

Mark Greaves (PCNetSpec)

WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

ZapDog5

Yep, I did that (I think - it was something like 'restore default settings' or something)

I tried other linux distros too and the problem was the same there (eg Ubuntu) but it worked fine in Fedora previously. Wondering if I need to reinstall Fedora or buy a dongle instead...


Mark Greaves (PCNetSpec)

My guess would be that it'll be the same in Fedora now too

For some reason I **think** the motherboard is disabling the hardware and ignoring the switch/key combo .. usually the "removing the battery trick" works, but obviously that's going to be a problem here.

Is there an option to disable wireless in the BIOS .. if so, disable it .. boot once .. reboot .. re-enable wireless .. and boot.

Maybe that will unstick it.

Something else .. have you tried the key combo a few times because sometimes it just disables bluetooth on the first click, then disables wireless, then re-enables bluetooth, then re-enables wireless .. if you get my drift
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

ZapDog5

I couldn't find anything in the BIOS that would disable wifi.

I tried the key combo a few times too but that didn't seem to do anything.

Worst case I can take it to bits tomorrow and remove the battery and see if that makes any difference.

Thanks for looking into this so deeply - it's a Herculean effort!

Mark Greaves (PCNetSpec)

#22
Maybe simply running the battery flat will do it .. just a thought.
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

ZapDog5



Mark Greaves (PCNetSpec)

#24
Maybe also try a Fedora LiveDVD/LiveUSB .. just to check.
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

ZapDog5

Good idea.

I'll try both those things and update later...

Thanks again.

Mark Greaves (PCNetSpec)

If it works in a Fedora Live session .. check which kernel they're running, maybe we can duplicate that in Mint.
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

ZapDog5

Still no luck.

I ran the battery down to zero overnight, pressed power button etc but still blocked.

I also booted Fedora 29 from a USB and its blocked there too...

donwatson

On my Novatech the Fn/F12 keys are the wireless control, if that helps ??
Don W
Novatech build
Intel Celeron CPU 1.80 Ghz   Memory 4.00GB (3.71GB usable)
Peppermint 9    64 bit     500 GB HD        496 GB Ext 4
4.0GB Swap Partition    4.0GB Extended Partition   1.1Mb Free Space
External 2TiB HD

ZapDog5

Hi Don,

Thanks - tried that but still no luck.

Don't know if it's related or not, but when i shut down, it just hangs at the mint logo and I need to switch off manually. Restart works fine though.