Tech Zone > Linux Solutions

OS not able to properly create filesystem

(1/1)

anaigini:
Hi,

I have a task of creating filesystem from an external HP 3PAR storage.
The OS is RHEL 5.8.

These were the steps I used for the OS to detect the allocated storage to the server :

1) Scan for available hosts in system :


--- Code: ---
# ls /sys/class/fc_host
--- End code ---

2) Run the following commands to scan the LUN


--- Code: ---
$ echo "- - -" > /sys/class/scsi_host/host3/scan

$ echo "- - -" > /sys/class/scsi_host/host4/scan
--- End code ---


3) Now edit /etc/multipath.conf and add the following:


--- Code: ---
blacklist_exceptions {
        wwid "360002ac0000000000000008e0001ee00"
        wwid "360002ac0000000000000008f0001ee00"
        wwid "360002ac000000000000000900001ee00"
        wwid "360002ac000000000000000910001ee00"
        wwid "360002ac000000000000000920001ee00"
        wwid "360002ac000000000000000930001ee00"
}
--- End code ---

4) Run the command :


--- Code: ---
# multipath -v2
--- End code ---

>>>>The problem starts here, whereby I don't see any output :


--- Code: ---
[root@csixdb1 ~]# multipath -v2
[root@csixdb1 ~]#
--- End code ---

Even when I use multipath -ll, there is no output :


--- Code: ---
[root@csixdb1 ~]# multipath -ll
[root@csixdb1 ~]#
--- End code ---

I have already started the service :


--- Code: ---
root@csixdb1 ~]# /etc/init.d/multipathd status
multipathd (pid  29995) is running...
[root@csixdb1 ~]#
--- End code ---

Is there any steps I am missing out ? How do I know if the device is detected, and what is the name of the device?


Navigation

[0] Message Index

Go to full version