Author Topic: Using "mpack" to send files [SOLVED]  (Read 300 times)

0 Members and 1 Guest are viewing this topic.

Offline Keith

  • Hero Member
  • *****
  • Posts: 937
  • Karma: 11
  • Gender: Male
  • Linux Novice
    • View Profile
    • Awards
Using "mpack" to send files [SOLVED]
« on: July 25, 2019, 08:52:44 pm »
I use mpack on my T500 laptop, after a lot of initial difficulty, and now want to use it on an ASUSTeK P6-P5G41E running Ubuntu 18.04 in gnome-flashback.

The command format is mpack -s "<subject line>"  -a <file path>  <email address>   which works fine on my T500 but on the Asus the error message is "execv: No such file or directory"  although the specified file-path is valid. 

Any ideas would be welcome.
----------------
[EDIT]  It turns out that the Mail Transfer Agent "sendmail" was not installed by default.  Installing it removes the error message but the email is still not sent.
[EDIT2] Remembered that I need to set up a ssmtp.conf file in /etc/ssmtp so copied the file from my T500 and edited it for the owner of the Asus.  Still no joy.
[EDIT 3] It turns out that SSMTP was not installed despite Thunderbird working well.  Installing it makes mpack work OK. 

SOLUTION:
Install sendmail
Install SSMTP
Create a file /etc/ssmtp/ssmtp.conf
  See the second link below.

Useful links:
http://ozzmaker.com/send-email-from-the-raspberry-pi-or-linux-command-line-with-attachments/
https://wiki.archlinux.org/index.php/SSMTP
« Last Edit: July 25, 2019, 10:10:09 pm by Keith »

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 18176
  • Karma: 476
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Using "mpack" to send files [SOLVED]
« Reply #1 on: July 25, 2019, 10:30:44 pm »
Providing your own solutions again eh Keith...

Nice :)
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline Keith

  • Hero Member
  • *****
  • Posts: 937
  • Karma: 11
  • Gender: Male
  • Linux Novice
    • View Profile
    • Awards
Re: Using "mpack" to send files [SOLVED]
« Reply #2 on: July 26, 2019, 06:21:26 pm »
I was a bit embarrassed about that as I ought to have persevered before launching a post.  On the other hand these difficulties I've had seem to be common, judging by the number of posts in other forums, so if my solutions are useful to others then I don't feel so daft. 

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 18176
  • Karma: 476
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Using "mpack" to send files [SOLVED]
« Reply #3 on: July 26, 2019, 08:42:17 pm »
Useful forum content never hurts :)
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

 


SimplePortal 2.3.3 © 2008-2010, SimplePortal