Author Topic: gparted doesn't work in the new Debian 10.0 in my Dell Inspiron 1545  (Read 251 times)

0 Members and 1 Guest are viewing this topic.

Offline nogueira13

  • Jr. Member
  • **
  • Posts: 2
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
I already done twice the install of Debian 10.0 in my Laptop Dell Inspiron 1545 and I choose Gnome (under Xorg, Gnome Weyland and Mate). I install it using the Netinstall CD disk. In the two cases, I can't use gparted. I installed it but when I start it, I type the root password but the app doesn't open. Even in Mate graphics manager.
I already received the following message when I tryed to format an usb pendrive:
"Error synchronizing after initial wipe: timed out waiting for object (udisks-error-quark, 0)"
Another error that I found is that when I start an app "overgrive", it is not showed me that the app is running in the notifying panel.
I beg your pardon for my poor English but my native language is Portuguese.
I hope you may help me.
Sincerely
Antonio Carlos

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 18208
  • Karma: 476
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: gparted doesn't work in the new Debian 10.0 in my Dell Inspiron 1545
« Reply #1 on: September 04, 2019, 12:37:15 am »
What happens if you run:
Code: [Select]
/usr/sbin/gparted
in a terminal ?
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline nogueira13

  • Jr. Member
  • **
  • Posts: 2
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: gparted doesn't work in the new Debian 10.0 in my Dell Inspiron 1545
« Reply #2 on: September 04, 2019, 03:24:48 am »
I received this message:

root@debian-nogueira:/home/nogueira# /usr/sbin/gparted
Unit tmp.mount does not exist, proceeding anyway.

And gparted didn't openned.

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 18208
  • Karma: 476
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: gparted doesn't work in the new Debian 10.0 in my Dell Inspiron 1545
« Reply #3 on: September 04, 2019, 03:36:31 pm »
You might want to read this
https://bugs.launchpad.net/ubuntu/+source/gparted/+bug/1744372
and this
https://bugs.launchpad.net/ubuntu/+source/gparted/+bug/1737248

Yes they're specifically about Ubuntu, but I'm going to bet the same 'Gparted won't work under wayland' applies to Debian too.

Maybe gnome-disks would be a better bet, unless you want to try a version of Gparted that does implement --enable-xhost-root

Couldn't you just switch out of a wayland session back to an X session .. then use Gparted .. then switch back ?
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

 


SimplePortal 2.3.3 © 2008-2010, SimplePortal