Author Topic: How to always have the most up to date copy of LibreOffice  (Read 914 times)

0 Members and 1 Guest are viewing this topic.

Offline Tramlink

  • Hero Member
  • *****
  • Posts: 949
  • Karma: 12
  • Gender: Male
  • Is the mist clearing
    • View Profile
    • Awards
How to always have the most up to date copy of LibreOffice
« on: December 14, 2019, 02:22:37 pm »
I am using Mint 18.3 64bit

I updated my LibreOffice to - LibreOffice_6.2.5_Linux_x86-64

Every time I open the program I am told there is an up date available.

I would like for the up dates to take place automagically is that possible?

Any help appreciated.

Offline Mark Greaves (PCNetSpec)

  • Hero Member
  • *****
  • Posts: 18277
  • Karma: 477
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: How to always have the most up to date copy of LibreOffice
« Reply #1 on: December 14, 2019, 07:33:36 pm »
How did you install version 6.2.5 ?

and what's the output from:
Code: [Select]
dpkg -l | grep libreoffice
« Last Edit: December 14, 2019, 07:35:33 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline Tramlink

  • Hero Member
  • *****
  • Posts: 949
  • Karma: 12
  • Gender: Male
  • Is the mist clearing
    • View Profile
    • Awards
Re: How to always have the most up to date copy of LibreOffice
« Reply #2 on: December 14, 2019, 10:56:52 pm »
I downloaded the program and did a stand-alone install.

Code: [Select]
cjhm@userone ~ $ dpkg -l | grep libreoffice
ii  libobasis6.1-libreofficekit-data                  6.1.5.2-2                                        amd64        Libreofficekit data files for LibreOffice 6.1 .5.2
ii  libobasis6.2-libreofficekit-data                  6.2.5.2-2                                        amd64        Libreofficekit data files for LibreOffice 6.2 .5.2
rc  libreoffice-avmedia-backend-gstreamer             1:5.1.6~rc2-0ubuntu1~xenial6                     amd64        GStreamer backend for LibreOffice
rc  libreoffice-base                                  1:5.1.6~rc2-0ubuntu1~xenial6                     amd64        office productivity suite -- database
rc  libreoffice-base-core                             1:5.1.6~rc2-0ubuntu1~xenial6                     amd64        office productivity suite -- shared library
rc  libreoffice-base-drivers                          1:5.1.6~rc2-0ubuntu1~xenial6                     amd64        Database connectivity drivers for LibreOffice
rc  libreoffice-calc                                  1:5.1.6~rc2-0ubuntu1~xenial6                     amd64        office productivity suite -- spreadsheet
rc  libreoffice-common                                1:5.1.6~rc2-0ubuntu1~xenial6                     all          office productivity suite -- arch-independent files
rc  libreoffice-core                                  1:5.1.6~rc2-0ubuntu1~xenial6                     amd64        office productivity suite -- arch-dependent files
rc  libreoffice-draw                                  1:5.1.6~rc2-0ubuntu1~xenial6                     amd64        office productivity suite -- drawing
rc  libreoffice-gnome                                 1:5.1.6~rc2-0ubuntu1~xenial6                     amd64        office productivity suite -- GNOME integration
rc  libreoffice-gtk                                   1:5.1.6~rc2-0ubuntu1~xenial6                     amd64        office productivity suite -- GTK+ integration
rc  libreoffice-impress                               1:5.1.6~rc2-0ubuntu1~xenial6                     amd64        office productivity suite -- presentation
rc  libreoffice-java-common                           1:5.1.6~rc2-0ubuntu1~xenial6                     all          office productivity suite -- arch-independent Java support files
rc  libreoffice-math                                  1:5.1.6~rc2-0ubuntu1~xenial6                     amd64        office productivity suite -- equation editor
rc  libreoffice-ogltrans                              1:5.1.6~rc2-0ubuntu1~xenial6                     amd64        LibreOffice Impress extension for slide transitions using OpenGL
rc  libreoffice-pdfimport                             1:5.1.6~rc2-0ubuntu1~xenial6                     amd64        PDF Import component for LibreOffice
rc  libreoffice-sdbc-firebird                         1:5.1.6~rc2-0ubuntu1~xenial6                     amd64        Firebird SDBC driver for LibreOffice
rc  libreoffice-sdbc-hsqldb                           1:5.1.6~rc2-0ubuntu1~xenial6                     amd64        HSQLDB SDBC driver for LibreOffice
ii  libreoffice-style-mint                            5.1+3                                            all          Linux Mint theme for LibreOffice.org
rc  libreoffice-writer                                1:5.1.6~rc2-0ubuntu1~xenial6                     amd64        office productivity suite -- word processor
ii  libreoffice6.1                                    6.1.5.2-2                                        amd64        Brand module for LibreOffice 6.1 .5.2
ii  libreoffice6.1-base                               6.1.5.2-2                                        amd64        Base brand module for LibreOffice 6.1 .5.2
ii  libreoffice6.1-calc                               6.1.5.2-2                                        amd64        Calc brand module for LibreOffice 6.1 .5.2
rc  libreoffice6.1-debian-menus                       6.1.5-2                                          all          LibreOffice 6.1 desktop integration
ii  libreoffice6.1-dict-en                            6.1.5.2-2                                        amd64        En dictionary for LibreOffice 6.1 .5.2
ii  libreoffice6.1-dict-es                            6.1.5.2-2                                        amd64        Es dictionary for LibreOffice 6.1 .5.2
ii  libreoffice6.1-dict-fr                            6.1.5.2-2                                        amd64        Fr dictionary for LibreOffice 6.1 .5.2
ii  libreoffice6.1-draw                               6.1.5.2-2                                        amd64        Draw brand module for LibreOffice 6.1 .5.2
ii  libreoffice6.1-en-us                              6.1.5.2-2                                        amd64        Brand language module for LibreOffice 6.1 .5.2
ii  libreoffice6.1-impress                            6.1.5.2-2                                        amd64        Impress brand module for LibreOffice 6.1 .5.2
ii  libreoffice6.1-math                               6.1.5.2-2                                        amd64        Math brand module for LibreOffice 6.1 .5.2
ii  libreoffice6.1-ure                                6.1.5.2-2                                        amd64        UNO Runtime Environment .5.2
ii  libreoffice6.1-writer                             6.1.5.2-2                                        amd64        Writer brand module for LibreOffice 6.1 .5.2
ii  libreoffice6.2                                    6.2.5.2-2                                        amd64        Brand module for LibreOffice 6.2 .5.2
ii  libreoffice6.2-base                               6.2.5.2-2                                        amd64        Base brand module for LibreOffice 6.2 .5.2
ii  libreoffice6.2-calc                               6.2.5.2-2                                        amd64        Calc brand module for LibreOffice 6.2 .5.2
ii  libreoffice6.2-debian-menus                       6.2.5-2                                          all          LibreOffice 6.2 desktop integration
ii  libreoffice6.2-dict-en                            6.2.5.2-2                                        amd64        En dictionary for LibreOffice 6.2 .5.2
ii  libreoffice6.2-dict-es                            6.2.5.2-2                                        amd64        Es dictionary for LibreOffice 6.2 .5.2
ii  libreoffice6.2-dict-fr                            6.2.5.2-2                                        amd64        Fr dictionary for LibreOffice 6.2 .5.2
ii  libreoffice6.2-draw                               6.2.5.2-2                                        amd64        Draw brand module for LibreOffice 6.2 .5.2
ii  libreoffice6.2-en-us                              6.2.5.2-2                                        amd64        Brand language module for LibreOffice 6.2 .5.2
ii  libreoffice6.2-impress                            6.2.5.2-2                                        amd64        Impress brand module for LibreOffice 6.2 .5.2
ii  libreoffice6.2-math                               6.2.5.2-2                                        amd64        Math brand module for LibreOffice 6.2 .5.2
ii  libreoffice6.2-ure                                6.2.5.2-2                                        amd64        UNO Runtime Environment .5.2
ii  libreoffice6.2-writer                             6.2.5.2-2                                        amd64        Writer brand module for LibreOffice 6.2 .5.2
cjhm@userone ~ $
« Last Edit: December 15, 2019, 07:19:15 pm by Mark Greaves (PCNetSpec) »

Offline Mark Greaves (PCNetSpec)

  • Hero Member
  • *****
  • Posts: 18277
  • Karma: 477
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: How to always have the most up to date copy of LibreOffice
« Reply #3 on: December 15, 2019, 07:10:55 pm »
Personally I'd purge anything to do with libreoffice
Code: [Select]
sudo apt-get remove --purge libobasis6.1-libreofficekit-data libobasis6.2-libreofficekit-data libreoffice-avmedia-backend-gstreamer libreoffice-base libreoffice-base-core libreoffice-base-drivers libreoffice-calc libreoffice-common libreoffice-core libreoffice-draw libreoffice-gnome libreoffice-gtk libreoffice-impress libreoffice-java-common libreoffice-math libreoffice-ogltrans libreoffice-pdfimport libreoffice-sdbc-firebird libreoffice-sdbc-hsqldb libreoffice-style-mint libreoffice-writer libreoffice6.1 libreoffice6.1-base libreoffice6.1-calc libreoffice6.1-debian-menus libreoffice6.1-dict-en libreoffice6.1-dict-es libreoffice6.1-dict-fr libreoffice6.1-draw libreoffice6.1-en-us libreoffice6.1-impress libreoffice6.1-math libreoffice6.1-ure libreoffice6.1-writer libreoffice6.2 libreoffice6.2-base libreoffice6.2-calc libreoffice6.2-debian-menus libreoffice6.2-dict-en libreoffice6.2-dict-es libreoffice6.2-dict-fr libreoffice6.2-draw libreoffice6.2-en-us libreoffice6.2-impress libreoffice6.2-math libreoffice6.2-ure libreoffice6.2-writer
Then add the libreoffice PPA
Code: [Select]
sudo add-apt-repository ppa:libreoffice/ppa
then update your package cache
Code: [Select]
sudo apt-get update
then run a system update
Code: [Select]
sudo apt-get dist-upgrade
As you're on Mint 18 which is based on xenial (16.04), you should now be on LibreOffice 6.2.8

and your system should automagically update if/when updates are added to the PPA .. not that I'd expect many (if any) updates to LO for xenial in the future, I mean LO is now on 6.3.3 in the same PPA for later versions of Ubuntu/Mint.
« Last Edit: December 15, 2019, 07:18:44 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline Tramlink

  • Hero Member
  • *****
  • Posts: 949
  • Karma: 12
  • Gender: Male
  • Is the mist clearing
    • View Profile
    • Awards
Re: How to always have the most up to date copy of LibreOffice
« Reply #4 on: December 24, 2019, 04:06:04 pm »
Thanks for the information. Now updated but just as a thought what is the point of a LTS release if support is restricted.

Later versions of mint say that networking especially with windows computers is not so good so not sure if I want to upgrade my system.

 Thanks for your help.

Offline Sabinus

  • Jr. Member
  • **
  • Posts: 11
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: How to always have the most up to date copy of LibreOffice
« Reply #5 on: December 25, 2019, 01:36:10 am »
This is interesting, I am running Linux Mint 19.3 cinammon but my libreoffice is version 6.0.7.3. I have only upgraded two days ago and should have the newest version. On my LO, there is no option to ugrade or update. Does it mean that I have to do a fresh LO install?

Offline Sabinus

  • Jr. Member
  • **
  • Posts: 11
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: How to always have the most up to date copy of LibreOffice
« Reply #6 on: December 25, 2019, 02:42:23 am »
This is interesting, I am running Linux Mint 19.3 cinammon but my libreoffice is version 6.0.7.3. I have only upgraded two days ago and should have the newest version. On my LO, there is no option to ugrade or update. Does it mean that I have to do a fresh LO install?
Just to update everyone, I have been able to download the most recent Libreoffice flatpak (Version 6.3.4.2) from the software manager. However, the bundled version 6.0.7.3 is still in my laptop. How do I remove it and keep the most up-to-date version only?

Offline Mark Greaves (PCNetSpec)

  • Hero Member
  • *****
  • Posts: 18277
  • Karma: 477
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: How to always have the most up to date copy of LibreOffice
« Reply #7 on: December 25, 2019, 09:22:29 pm »
@Sabinus

This should remove the .deb version without uninstalling the flatpak version:
Code: [Select]
sudo apt-get remove --purge libreoffice*
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline Sabinus

  • Jr. Member
  • **
  • Posts: 11
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: How to always have the most up to date copy of LibreOffice
« Reply #8 on: December 27, 2019, 11:03:28 pm »
This is interesting, I am running Linux Mint 19.3 cinammon but my libreoffice is version 6.0.7.3. I have only upgraded two days ago and should have the newest version. On my LO, there is no option to ugrade or update. Does it mean that I have to do a fresh LO install?
Just to update everyone, I have been able to download the most recent Libreoffice flatpak (Version 6.3.4.2) from the software manager. However, the bundled version 6.0.7.3 is still in my laptop. How do I remove it and keep the most up-to-date version only?
Thanks a lot Mark Greaves, I have used the command and the bundled Libre office is gone from my laptop leaving only  the flatpak (the newest version) installed on my laptop. Really appreciated.
Does this mean that the flatpak Libre office on my laptop will auto-update or notify me when new updates are available? If not, how do I keep it updated?

Offline Sabinus

  • Jr. Member
  • **
  • Posts: 11
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: How to always have the most up to date copy of LibreOffice
« Reply #9 on: December 29, 2019, 02:25:08 pm »
@Sabinus

This should remove the .deb version without uninstalling the flatpak version:
Code: [Select]
sudo apt-get remove --purge libreoffice*
Mission accomplished! Thanks again Mark Greaves. I was wondering why the newest version (6.3.4.2) of Libre Office did not over-write the much older version 6.0.7.3? Being a MS Windows user for most of my computing years, I would have expected that to happen without any doubt and I am wondering if it is one of those things that need to be more polished on Linux?

Offline Mark Greaves (PCNetSpec)

  • Hero Member
  • *****
  • Posts: 18277
  • Karma: 477
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: How to always have the most up to date copy of LibreOffice
« Reply #10 on: December 30, 2019, 03:09:55 pm »
Being able to have multiple versions of an app installed at the same time (each with differing dependencies/libraries but without conflict) is a FEATURE of flatpak and snap .. not a mistake/bug that needs fixing ;)
« Last Edit: December 30, 2019, 03:12:31 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

 


SimplePortal 2.3.3 © 2008-2010, SimplePortal