Author Topic: Sendmail problems  (Read 537 times)

0 Members and 1 Guest are viewing this topic.

Offline Keith

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1030
  • Karma: 13
  • Gender: Male
  • Linux Novice
  • Awards Contributor Of The Month
    • View Profile
    • Awards
Sendmail problems
« on: February 12, 2020, 06:23:16 pm »
Lenovo Thinkpad T500 - Ubuntu 16.04

Since my email provider has updated its security arrangements it can’t accept my emails sent from  the command line with a sender name that is not my registered username – e.g. an alias.  This ought not be a problem as I have set up my /etc/ssmtp/ssmtp.conf file with my registered base address that ought to be used by sendmail:

ssmtp.conf
root=keith_surname@mailco.com
mailhub=mail.runbox.com:465

AuthUser=keith_surname@mailco.com
AuthPass={password}
UseTLS=YES
UseSSL=YES

rewriteDomain=mailco.com
hostname=T500
FromLineOverride=YES
--------------------------------------------------

But when I use sendmail, it removes my surname from the “From” address and my mail provider rejects the email as the From name is incorrect:

keith@T500:~/.bin$ sendmail -v keith_surname@mailco.com  < mail_message
[<-] 220 mailfront20.runbox ESMTP Exim 4.90_1 Ubuntu Wed, 12 Feb 2020 18:55:02 +0100
[->] EHLO T500
[<-] 250 HELP
[->] AUTH LOGIN
[<-] 334 VXNlcm5hbWU6
[->] a2VpdGhfc3RhbW1lcnNAcnVuYm94LmNvbQ==
[<-] 334 UGFzc3dvcmQ6
[<-] 235 Authentication succeeded
[->] MAIL FROM:<keith@mailco.com>
[<-] 250 OK
[->] RCPT TO:<keith_surname@mailco.com>
[<-] 250 Accepted
[->] DATA
[<-] 354 Enter message, ending with "." on a line by itself
[->] Received: by T500 (sSMTP sendmail emulation); Wed, 12 Feb 2020 17:55:01 +0000
[->] From: "keith" <keith@mailco.com>
[->] Date: Wed, 12 Feb 2020 17:55:01 +0000
[->]
[->] Text for message
[->]
[->] .
[<-] 550 Invalid From address. Please see https://help.mailco.com/identities/
sendmail: 550 Invalid From address. Please see https://help.mailco/identities/
keith@T500:~/.bin$

In principle I could add the name "keith@mailco.com" to my account as an alias and that would work, but someone has already claimed that so I can't use it.
My mail provider has been unable to help me and I would be grateful for advice. 
« Last Edit: February 12, 2020, 06:37:14 pm by Keith »

 


SimplePortal 2.3.3 © 2008-2010, SimplePortal