Updates:

Forums updated to SMF version 2.1.1

Problem installing dependencies for Nvidia 390 driver (Resolved)

Started by Tramlink, July 15, 2020, 11:27:17 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

Tramlink

Running mint 19.3 cinnamon (this is an upgrade from 18.3).

As I was having issues launching a game I thought I would try a different graphics driver (340) as listed in the driver manager.

The change was not allowed and when I tried to return to the recommended 390 driver I was told that the following dependences were not on the system.

Depends: libnvidia-gl-390 but it is not installed
nvidia-driver-390 : Depends: libnvidia-gl-390 (= 390.138-0ubuntu0.18.04.1)

I have tried repairing them through the "Package manager" I am told they can not be installed.
I tried installing them through apt and I am told there is a conflict with the 340 driver.
Also tried install the 390 driver package from Nvidia.

Any clues please how I can restore the dependencies.

Thank you.

Rich J

Quote from: Tramlink on July 15, 2020, 11:27:17 AM
Running mint 19.3 cinnamon (this is an upgrade from 18.3).

As I was having issues launching a game I thought I would try a different graphics driver (340) as listed in the driver manager.

The change was not allowed and when I tried to return to the recommended 390 driver I was told that the following dependences were not on the system.

Depends: libnvidia-gl-390 but it is not installed
nvidia-driver-390 : Depends: libnvidia-gl-390 (= 390.138-0ubuntu0.18.04.1)

I have tried repairing them through the "Package manager" I am told they can not be installed.
I tried installing them through apt and I am told there is a conflict with the 340 driver.
Also tried install the 390 driver package from Nvidia.

Any clues please how I can restore the dependencies.

Thank you.

Hi Tramlink  - take a look here - https://forums.linuxmint.com/viewtopic.php?t=316253

Rich


Tramlink

Thanks for that info.

I am not using the 340 driver.

The 390 driver is newer and was working just fine until I tried to use the older driver.

I just want my 390 driver working again.

Driver manager shows I am using the 390 driver but when the computer starts I am told to check my drivers as there is a problem.

Tramlink

In the end I did a clean installation of mint 19.3 mate 64bit.

Keith



Tramlink

Yes the problem was fixed as the drivers were offer as part of installing mint 19.3 mate 64bit.

Thanks for your information.