General Help & Advice > Hardware Compatibility

light slowly flashing on external hard drive

(1/3) > >>

freelancehelp:
A new WD Elements portable hard drive has been plugged into a USB 3 port on a Linux desktop.

The hard drive does not appear on an fdisk -l
listing. The small light on the drive is slowly flashing.

What is happening ? Why doesn't the drive appear in the fdisk listing ?

Is the system trying to automatically mount the hard drive ?

Is the USB port underpowered ?

I hesitate to unplug the hard drive while the light is flashing in case this corrupts the filesystem
on the hard drive.

Keith:
Try
--- Code: ---
sudo fdisk -l
--- End code ---
The sudo is necessary on my Ubuntu 16 PC. 
If the hard drive is new you should have a manual for it which will tell you the power requirements.  Sometimes one has to power these things from two USB sockets using a special cable.  If you don't have the manual then a web search will find the information. 

I wouldn't worry too much about the filesystem - as it's new, with none of your files on it, it can be reformatted later. 

Would you tell us which Linux version you are using, the make/model of your PC and the model of your hard drive?  This info will help people experienced in these things to provide advice. 

Keith

freelancehelp:
The command fdisk -l has already been tried. Also lsusb has been run. In neither case was the hard drive listed,
so the system doesn't see it.

There have been previous problems with the particular USB port, whereby it seemed that another, older hard drive
was suffering hardware problems. Hence the switch to a new hard drive.

The operating system is Debian Jessie (yes, I know it is outdated - a desktop with Buster is to be set up shortly).

The hard drive needs to be used to backup the current system so that relevant files can be transferred to the
new system.

The new hard drive is a WD Elements portable hard drive.

I am beginning to wonder whether the slowly flashing light means the hard drive has been put into standby mode.
This suggests to me that this particular USB port may be low on power and thus cannot power the hard drive properly.

Other USB ports seem to work okay.


The new drive is a portable drive so the USB port should be able to power it.

freelancehelp:
The desktop is a custom build with a gigabyte motherboard.

I'm not sure offhand which particular board.

Keith:
If lsusb doesn't list it then it's not being recognised, but the fdisk command ought to have been "sudo fdisk -l" anyway. 

You mention that you've been having problems with that particular USB port but don't mention whether you've tried the HDD on the other ports - I presume you have and that it failed to work on those, too - please confirm that. 
Do USB sticks work OK in all the ports?  If so, then the problem resides with the new HDD.  Perhaps you could consider returning it, although Western Digital has a good reputation. 

Keith

Navigation

[0] Message Index

[#] Next page

Go to full version