Author Topic: trouble with USB 3 port  (Read 1117 times)

0 Members and 1 Guest are viewing this topic.

Offline freelancehelp

  • Jr. Member
  • **
  • Posts: 44
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
trouble with USB 3 port
« on: July 30, 2020, 10:05:36 am »
I have a problem with a USB 3 port on a desktop running Debian Linux. The problem started when a system backup was attempted to a portable hard drive plugged into the USB 3 port. The backup operation had previously been done many times with no problems.

This time the mount operation failed with a message of the type 'can't find UUID=....'

Various commands such as fdisk -l showed that the kernel was not detecting the drive.

The drive was unplugged, then replug with a dmesg command issued straight after the replug.
The dmesg output seemed to indicate the portable hard drive itself had some problem.

A new portable hard drive was plugged into the port, but the kernel could not see the new drive, although a slowly flashing light on the drive indicated some power was reaching the hard drive.

I thought that perhaps the port was not supplying enough power to the drive, so I then plugged a new USB flash drive into the port. However the kernel would not recognise the flash drive.

Someone subsequently suggested that perhaps the power pins of the port were working but not the data pins.
This could perhaps be due to a problem with the port's USB header or associated cabling or possibly due to damage to
the host controller or associated wiring.

Any thoughts on this, please.

Offline Rich J

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 531
  • Karma: 9
  • Gender: Male
  • Still a Linux Luvvie!
    • View Profile
    • Awards
Re: trouble with USB 3 port
« Reply #1 on: July 31, 2020, 08:10:14 am »
I have a problem with a USB 3 port on a desktop running Debian Linux. The problem started when a system backup was attempted to a portable hard drive plugged into the USB 3 port. The backup operation had previously been done many times with no problems.

This time the mount operation failed with a message of the type 'can't find UUID=....'

Various commands such as fdisk -l showed that the kernel was not detecting the drive.

The drive was unplugged, then replug with a dmesg command issued straight after the replug.
The dmesg output seemed to indicate the portable hard drive itself had some problem.

A new portable hard drive was plugged into the port, but the kernel could not see the new drive, although a slowly flashing light on the drive indicated some power was reaching the hard drive.

I thought that perhaps the port was not supplying enough power to the drive, so I then plugged a new USB flash drive into the port. However the kernel would not recognise the flash drive.

Someone subsequently suggested that perhaps the power pins of the port were working but not the data pins.
This could perhaps be due to a problem with the port's USB header or associated cabling or possibly due to damage to
the host controller or associated wiring.

Any thoughts on this, please.

Have you been inside the case recently?  If not, something may still have become dislodged through general use - dusting, moving around etc - causing the issue.  Also, over time, electrical connections can suffer from 'contact resistance' problems (depends on ambient humidity and so on) that can often be cured by simply unplugging and re-plugging the offending connector.  Worth opening the case and checking?  Don't forget to use an earth strap or at least earth yourself on the bare case before delving!

Offline freelancehelp

  • Jr. Member
  • **
  • Posts: 44
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: trouble with USB 3 port
« Reply #2 on: August 08, 2020, 04:23:33 pm »
I have now seen a number of cases where USB devices are not detected.

It seems that the xhci_hcd driver needs to be replaced/reinitialised.

Some of the posts recommend that the computer is completely powered down (I.e. all external devices are unmounted,
the computer is switched off and unplugged from the mains). After a wait of, say, up to 30 minutes, the computer is
rebooted. The xhci_hcd driver should be reinitialised by the reboot, so the USB 3 port should then work fine.

Other posts suggest that instead of a power down and reboot, the xhci_hcd driver could be disabled and then re-enabled
similar to suggestion in https://zedt.eu/tech/linux/restarting-usb-subsystem-centos/

Does anyone know which directory contains the xhci_hcd driver in Debian, please ?

Offline freelancehelp

  • Jr. Member
  • **
  • Posts: 44
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: trouble with USB 3 port
« Reply #3 on: August 24, 2020, 06:38:03 pm »
 I am still struggling to solve the problem with the malfunctioning USB 3 port on a desktop
running Debian.

I would be very grateful if someone could please give useful answers to the following questions :-

 (1) Can the desktop be safely rebooted, if needed, given the USB 3 problem?

 (2) Can the USB 3 problem be fixed in some way or is the port now permanently
unavailable?

 (3) If the USB 3 port is unavailable, can the new portable hard drive be used to
     do a back-up of the system from the USB 2 port currently occupied by a card reader
     or is there any risk the card reader will be messed up again afterwards ?

     (On a previous occasion, a portable hard drive was plugged into this USB 2 port
      in place of the card reader. The system issued a message indicating the port was busy.
      The card reader was plugged back into the USB 2 port and it was then found that
      a card inserted into the card reader could not be mounted).

Offline Keith

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1148
  • Karma: 19
  • Gender: Male
  • Linux Novice
  • Awards Contributor Of The Month
    • View Profile
    • Awards
Re: trouble with USB 3 port
« Reply #4 on: August 24, 2020, 08:40:41 pm »
1. I am sure that the PC can be rebooted safely, but don't unplug any USB devices before doing so. 
2. Sorry, I can't help you on that one.
3. Provided that the card reader was not just pulled out of the port before the PC was shut down, it will be OK (or is it the same one unplugged before?).  The new portable drive ought to be fine for a backup, in principle, unless there is a PC problem preventing its use. 

Perhaps not very helpful, but the best I can do. 

Keith

 


SimplePortal 2.3.3 © 2008-2010, SimplePortal