Updates:

Forums updated to SMF version 2.1.1

Bluetooth for Slax Linux OS

Started by cyrixjames69, October 31, 2020, 09:12:03 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

cyrixjames69

Hello All

I am Cyrix james here and i am very new to Linux. I was looking for  a lightweight Linux and came across Slax OS. its super fast and works smooth.i am trying to install bluetooth module to it .i install blueman it got installed but when iam trying to open it doesnt open.more over when i checked the bluetooth status its shows the follwing messages
Failed to obtain handles for "Service Changed" characteristic.
sap driver initialization failed.
Sap-server:Operation not permitted(1)
which Bluetooth module works with Slax Os.
Kindly guide me to install it and use it .

Rich J

Quote from: cyrixjames69 on October 31, 2020, 09:12:03 AM
Hello All

I am Cyrix james here and i am very new to Linux. I was looking for  a lightweight Linux and came across Slax OS. its super fast and works smooth.i am trying to install bluetooth module to it .i install blueman it got installed but when iam trying to open it doesnt open.more over when i checked the bluetooth status its shows the follwing messages
Failed to obtain handles for "Service Changed" characteristic.
sap driver initialization failed.
Sap-server:Operation not permitted(1)
which Bluetooth module works with Slax Os.
Kindly guide me to install it and use it .

Hi Cyrix james - and welcome to the forum.

Which version of Slax are you running?  You might take a look here -

https://www.slax.org/modules.php?detail=bluez&category=network

It appears that it depends on which version of Slax you have as to how the module is installed.

Rich


cyrixjames69

Quote from: Rich J on November 01, 2020, 08:05:54 AM
Quote from: cyrixjames69 on October 31, 2020, 09:12:03 AM
Hello All

I am Cyrix james here and i am very new to Linux. I was looking for  a lightweight Linux and came across Slax OS. its super fast and works smooth.i am trying to install bluetooth module to it .i install blueman it got installed but when iam trying to open it doesnt open.more over when i checked the bluetooth status its shows the follwing messages
Failed to obtain handles for "Service Changed" characteristic.
sap driver initialization failed.
Sap-server:Operation not permitted(1)
which Bluetooth module works with Slax Os.
Kindly guide me to install it and use it .

Hi Cyrix james - and welcome to the forum.

Which version of Slax are you running?  You might take a look here -

https://www.slax.org/modules.php?detail=bluez&category=network

It appears that it depends on which version of Slax you have as to how the module is installed.

Rich

Quote from: Rich J on November 01, 2020, 08:05:54 AM
Quote from: cyrixjames69 on October 31, 2020, 09:12:03 AM
Hello All

I am Cyrix james here and i am very new to Linux. I was looking for  a lightweight Linux and came across Slax OS. its super fast and works smooth.i am trying to install bluetooth module to it .i install blueman it got installed but when iam trying to open it doesnt open.more over when i checked the bluetooth status its shows the follwing messages
Failed to obtain handles for "Service Changed" characteristic.
sap driver initialization failed.
Sap-server:Operation not permitted(1)
which Bluetooth module works with Slax Os.
Kindly guide me to install it and use it .

Hi Cyrix james - and welcome to the forum.

Which version of Slax are you running?  You might take a look here -

https://www.slax.org/modules.php?detail=bluez&category=network

It appears that it depends on which version of Slax you have as to how the module is installed.

Rich



Dear Rich.

Thanks for your fast response. I installed Slax 64bit  9.11.0

cyrixjames69

Quote from: cyrixjames69 on October 31, 2020, 09:12:03 AM
Hello All

I am Cyrix james here and i am very new to Linux. I was looking for  a lightweight Linux and came across Slax OS. its super fast and works smooth.i am trying to install bluetooth module to it .i install blueman it got installed but when iam trying to open it doesnt open.more over when i checked the bluetooth status its shows the follwing messages
Failed to obtain handles for "Service Changed" characteristic.
sap driver initialization failed.
Sap-server:Operation not permitted(1)
which Bluetooth module works with Slax Os.
Kindly guide me to install it and use it .
Quote from: Rich J on November 01, 2020, 08:05:54 AM
Quote from: cyrixjames69 on October 31, 2020, 09:12:03 AM
Hello All

I am Cyrix james here and i am very new to Linux. I was looking for  a lightweight Linux and came across Slax OS. its super fast and works smooth.i am trying to install bluetooth module to it .i install blueman it got installed but when iam trying to open it doesnt open.more over when i checked the bluetooth status its shows the follwing messages
Failed to obtain handles for "Service Changed" characteristic.
sap driver initialization failed.
Sap-server:Operation not permitted(1)
which Bluetooth module works with Slax Os.
Kindly guide me to install it and use it .

Hi Cyrix james - and welcome to the forum.

Which version of Slax are you running?  You might take a look here -

https://www.slax.org/modules.php?detail=bluez&category=network

It appears that it depends on which version of Slax you have as to how the module is installed.

Rich



Dear Rich..
I have installed the latest Slax 9.10 .any luck to make Bluetooth work

Thanks in advance

Mad Penguin

Hi Cyrix,

I don't think the SAP module is used, so the two "errors" you're seeing I think can be taken as warnings. If you try;

apt purge bluetooth blueman
apt install bluetooth blueman

Then from a terminal session type;
blueman
Assuming it still fails to start, what does it print in the terminal session?
https://twitter.com/garethbult
https://gareth.bult.co.uk


Rich J

Did you look at the link I provided?  It seems that Slax uses bluez module, not blueman.  There is a download available from the link - if that doesn't work, you can contact the developer directly. 

I have no knowledge of Slax but it would appear to be very niche and it is uncertain as to how much support is available.  If you still have issues, perhaps a move to a more popular lightweight distro would be advisable?  ;)

Mad Penguin

Hi Rich, the link you provided is headed by a notice saying Slax now uses 'apt', which I'm presuming means it's debian based. If it's debian based, then the "bluetooth" package should be a metapackage that includes bluez, bluez-tools and some other dependencies. "blueman" is a UI that talks to the bluez API, it's not something I've used recently, but I can't think of any reason why this wouldn't work on Slax assuming that bluez can be made to work. There may be another UI you can use instead of blueman, but that combination should be Ok.

I totally agree it does look very niche, I too would recommend a more mainstream option, especially for new users .. :)
https://twitter.com/garethbult
https://gareth.bult.co.uk