Author Topic: How to stop Kate text editor saving backups?  (Read 637 times)

0 Members and 1 Guest are viewing this topic.

Offline Keith

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1245
  • Karma: 19
  • Gender: Male
  • Linux Novice
    • View Profile
    • Awards
How to stop Kate text editor saving backups?
« on: December 09, 2020, 10:42:29 am »
I became fed up with the newer versions of the gedit text editor which, like many other applications, appears to be moving towards "mouse-only" commands.  I find it inconvenient to keep moving between keyboard and mouse just to do something that I used to be able to do with a few keystrokes while my hands are already on the keyboard.

So I moved to the Kate editor.  It's very good and is very configurable.  However;  I discovered recently that it saves a backup in XDP format of every file-save action.  Apparently this is a format that allows easy conversion between XML and PDF formats.  Not that I would ever want to do that.  And these files just keep mounting up. 

I found this link:  https://www.linuxquestions.org/questions/linux-newbie-8/how-to-prevent-backup-file-creation-kate-and-kwrite-940857/ that explains how to stop Kate from doing this, as follows:
Settings > Configure Kate > Editor Component > Open/Save > Advanced
Uncheck the box next to local files under "Backup on Save"

but when I navigated to that Kate settings page, the box was already un-ticked.

Does anyone have any experience of overcoming this feature?
Thanks.

Keith

{Ubuntu 18.04 on Lenovo Thinkpad T500.   Kate Version 20.04.0}
« Last Edit: December 09, 2020, 10:45:43 am by Keith »

 


SimplePortal 2.3.3 © 2008-2010, SimplePortal