Updates:

Similar topics mod installed, currently shown at the end of a topic

Linux terminal is not responding to any keyboard signal - [SOLVED]

Started by cloudytech147, November 08, 2021, 08:52:59 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

cloudytech147

After my python flask app crushed without exiting, I tried using ctrl-C to stop it, instead of exiting the app I got ^C and for any other signal I tried via my keyboard as well, only control characters, as can be seen below:



To stop the process I had to open the best Linux terminal and send a kill signal from there.

This wasn't the first time I encounter this, What is causing this?

Is there a way to kill the process from within?




Keith

Hi Cloudytech - and welcome to the Forum. 

Please read this link: https://linuxforums.org.uk/index.php?board=209.0 which will advise you how to submit posts. 
Without knowing anything about your computer and OS, we can't really advise you. 

Keith


DavidMcCann

There's nothing wrong with the computer or the keyboard — the problem is just that the Python program is written in such a way that ^C is trapped. The only solution is to suspend it with ^Z and manually kill it, as explained here:
https://codeigo.com/python/terminating-a-python-script