Updates:

You can now choose from a number of pre-installed themes

Change the Linux kernel

Started by Sir Maken, December 08, 2021, 04:30:36 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

Sir Maken

Ubuntu Mainline Kernel Installer shows I have 4 kernels:

5.13.0.22.33 Installed
5.13.0.22.22 Installed
5.13.0.22.21 Installed
5.13.0 Running

I have a problem connecting two monitors (HDMI + DisplayPort)

How do I try each of the newer kernels?

I am using Ubuntu 21.10

DavidMcCann

Those kernels will be very little different from each other — the difference will probably be quite invisible to the user. Information on selecting a kernel when booting and permanently changing the default is in the wiki: https://wiki.ubuntu.com/Kernel/KernelBootParameters

For adding a second monitor, see https://help.ubuntu.com/stable/ubuntu-help/display-dual-monitors.html



Sir Maken

#2
Thanks for your input.

However, I know how to use dual monitors but I cannot use them currently and the cause has not yet been determined.

I use DisplayPort on one monitor and if I connect a cable to the HDMI port  even without another monitor connected to it and then reboot the machine stops (hangs).

Identical if I connect a monitor to the HDMI cable.

However, the displays work fine if I connect the HDMI monitor AFTER I have rebooted. Only thing which does not work is the Display options.

Everything works fine in Windows 10. Thats why I wondered if the kernels may have a change that would affect the problem. I do not want to change the kernel permanently, just test. Also, I didn't install the 3 additional kernels.

DavidMcCann

There are a lot of reports on line discussing similar problems, generally with Windows, and it's been around for several years. Obviously the monitor, computer port, and cable are satisfactory. So, what happens if you connect only the HDMI port and reboot?

Do you have Nvidia graphics? If so, the proprietary driver might help. If you are using Wayland graphics, switching to X might work. Some have solved it by disabling secure boot in the BIOS.

Sir Maken

Thank you,

However, Windows boots fine with both monitors connected, HDMI only is fine on Ubuntu.

I don't have Nvidia and I am not using Wayland, I am using integrated Intel UHD Graphics 630.

Secure boot is disabled.

I feel sure it is the Ubuntu driver which does not work with the mobo I am using - ASUS® TUF GAMING Z590-PLUS WIFI (LGA1200, USB 3.2, PCIe 4.0) - ARGB Ready

ASUS are looking into the possibility of BIOS  or other mobo fault.  Meantime I think I should wait for the next LTS version next year.