Updates:

Similar topics mod installed, currently shown at the end of a topic

HALP. cannot set up vpn on ubuntu

Started by dexxin, January 21, 2022, 04:27:21 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

dexxin

hey guys. i have been going absolutely stir crazy, on this for going on 6 hours straight! cannot get my vpn settings to load at all. i have tried everryytthhiinngg. all sudo commands, zip commands, installed software, lost my marbles and getting the same error. below is the code for the open vpn protocol for perfect privacy. any idea what's going on please? much appreciation. ps have had this exact set up before and never ever had an issue. wahhhhh.


terminal code is as follows (red text at bottom is the root issue):



[email protected]:~$ sudo apt update && sudo apt install openvpn resolvconf

[sudo] password for roni:

Hit:1 http://archive.canonical.com/ubuntu focal InRelease

Hit:2 http://archive.ubuntu.com/ubuntu focal InRelease

Get:3 http://archive.ubuntu.com/ubuntu focal-updates InRelease [114 kB]

Get:4 http://archive.ubuntu.com/ubuntu focal-security InRelease [114 kB]

Get:5 http://archive.ubuntu.com/ubuntu focal-backports InRelease [108 kB]

Get:6 http://archive.ubuntu.com/ubuntu focal-security/main Sources [198 kB]

Get:7 http://archive.ubuntu.com/ubuntu focal-security/main amd64 Packages [1,178 kB]

Get:8 http://archive.ubuntu.com/ubuntu focal-security/main i386 Packages [363 kB]

Get:9 http://archive.ubuntu.com/ubuntu focal-security/universe amd64 Packages [676 kB]

Get:10 http://archive.ubuntu.com/ubuntu focal-security/universe i386 Packages [532 kB]

Fetched 3,283 kB in 2s (2,059 kB/s)                     

Reading package lists... Done

Building dependency tree       

Reading state information... Done

3 packages can be upgraded. Run 'apt list --upgradable' to see them.

Reading package lists... Done

Building dependency tree       

Reading state information... Done

resolvconf is already the newest version (1.82).

openvpn is already the newest version (2.4.7-1ubuntu2.20.04.3).

0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.

[email protected]:~$ cd /etc/openvpn/

[email protected]:/etc/openvpn$ sudo unzip -j linux_op24_udp_v4_AES256GCM_AU_in_ci.zip

unzip:  cannot find or open linux_op24_udp_v4_AES256GCM_AU_in_ci.zip, linux_op24_udp_v4_AES256GCM_AU_in_ci.zip.zip or linux_op24_udp_v4_AES256GCM_AU_in_ci.zip.ZIP.

[email protected]:/etc/openvpn$

Keith

Hi Dexxin - and welcome to the Forum.

Quotehave had this exact set up before and never ever had an issue
Do you mean on this computer with this operating system? 

Please list the contents of /etc/openvpn

Keith


Mad Penguin

Hi dexxin,
It may be that you need to use "openvpn" specifically, but if not, you might like to consider; https://tinc-vpn.org/ (https://tinc-vpn.org/) , I struggled with OpenVPN for many (many) years before finding tinc. I've now been on tinc for probably 4-5 years, the two have quite different characteristics, but I think I would struggle to find a point where OpenVPN wins ..
https://twitter.com/garethbult
https://gareth.bult.co.uk