Author Topic: Forum Updates ...  (Read 1374 times)

0 Members and 1 Guest are viewing this topic.

Offline Mad Penguin

  • Administrator
  • Hero Member
  • *****
  • Posts: 1497
  • Karma: 10024
  • Gender: Male
    • View Profile
    • Awards
Forum Updates ...
« on: June 29, 2010, 11:24:02 am »
Ok, I'm sufficiently happy I've fixed the problem that I'm going to announce it as fixed (!)

You may (or may not) have noticed that from time to time the forums may have served up 'broken' images, in particular some of the images on the front page. (i.e. powered by Linux or the buttons futher down)

After a little tracing it became apparent that the reason the images weren't showing, was that the image headers were (at random) being corrupted by an error in "memcache_set", which is part of the Forum's (and PHP's) caching sub-system. Turns out to be a known issue with PHP's memcache interface so after upgrading all the servers to the latest version, it does appear that the problem has gone away.

(MP: rant-on)

By default it seems Ubuntu 9.10 server uses version 3.0.1 of the PHP memcache code, this was released on the second of Feb 2008. The fix was released in September 2008 in version 3.0.2. Arhrhrhrhrhrhr! Which planet are they on - this is a critical bug fix in basic web server infrastructure and they are nearly two years behind, and they STILL haven't upgraded their repo's !!  We're now on 3.0.4 which was released in Feb 2009 .. I'd say I'm speechless but I'm not, it's just that if I said what I wanted to say I'd have to moderate myself.

I feel a "Linux UK" distribution coming on!

(MP: rant-off)

For anyone else unfortunate enough to experience this issue, here's the fix;

Quote
apt-get install php5-dev
apt-get install php-pear
pecl install memcache-3.0.4

And if you're running any memory resident PHP like fastcgi , don't forget to restart it!
Check it with php -r "phpinfo();" > temp
(look at the contents of temp for the memcache version string)

 


SimplePortal 2.3.3 © 2008-2010, SimplePortal