Author Topic: new to *linux  (Read 7551 times)

0 Members and 1 Guest are viewing this topic.

Offline Mark Greaves (PCNetSpec)

  • Hero Member
  • *****
  • Posts: 18277
  • Karma: 477
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: new to *linux
« Reply #15 on: July 24, 2010, 07:08:21 am »
You left out the bit I needed... the ID string for the Huawei modem... similar to this  ID 12d1:1001

But as it's mentioning E620 modem, I'm guessing it *has* switched to "modem" mode (can't be sure without the  ID string)

If this is the case, It should be working, so recheck your settings in network manager.
« Last Edit: July 24, 2010, 07:26:24 am by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline jmyeom

  • Jr. Member
  • **
  • Posts: 18
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: new to *linux
« Reply #16 on: July 24, 2010, 07:31:28 pm »
if you look at the pictures, i have it just like that, except this:

in the username box, it says three, if i dont have it in, it disconnects me without even thinking about it,
if i put it on "three", my signal bar goes mad, does some sort of round loading thing, going that fast i cant tell what way its ment to be going..
i let this run how it is, left it, went for a cig, came back around 5 minutes later, nothing, still doing it
i was able to hover over it and it said something, but i cant remembers, ill edit this post with that info
ill also edit with the info from lsusb, ill do a copy and paste job

edit:
here is the info
http://img137.imageshack.us/img137/557/screenshot5w.png

the text changes with that info and "attempting to connect"
the hewlett-packard is my memory stick, so thats fine
hope this help
« Last Edit: July 24, 2010, 07:41:20 pm by jmyeom »

Offline Mark Greaves (PCNetSpec)

  • Hero Member
  • *****
  • Posts: 18277
  • Karma: 477
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: new to *linux
« Reply #17 on: July 24, 2010, 09:00:43 pm »
Is this a PAYG 3 UK dongle?... if so, try this... go into the network manager and try changing the APN to three.co.uk

Right-Click the Network Manager icon by your clock... select Edit Connections... click the Mobile Broadband tab... highlight the connection and select Edit... change the APN: from 3internet to three.co.uk... click Apply... click Close.

Now try connecting.
« Last Edit: July 24, 2010, 09:10:45 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline jmyeom

  • Jr. Member
  • **
  • Posts: 18
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: new to *linux
« Reply #18 on: July 24, 2010, 10:08:07 pm »
same results, without putting "three" as username, it does nothing
put it as three, just makes the loader spin and say the same thing

Offline Mark Greaves (PCNetSpec)

  • Hero Member
  • *****
  • Posts: 18277
  • Karma: 477
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: new to *linux
« Reply #19 on: July 24, 2010, 10:31:07 pm »
Is there any way you can get this PC connected to the internet?... wireless or ethernet cable?

is it s 3 UK dongle? (or orange/t-mobile/vodafone etc.)

is it PAYG or contract?

are you sure you can get a signal where you are? (has it connected from the same place in windows)
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline jmyeom

  • Jr. Member
  • **
  • Posts: 18
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: new to *linux
« Reply #20 on: July 24, 2010, 10:48:49 pm »
the dongle is used to send these massages from a windows machine,
its pay as you go,
its a 3 dongle, and the network is 3,
i can get a signal
i have not tried wireless or wired, as the amount of trouble i would need to get though to get it,

if it is best for me to be connected to the internet, ill sort somethign out within the next few hours, just post back if you need it, if no reply within a hour i may have to set it up tomorrow

Offline Mark Greaves (PCNetSpec)

  • Hero Member
  • *****
  • Posts: 18277
  • Karma: 477
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: new to *linux
« Reply #21 on: July 25, 2010, 12:41:31 am »
I need you to install...

Preferably the Ubuntu Updates.... this will take a while.

wvdial and gnome-ppp... so we can see what is happening during the connection process and see where the problem lies

So connect it to a router with an ethernet cable, let it get ALL the updates... then open a terminal and type:
Code: [Select]
sudo apt-get update && sudo apt-get install wvdial gnome-ppp
Once it's done... test your connection (first change the APN back to 3internet)... if it still doesn't work, I'll talk you through setting up and using Wvdial/Gnome PPP to connect, this will save a logfile of commands sent and received so we can work out where the connection fails.

Also it may be a good idea to check in Windows "Network Connections" to see what the settings for the PPP dial -up connection settings are for the 3 dongle (if that's where they are stored... can't remember and no 3g dongle to check with)
« Last Edit: July 25, 2010, 12:57:20 am by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline jmyeom

  • Jr. Member
  • **
  • Posts: 18
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: new to *linux
« Reply #22 on: July 25, 2010, 01:28:23 am »
right thanks, tomorrow ill head down the nearest e-cafe, ill update it and dl what you said, in the mean time im trying to install xampp, this is the most important, as i can just transfer files and upload, but need xampp on the netbook

http://www.apachefriends.org/en/xampp-linux.html

thats where im looking, i downloaded it, and its on a memory stick "F:/"

when i put the command in it says

tar xvfz xampp-linux-1.7.3a.tar.gz -C /opt
you may not specify more then one "-acdtrux" option

any ideas?


edit:

also, i got half a gig of ram on my netbook, shall i upgrade to 1.5gb of ram?, is it work it, or will i  see no difference

Offline Mark Greaves (PCNetSpec)

  • Hero Member
  • *****
  • Posts: 18277
  • Karma: 477
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: new to *linux
« Reply #23 on: July 25, 2010, 01:47:30 am »
There is no such thing as an F: drive in Linux

Copy the xampp-linux-1.7.3a.tar.gz file to your "home" directory on the Ubuntu PC, then open a terminal and type:
Code: [Select]
cd ~
sudo tar xvfz xampp-linux-1.7.3a.tar.gz -C /opt
hitting enter after each line and entering the root password when asked. (REMEMBER, Linux commands ARE case sensitive)

To start XAMPP, open a terminal and type:
Code: [Select]
sudo /opt/lampp/lampp start
Or
Code: [Select]
su
/opt/lampp/lampp start
hitting enter after each line.

More RAM is always a good thing... if it's available Linux will use it.
« Last Edit: July 25, 2010, 02:06:52 am by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline jmyeom

  • Jr. Member
  • **
  • Posts: 18
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: new to *linux
« Reply #24 on: July 25, 2010, 02:36:55 am »
still getting you may not specify more then one "-acdtrux" option
also, i cant put into home/, permission denied, i put into home/jmyeom (user account) instead

edit:
i read it after you change it, i change the -c to -C and it seems to be working, it looks likes its unpacking atm, will post results

says i need to start it as root, and putting in su asks for a password, i put in my password, and it says failure, any ideas?
sudo /opt/lampp/lampp start

not on 2 lines
« Last Edit: July 25, 2010, 02:41:39 am by jmyeom »

Offline Mark Greaves (PCNetSpec)

  • Hero Member
  • *****
  • Posts: 18277
  • Karma: 477
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: new to *linux
« Reply #25 on: July 25, 2010, 02:57:38 am »
su or sudo WILL ask for the root password... but it should be "your" password if you are logged on as the primary user (first account created)... at least in Ubuntu or Mint.

if you are logged on as any other user than the first user account you created, the root password will be the password of the first account... again this applies to Ubuntu and Mint, and only as long as you haven't changed the root password.

try:
Code: [Select]
sudo su
hit enter... then "your" password... then:
Code: [Select]
/opt/lampp/lampp start
hit enter.

Or

Code: [Select]
sudo /opt/lampp/lampp start
hit enter... then "your" password (and yes this is all on one line)

And remember, in a terminal when you enter your password you won't "See" anything being entered, but it IS being entered and passwords ARE case sensitive too... also when I say "your home" i mean the home folder of the current user which will be /home/username
« Last Edit: July 25, 2010, 03:17:27 am by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline jmyeom

  • Jr. Member
  • **
  • Posts: 18
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: new to *linux
« Reply #26 on: July 25, 2010, 03:18:32 am »
thanks, i think im starting to unserstand linux a bit, but still hate the command line, have to do everything inside of it :P

ive installed xampp, but i cant change anything, it says i need permission, the currect owner is "root", how would i got about this, if im not mistaken its chmod?

how would i do it for a folder?, i can only see info for files
thanks

Offline Mark Greaves (PCNetSpec)

  • Hero Member
  • *****
  • Posts: 18277
  • Karma: 477
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: new to *linux
« Reply #27 on: July 25, 2010, 03:27:15 am »
if you are on about editing files ANYWHERE on the system EXCEPT your home directory, you will need root privileges... DON'T chmod them.

start the program you are going to use you edit them with root privileges... let's say I want to use gedit to edit a text file... you can either:
Code: [Select]
sudo gedit
then browse to the file within gedit

or to open the file directly in gedit
Code: [Select]
sudo gedit /path/to/file/filename
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline jmyeom

  • Jr. Member
  • **
  • Posts: 18
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: new to *linux
« Reply #28 on: July 25, 2010, 03:29:07 am »
no, my linux path, htdocs is not accessble,


also, su asked for a password, my normal password does not work

sudo asks for the password for jmyeom, my password works


i need to chmod my xampp folder, how would i do this?

Offline Mark Greaves (PCNetSpec)

  • Hero Member
  • *****
  • Posts: 18277
  • Karma: 477
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: new to *linux
« Reply #29 on: July 25, 2010, 03:48:58 am »
use sudo su  instead of su then and "your" password

You SHOULDN'T need to chmod the directory.

If you want to browse your directories in nautilus with root acess:
Code: [Select]
sudo nautilus
will start nautilus (file manager) with root access.

If you want to know chmod syntax, or any other command... type
man commandname

so for the man (manual) page for the command chmod
Code: [Select]
man chmod
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

 


SimplePortal 2.3.3 © 2008-2010, SimplePortal