Updates:

You can now choose from a number of pre-installed themes

S - Video

Started by klbmanu, November 20, 2010, 06:46:26 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

klbmanu

I am using a Dell 1520 notebook running ubuntu into a Bush TV. I want to put my laptop display onto the TV. I have an s video cable but it doesn't appear on any AV channels so is there some way i have to set it up on my laptop?

Mark Greaves (PCNetSpec)

is that an NVIDIA GeForce 8600M GT ?

If so which drivers are you using ? (ie. Nouveau or NVIDIA)

If unsure, send the output from:
sudo lshw -C display
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk


klbmanu

I entered that and got this back:
*-display:0             
       description: VGA compatible controller
       product: Mobile GM965/GL960 Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: [email protected]:00:02.0
       version: 0c
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:27 memory:fea00000-feafffff memory:e0000000-efffffff(prefetchable) ioport:efe8(size=8)
  *-display:1 UNCLAIMED
       description: Display controller
       product: Mobile GM965/GL960 Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2.1
       bus info: [email protected]:00:02.1
       version: 0c
       width: 64 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list
       configuration: latency=0
       resources: memory:feb00000-febfffff

Mark Greaves (PCNetSpec)

Try rebooting with the TV attached, then go to System>Preferences>Monitors, and try hitting the "Detect Monitors" button... also try setting the resolution to 800 X 600 and see if that works.

If not, you may have to create/edit your /etx/X11/xorg.conf file.
can you let me knowif this fies exists, and if it does, what are its contents.

Is it the cable that came from Dell, as I'm reading a lot of people had problems with after market cables (ie. does it work in Window?)
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

klbmanu

It's an aftermarket Sony cable. Neither of them worked, i don't think that file is there either.


Mark Greaves (PCNetSpec)

#5
Have you tried the cable in Windows (from the Dell), and did it work ?
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

klbmanu

I don't have windows on my laptop.

Mark Greaves (PCNetSpec)

That could be a problem... I could talk you through creating a xorg.conf file, but with an intel graphics card there is a risk of ending up with no graphics... fixable, but only if you know what you're doing.

a) it may not work anyway.
and
b) if it IS a problem with the cable it definitely won't work.

so what do you want to do ?
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

klbmanu

I'll have a go at it, might as well


Mark Greaves (PCNetSpec)

Make sure the TV is connected and switched on whilst you do this...

First generate a xorg.conf.new file...

IMPORTANT - you're going to end up with no GUI until you restart X, so you might want to print this off

To generate xorg.conf.new you need to switch to a virtual console using the key-combo Ctrl+Alt+F1

You will then need to log-in with your username and password

First make sure you are in your home directory
cd ~

Now execute the following commands:
This will stop X.
sudo service gdm stop

Now generate an xorg.conf file:
sudo Xorg -configure
(remember Linux IS case sensitive)

This has generated the file xorg.conf.new in your home directory

Now restart X:
sudo service gdm start

Your desktop GUI will start again...Next, open a terminal and backup your /etc/X11/xorg.conf file (if there is one)
sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.bak

Then move xorg.conf.new from your home directory to the /etc/X11/ directory, and rename it xorg.conf
sudo cp ~/xorg.conf.new /etc/X11/xorg.conf

Now reboot.




If anything goes wrong and you are left in a console, just delete the xorg.conf file
sudo rm /etc/X11/xorg.conf
and/or copy the backup over the new one
sudo cp /etc/X11/xorg.cong.bak /etc/X11/xorg.conf
then after a reboot, everything will be back to how it was.
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

klbmanu

I've done that and the file is there. What do i do next?

Mark Greaves (PCNetSpec)

Can you send us the contents of your /etc/X11/xorg.conf file:

gedit /etc/X11/xorg.conf

You could also try this again:

With the TV attached and switched on, go to System>Preferences>Monitors, and try hitting the "Detect Monitors" button... if both monitors are detected, put a tick in "Same image in all monitors"... also, you may have to try different resolutions.

Let me know if both monitors aren't detected.
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

klbmanu

Section "ServerLayout"
Identifier     "X.org Configured"
Screen      0  "Screen0" 0 0
InputDevice    "Mouse0" "CorePointer"
InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
ModulePath   "/usr/lib/xorg/modules"
FontPath     "/usr/share/fonts/X11/misc"
FontPath     "/usr/share/fonts/X11/cyrillic"
FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath     "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath     "/usr/share/fonts/X11/Type1"
FontPath     "/usr/share/fonts/X11/100dpi"
FontPath     "/usr/share/fonts/X11/75dpi"
FontPath     "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
FontPath     "built-ins"
EndSection

Section "Module"
Load  "extmod"
Load  "dri"
Load  "glx"
Load  "dbe"
Load  "record"
Load  "dri2"
EndSection

Section "InputDevice"
Identifier  "Keyboard0"
Driver      "kbd"
EndSection

Section "InputDevice"
Identifier  "Mouse0"
Driver      "mouse"
Option     "Protocol" "auto"
Option     "Device" "/dev/input/mice"
Option     "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
Identifier   "Monitor0"
VendorName   "Monitor Vendor"
ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "NoAccel"            # [<bool>]
        #Option     "SWcursor"            # [<bool>]
        #Option     "ColorKey"            # <i>
        #Option     "CacheLines"          # <i>
        #Option     "Dac6Bit"            # [<bool>]
        #Option     "DRI"                # [<bool>]
        #Option     "NoDDC"              # [<bool>]
        #Option     "ShowCache"          # [<bool>]
        #Option     "XvMCSurfaces"        # <i>
        #Option     "PageFlip"            # [<bool>]
Identifier  "Card0"
Driver      "intel"
VendorName  "Intel Corporation"
BoardName   "Mobile GM965/GL960 Integrated Graphics Controller"
BusID       "PCI:0:2:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device     "Card0"
Monitor    "Monitor0"
SubSection "Display"
Viewport   0 0
Depth     1
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     4
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     8
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     15
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     16
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     24
EndSubSection
EndSection


Thats the Xorg file. I've got the tv showing up as a monitor but nothing appears on the screen.

Mark Greaves (PCNetSpec)

have you tried different resolutions ?
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

klbmanu

I've tried every resolution possible