Author Topic: Aiptek tablet driver for linux is confusing  (Read 8886 times)

0 Members and 1 Guest are viewing this topic.

Offline Ava

  • Jr. Member
  • **
  • Posts: 22
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Aiptek tablet driver for linux is confusing
« on: March 13, 2011, 12:28:11 am »
I've downloaded the Linux version from here -
http://www.aiptek.eu/index.php?option=com_product&task=view&productid=184&Itemid=542

I found a Readme file, because there is no clear place to start in the midst of all these strange folders... the instructions are thus (with edited-out gaps):

(click to show/hide)

This makes no sense to me. Where do I start? :( The beginning doesn't make sense...

I should add - I installed the Windows driver using Wine, though it doesn't seem to have worked. The tablet DOES work, but not well enough to really use.

I'd be really grateful for any help :/ Thanks. :)
« Last Edit: March 13, 2011, 02:28:45 am by Mark Greaves (PCNetSpec) »

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 18208
  • Karma: 476
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Aiptek tablet driver for linux is confusing
« Reply #1 on: March 13, 2011, 01:01:31 am »
I wouldn't bother with those drivers, they're quite old and only appear to contain drivers for kernels up to 2.6.30.1

According to this:
https://help.ubuntu.com/community/AiptekTablet

The drivers for your tablet are contained in the xserver-xorg-input-aiptek package, available from the Ubuntu repositories through your package manager (Synaptic).

or can be installed with:
Code: [Select]
sudo apt-get install xserver-xorg-input-aiptek

BUT - They are in the "universe" repo, so you will have to enable that first.

Whilst enabling "universe", you might as well enable "multiverse" and "partner" at the same time...



Instructions on how to enable the "universe", "multiverse" and "partner" repositories -

Go to System>Administration>Synaptic Package Manager

When Synaptic opens, go to Settings>Repositories>Ubuntu Software (tab)
Put ticks in:
Community maintained Open Source software (universe)
and
Software restricted by copyright or legal issues (multiverse)

Click the "Other Software" (tab), and put ticks in:
Canonical Partners
and (if you want)
Canonical Partners (Source Code)

Click Close

Now click the "Reload" button on the toolbar.



If you REALLY want to attempt the "Ubuntu" instructions from the ReadMe, let me know.

But be aware they only contain drivers for kernels <= 2.6.30.1 YOUR kernel is 2.6.35 (in Maverick), so they *probably* wont build properly, if at all.

But effectively, what they want you to do is....

(click to show/hide)

Does that make sense ?

I agree, it's not the best laid out ReadMe I've ever seem ;)
« Last Edit: March 13, 2011, 05:34:41 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline Ava

  • Jr. Member
  • **
  • Posts: 22
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Aiptek tablet driver for linux is confusing
« Reply #2 on: March 13, 2011, 10:06:22 pm »
Hmm... well, that (the first part, not the readme instructions) did work, thanks :) Though it doesn't seem to have improved the tablet's performance  :-\ Do you think it might just not be very linux-compatible, or have I missed something...?

(The problem is that as I hover the pen over the tablet, it follows it on the monitor - however, after I tap it, it no longer hovers again until I lift the pen up further than that hovering point, and put it back down again... if that makes any sense  :-\)
« Last Edit: March 13, 2011, 10:13:57 pm by Ava »

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 18208
  • Karma: 476
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Aiptek tablet driver for linux is confusing
« Reply #3 on: March 13, 2011, 10:59:32 pm »
[EDIT]
See next posting BEFORE doing this.
[END EDIT]

Have you followed the other instructions on the link in my last post?

!) Create a file called 69-xserver-xorg-input-aiptek.rules containing the text:

Quote
ACTION!="add|change", GOTO="xorg_aiptek_end"
KERNEL!="event[0-9]*", GOTO="xorg_aiptek_end"

ATTRS{idVendor}=="08ca", ENV{x11_driver}="aiptek", SYMLINK+="input/aiptektablet"

LABEL="xorg_aiptek_end"

Copy that file to the /lib/udev/rules.d directory.


2) Create a file called 10-aiptek.conf containing the text:

Quote
Section "InputClass"
        Identifier "pen"
        MatchProduct "Aiptek|AIPTEK|aiptek"
        MatchDevicePath "/dev/input/event*"
        Driver "aiptek"
        Option "SendCoreEvents" "true"
        Option "USB" "on"
        Option "Type" "stylus"
        Option "Mode" "absolute"
        Option "zMin" "0"
        Option "zMax" "511"
EndSection

If you are using Ubuntu 10.10 (Maverick), Copy that file to the /usr/share/X11/xorg.conf.d directory.

3) Run:

Code: [Select]
xinput get-button-map Aiptek

it will probably return "1 2 3 4 5" then  try remapping the buttons with:

Code: [Select]
xinput set-button-map Aiptek 1 3 2 4 5

or

Code: [Select]
xinput set-button-map Aiptek 2 1 3 4 5

You'll have to work out the button mapping order yourself.

BE AWARE, the button mapping changes won't survive a reboot, so you'll have to script that and add the script to the startup applications.

If you don't know how... once you get it right by manually playing with the mappings, write the command that worked best down and let me know what it is, and I'll talk you through running it automatically at system startup.
« Last Edit: March 14, 2011, 01:57:02 am by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 18208
  • Karma: 476
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Aiptek tablet driver for linux is confusing
« Reply #4 on: March 13, 2011, 11:14:13 pm »
Don't follow the instructions in the previous posting yet.

There seems to be a newer driver for the AIPTEK Slim Tablet U600 Premium II... see here:
https://help.ubuntu.com/community/TabletSetupWizardpen

Instructions to follow.
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 18208
  • Karma: 476
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Aiptek tablet driver for linux is confusing
« Reply #5 on: March 13, 2011, 11:32:43 pm »
OK, installing the newer driver...

First lets get rid of the previous driver, just in case it conflicts...
Code: [Select]
sudo apt-get purge xserver-xorg-input-aiptek

Now lets add the PPA for the correct drivers:
Code: [Select]
sudo add-apt-repository ppa:doctormo/xorg-wizardpen

Update the apt cache:
Code: [Select]
sudo apt-get update

Install the (correct) xserver-xorg-input-wizardpen driver:
Code: [Select]
sudo apt-get install xserver-xorg-input-wizardpen

Reboot your machine. It should just work.

If it doesn't, let me know as there are also troubleshooting and calibration sections at this link.
https://help.ubuntu.com/community/TabletSetupWizardpen
« Last Edit: March 13, 2011, 11:46:41 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 18208
  • Karma: 476
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Aiptek tablet driver for linux is confusing
« Reply #6 on: March 14, 2011, 01:27:23 am »
OK folks... installing the xserver-xorg-input-aiptek drivers then following the configuration instructions here:
https://help.ubuntu.com/community/TabletSetupWizardpen

Caused Ubuntu 10.10 to hang at bootup, so don't bother with them... at least in Maverick.
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 18208
  • Karma: 476
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Aiptek tablet driver for linux is confusing
« Reply #7 on: March 14, 2011, 01:58:33 am »
@Ava

At least you found out how to use a LiveCD to undo changes :)

OK, first thing I want you to do is uninstall the xserver-xorg-input-wizardpen drivers.
Code: [Select]
sudo apt-get purge xserver-xorg-input-wizardpen
hit enter, and your password when asked... and hit Y when asked if you want to continue.

Next, let's disable the PPA.
Go to System>Administration>Synaptic Package Manager
when synaptic opens, go to Settings>Repositories>Other Software (tab)

Look for the entry:
http://ppa.launchpad.net/doctormo/xorg-wizardpen/ubuntu maverick main
and remove the tick from box at the beginning of that line.
and if it exists, also remove the tick from:
http://ppa.launchpad.net/doctormo/xorg-wizardpen/ubuntu maverick main (Source Code)
when you've removed the ticks, click Close and if a message about "Repositories changed" pops up, Close that too.

Now, on the main Synaptic toolbar, click the Reload button... when that's done, close Synaptic.

Ok that's got rid of those.



Now let's reinstall the drivers we were first trying to configure... xserver-xorg-input-aiptek... and carry on trying to configure those.

To reinstall them:
Code: [Select]
sudo apt-get install xserver-xorg-input-aiptek

Now carry on with the instructions in this posting (above)
http://linuxforums.org.uk/general-help-advice/aiptek-tablet-driver-for-linux-is-confusing/msg39252/#msg39252
« Last Edit: March 14, 2011, 02:00:38 am by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline Ava

  • Jr. Member
  • **
  • Posts: 22
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Aiptek tablet driver for linux is confusing
« Reply #8 on: March 14, 2011, 06:06:57 pm »
Well, I got this far:

Quote
Copy that file to the /lib/udev/rules.d directory.

I get this message:
Error while copying "69-xserver-xorg-input-aiptek.rules".
There was an error copying the file into /lib/udev/rules.d.

Error opening file '/lib/udev/rules.d/69-xserver-xorg-input-aiptek.rules': Permission denied

Offline Ava

  • Jr. Member
  • **
  • Posts: 22
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Aiptek tablet driver for linux is confusing
« Reply #9 on: March 14, 2011, 06:09:28 pm »
In trying to edit the permissions of /lib/udev/rules.d/69-xserver-xorg-input-aiptek.rules it says -
You are not the owner, so you cannot change these permissions

Apparantly the owner is 'root'... I thought that was me?

Edit - just figured out how to access it, so this shouldn't be a problem now

Edit 2 - err... the udev folder is now empty. :/ At least through root...

Edit 3 - Ok, never mind this, sorted it out now
« Last Edit: March 14, 2011, 06:44:14 pm by Ava »

Offline Ava

  • Jr. Member
  • **
  • Posts: 22
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Aiptek tablet driver for linux is confusing
« Reply #10 on: March 14, 2011, 06:49:31 pm »
Quote
Run:

Code: [Select]
xinput get-button-map Aiptek

This comes up:
unable to find device Aiptek




Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 18208
  • Karma: 476
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Aiptek tablet driver for linux is confusing
« Reply #11 on: March 15, 2011, 09:24:20 pm »
Section "InputClass"
   Identifier "wizardpen"
   MatchDevicePath "/dev/input/event3"
   MatchProduct "WALTOP|Tablet"
   Driver "wizardpen"
EndSection


Just that... no more.
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 18208
  • Karma: 476
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Aiptek tablet driver for linux is confusing
« Reply #12 on: March 16, 2011, 01:36:01 am »
OK, yet another set of instructions... (if unsure about any of this, look for me in chat)

We're got 2 options here
1) retry the aiptek drivers but with 10-aiptek.conf renamed to 50-aiptek.conf

Remove wizardpen drivers:
Code: [Select]
sudo apt-get purge xserver-xorg-input-wizardpen
then install aiptek drivers:
Code: [Select]
sudo apt-get install xserver-xorg-input-aiptek

Now download these 2 files from my dropbox -
http://dl.dropbox.com/u/11876059/50-aiptek.conf
http://dl.dropbox.com/u/11876059/69-xserver-xorg-input-aiptek.rules

now open nautilus as root:
Code: [Select]
sudo nautilus
navigate to /usr/share/X11/xorg.conf.d and if 10-aiptek.conf exists, delete it.
now copy the 50-aiptek.conf you just downloaded to that same directory (ie. /usr/share/X11/xorg.conf.d)

now navigate to /lib/udev/rules.d
now copy the 69-xserver-xorg-input-aiptek.rules you just downloaded to that same directory (ie. /lib/udev/rules.d)... overwriting the existing file if there is one.

Ok, now reboot and try your tablet.

If your PC won't boot....
remember the pci=nomsi boot parameter
and the Places>Home Folder>xxxGB FileSystem... sudo nautilus
tricks, then delete:
/usr/share/X11/xorg.conf.d/50-aiptek.conf
and
/lib/udev/rules.d/69-xserver-xorg-input-aiptek.rules

the renaming of 10-aiptek.conf to 50-aiptek.conf fix can be found here:
http://www.control-alt-deleted.net/genius-g-pen-560-and-ubuntu-1010
and
https://help.ubuntu.com/community/AiptekTablet
and a lot of other places.



2) According to this:
http://ubuntuforums.org/showthread.php?t=1595648

The "Wacom" drivers now work in Ubuntu 10.10... your tablet is actually a rebadged wacom, so worth a go.

First make sure you have all the latest updates on your system as they only work with the latest kernel:
Code: [Select]
sudo apt-get update && sudo apt-get upgrade
if asked say yes to continue, and wait for it to finish.

now remove the aiptek driver:
Code: [Select]
sudo apt-get purge xserver-xorg-input-aiptek

Now open Synaptic and see if the xserver-xorg-input-wacom drivers are already installed (ie. green box)

if not, install them... either through Synaptic or with
sudo apt-get install xserver-xorg-input-wacom

open the  /usr/share/X11/xorg.conf.d/50-wacom.conf file (as root) in gedit:
Code: [Select]
sudo gedit /usr/share/X11/xorg.conf.d/50-wacom.conf

Find the (top section that reads

Quote
Section "InputClass"
   Identifier "Wacom class"
# WALTOP needs a patched kernel driver, that isn't in mainline lk yet,
# so for now just let it fall through and be picked up by evdev instead.
#   MatchProduct "Wacom|WALTOP|WACOM"
   MatchProduct "Wacom|WACOM|Hanwang"
   MatchDevicePath "/dev/input/event*"
   Driver "wacom"
EndSection


and change it to read:

Quote
Section "InputClass"
   Identifier "Wacom class"
# WALTOP needs a patched kernel driver, that isn't in mainline lk yet,
# so for now just let it fall through and be picked up by evdev instead.
   MatchProduct "Wacom|WALTOP|WACOM"
#   MatchProduct "Wacom|WACOM|Hanwang"
   MatchDevicePath "/dev/input/event*"
   Driver "wacom"
EndSection


Leave the other section as they are.

so the whole file now reads (click the Spoiler button below to view)

(click to show/hide)

Now reboot, and test the tablet.

Worst case scenario... reboot to the LiveCD, and delete the:
/usr/share/X11/xorg.conf.d/50-wacom.conf
file.
« Last Edit: March 16, 2011, 03:58:05 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline Ava

  • Jr. Member
  • **
  • Posts: 22
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Aiptek tablet driver for linux is confusing
« Reply #13 on: March 16, 2011, 10:19:41 pm »
Unfortunately the first didn't change it, and with the second I had to delete the file to get the computer working again, so that didn't work either :/

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 18208
  • Karma: 476
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Aiptek tablet driver for linux is confusing
« Reply #14 on: March 20, 2011, 06:02:13 pm »
For future readers, this problem was solved in chat...

These instructions are for 10.10 (Maverick) ONLY... if you are using 10.04 (Lucid) you will have to compile the latest wacom.ko, and update the xorg-macros to version 1.8... see the links at the bottom..

Eventually we settled on the xserver-xorg-input-wacom drivers which are already installed in Ubuntu 10.10 by default.

But we had to edit the:
MatchProduct
line in
/usr/share/X11/xorg.conf.d/50-wacom.conf

Getting the MatchProduct line wrong (on this system) caused the Xserver to stall during bootup, and the system wouldn't boot

The original line read:

Quote
   MatchProduct "Wacom|WACOM|Hanwang"


but
Code: [Select]
lsusb -v
reported the Product and Vendor ID's as:

Quote
idVendor           0x172f Waltop International Corp.
idProduct          0x0034 Slim Tablet


So editing the line to read:
   MatchProduct "Slim|Waltop|Wacom|WACOM|Hanwang"
Would probably have worked.

But instead we decided to have the hardware matched by vendor instead... so we commented out the MatchProduct line, eg.:
#   MatchProduct "Wacom|WACOM|Hanwang"

and added this MatchVendor line just beneath it:
Quote
   MatchVendor "Waltop|WALTOP|waltop"


so the whole (new), 50-wacom.conf file reads:

Quote
Section "InputClass"
   Identifier "Wacom class"
# WALTOP needs a patched kernel driver, that isn't in mainline lk yet,
# so for now just let it fall through and be picked up by evdev instead.
#   MatchProduct "Wacom|WALTOP|WACOM"
#   MatchProduct "Wacom|WACOM|Hanwang"
#   MatchProduct "Slim|Waltop|WALTOP|WACOM|Wacom"
   MatchVendor "Waltop|WALTOP|waltop"
   MatchDevicePath "/dev/input/event*"
   Driver "wacom"
EndSection

Section "InputClass"
   Identifier "Wacom serial class"
   MatchProduct "Serial Wacom Tablet"
   Driver "wacom"
EndSection

Section "InputClass"
        Identifier "Wacom serial class identifiers"
        MatchProduct "WACf|FUJ02e5|FUJ02e7"
        Driver "wacom"
EndSection


# N-Trig Duosense Electromagnetic Digitizer
Section "InputClass"
   Identifier "Wacom N-Trig class"
   MatchProduct "HID 1b96:0001|N-Trig Pen"
   MatchDevicePath "/dev/input/event*"
   Driver "wacom"
   Option "Button2" "3"
EndSection


then (in a terminal) entering:
Code: [Select]
lsmod
showed the wacom module wasn't listed, so wasn't loading automatically... so we added the line
wacom
to the /etc/modules file.

Rebooted, and Voila... a working tablet.



The important thing was to get the idVendor and/or idProduct lines -

idVendor           0x172f Waltop International Corp.
idProduct          0x0034 Slim Tablet

by running:
Code: [Select]
lsusb -v

then make sure the MatchProduct line and or MatchVendor line in 50-wacom.conf had those as the FIRST ID to look for, as in:

   MatchProduct "Slim|Waltop|WALTOP|WACOM|Wacom"
or
   MatchVendor "Waltop|WALTOP|waltop"

(Worth noting that it DOES seem to be case sensitive... if that first Waltop read WALTOP it stalled the Xserver, because the idVendor string the tablet was using read Waltop not WALTOP... see the lsusb -v output above).

then make sure the wacom module is being loaded.



Useful links:

http://ubuntuforums.org/showpost.php?p=6546012&postcount=1

http://ubuntuforums.org/showpost.php?p=9496609&postcount=1

http://ubuntuforums.org/showthread.php?t=1595648

http://ubuntuforums.org/showpost.php?p=9252390&postcount=1

http://ubuntuforums.org/showpost.php?p=9573142&postcount=1

« Last Edit: April 03, 2011, 11:06:29 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

 


SimplePortal 2.3.3 © 2008-2010, SimplePortal