Author Topic: Acer Aspire One Linpus Lite - Firefox web browser won't open  (Read 16454 times)

0 Members and 1 Guest are viewing this topic.

Offline Mark Greaves (PCNetSpec)

  • Hero Member
  • *****
  • Posts: 18277
  • Karma: 479
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • Awards
Acer Aspire One Linpus Lite - Firefox web browser won't open
« on: March 16, 2011, 04:41:24 pm »
[EDIT]

Firstly, do yourself a favour and consider getting rid of the default Linpus Lite operating system, and installing Peppermint 3 instead .. this will give you easy access to all the latest software including the latest version of Firefox, and a more familiar (Windows like) desktop interface ..see the link below:
http://linuxforums.org.uk/index.php?topic=10313.0

But if you MUST stick with the old/outdated/crippled/unsupported Linpus Lite .. carry on reading ..

These instructions are for the default version of Firefox 2 that comes pre-installed on the Acer Aspire One... NOT for Firefox 4, 5, 6, or 7 failing to start after an update... for that, click this link:

Install Firefox 7 on an Acer Aspire One running Linpus Lite Linux

[END EDIT]


If your Acer aspire One with Linpus Lite (Linux) was suddenly powered OFF with Firefox 2 (as used in Linpus Lite) still open, the browsers lock files may still exist, so Firefox won't start, and you may get a message saying Firefox is still running.

The fix is to rename the hidden ~/.mozilla directory....

Be Aware - This will remove any bookmarks, addons, and customisations you have made to Firefox, and restore it to its default state.

1.) Open a terminal... you can do this by hitting Alt+F2 and then typing terminal and clicking the Run button

2.) In the terminal enter:
Code: [Select]
thunar
and hit enter.

3.) When thunar opens hit Ctrl+H to display hidden files. (files/folders that start with . are hidden by default)

4.) Look for the folder called .mozilla

5.) Right-click the .mozilla folder, select "Rename"... and change its name to .mozilla-old

Firefox should now start without issue... (*may* require a reboot to kill any already running Firefox processes).




If after renaming the ~/.mozilla directory, Firefox starts ONCE, but fails to open again...

Ask yourself these 2 questions -
Did Firefox stop working immediately after a system update?
and
Where you asked to enter settings for the GoogleToolbar when Firefox started?

If the answer to both questions is "Yes"...

This appears to be due to an incompatibility between the new GoogleToolbar addon and Firefox 2 (as used in Linpus Lite).

The fix is to delete the ~/.mozilla/firefox/xxxxxx .default/GoogleToolbarData directory, and the ~/.mozilla/firefox/xxxxxx.default/extensions/{long giberish name} directory.
(where "xxxxxx" is a bunch of letters and/or numbers)

1.) Open a terminal... you can do this by hitting Alt+F2 and then typing terminal and clicking the Run button

2.) In the terminal enter:
Code: [Select]
thunar
and hit enter.

3.) When thunar opens hit Ctrl+H to display hidden files. (files/folders that start with . are hidden by default)

4.) Look for the folder called .mozilla, and enter it.

5.) Look for the folder called firefox, and enter it.

6.) Look for the folder called xxxxxx .default, and enter it.
(where xxxxxx is a series on letters and/or numbers)

7.) Look for the folder called GoogleToolbarData, and DELETE it

8.) Look for the folder called extensions, and enter it.

9.) Look for the folder called {long giberish name}, and DELETE it.
(where "long giberish name" is a long string of numbers and/or letters)
If there is more than one folder... you can either delete them all which will require you to reinstall any Firefox addons you use, or try to work out which one contains the GoogleToolbar extension.

Firefox should now start without issue... (*may* require a reboot to kill any already running Firefox processes).




Or you could try starting Firefox in "safe mode" then deleting or disabling the GoogleToolbar addon.
(I haven't tested this method, so can't say for sure that it works).

First reboot your PC (to kill any already running firefox processes), but when it starts, DON'T attempt to open Firefox normally... insted, follow these instructions.

To open Firefox in SAFE MODE...

Hit Alt+F2... in the resulting dialogue (text) box enter:
firefox -safe-mode
now click the Run button.
(don't miss out the space between the "x" and the "-", and it MUST be all lower case)

In the resulting dialogue, put a tick in "Disable all addons" (or similar)... then click "Continue in safe mode" (or similar).

Then if Firefox starts... Go to Tools>Addons>PlugIns (or Extensions), and delete or disable the GoogleToolbar plugin/extension.

Close Firefox, and restart it normally.

It *may* be better to disable the addon rather than delete it, as it *may* get reinstalled if you delete it... but that's for you to discover, I haven't got an AA1 so I can't test it. ;)

If anyone tries the "safe mode" method for disabling the GoogleToolbar addon, and finds it works or not, could you please let us know... for the benefit of future readers... thanks.



Another option would be to install Firefox 7.0.1 and the latest Flashplayer:
Install Firefox 7 on an Acer Aspire One running Linpus Lite Linux
(click the link above)
« Last Edit: February 03, 2013, 11:57:50 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline eveonpoll

  • Jr. Member
  • **
  • Posts: 2
  • Karma: 2
  • I've just joined!
    • View Profile
    • Awards
Re: Acer Aspire One Linpus Lite - Firefox web browser won't open
« Reply #1 on: May 08, 2011, 01:10:52 pm »
hI..  You're an absolute star!!  :)   I tried everyone's advice and then came to yours about OPENING IN SAFE MODE
Worked for me.
I can't thank you enough!! xx ;D

Offline Mark Greaves (PCNetSpec)

  • Hero Member
  • *****
  • Posts: 18277
  • Karma: 479
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • Awards
Re: Acer Aspire One Linpus Lite - Firefox web browser won't open
« Reply #2 on: May 08, 2011, 01:19:27 pm »
You're very welcome, and thanks for the feedback... it will be a big help for future readers :)
« Last Edit: May 12, 2011, 12:17:55 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline wendy

  • Jr. Member
  • **
  • Posts: 2
  • Karma: 2
  • I've just joined!
    • View Profile
    • Awards
Re: Acer Aspire One Linpus Lite - Firefox web browser won't open
« Reply #3 on: June 29, 2011, 12:36:03 pm »
 just want to thank you it actually worked!!! and it was so simple thanks to you!!! very grateful.

Offline Mark Greaves (PCNetSpec)

  • Hero Member
  • *****
  • Posts: 18277
  • Karma: 479
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • Awards
Re: Acer Aspire One Linpus Lite - Firefox web browser won't open
« Reply #4 on: June 29, 2011, 12:38:40 pm »
Thanks wendy, it's always nice to know these things helped someone :)
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline richm

  • Jr. Member
  • **
  • Posts: 1
  • Karma: 2
  • I've just joined!
    • View Profile
    • Awards
Re: Acer Aspire One Linpus Lite - Firefox web browser won't open
« Reply #5 on: August 24, 2011, 05:47:35 pm »
thanks VERY much for this - it solved my firefox problem :)
R

Offline Mark Greaves (PCNetSpec)

  • Hero Member
  • *****
  • Posts: 18277
  • Karma: 479
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • Awards
Re: Acer Aspire One Linpus Lite - Firefox web browser won't open
« Reply #6 on: August 24, 2011, 09:51:44 pm »
You're more than welcome :)
« Last Edit: August 24, 2011, 09:53:41 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

 


SimplePortal 2.3.3 © 2008-2010, SimplePortal