Author Topic: Updating flashplayer on Acer Aspire One running Linpus Lite  (Read 4038 times)

0 Members and 1 Guest are viewing this topic.

Offline taeasz

  • Jr. Member
  • **
  • Posts: 13
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Having now successfully installed Firefox 4.0.1 with much help from Mark Greaves on this forum, is there an easy fix for updating the flashplayer?

According to Adobe website latest verion available for Linux is 10.3.181.14.  The version shown on my AA1 is 10.1.85.3.

Would be very grateful for any guidance. Thanks.

Offline Mark Greaves (PCNetSpec)

  • Hero Member
  • *****
  • Posts: 18277
  • Karma: 477
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • Awards
Re: Updating flashplayer on Acer Aspire One running Linpus Lite
« Reply #1 on: May 18, 2011, 01:54:53 pm »
Go here:
http://get.adobe.com/flashplayer/?no_redirect
and in the drop down menu, select .tar.gz for other Linux, and click the "Download" button.

From this point onwards, I'm going to assume it downloaded to your "Downloads" directory.

Open a terminal, and enter:
Code: [Select]
cd ~/Downloads

Create a ~/.mozilla/plugins directory:
Code: [Select]
mkdir ~/.mozilla/plugins
(don't worry if it says it already exists... just move on to the next command)

Then extract the libflashplayer.so file from the archiive to the ~/.mozilla/plugins directory:
Code: [Select]
tar -zxvf install_flash_player_10_linux.tar.gz --directory ~/.mozilla/plugins libflashplayer.so

Close ALL open Firefox instances, and restart Firefox... now in FF go to Tools > Addons > Plugins and check it says:
Shockwave Flash 10.3r181

If there are 2 "Shockwave Flash" plugins listed in Firefox... just disable the older one, and restart Firefox.

You're done ;)



@taeasz

None of the above commands contain the "sudo" that was giving you problems, so you will be fine running them from an $ prompt.
Just copy/paste the above commands.
« Last Edit: May 18, 2011, 02:01:07 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline taeasz

  • Jr. Member
  • **
  • Posts: 13
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Updating flashplayer on Acer Aspire One running Linpus Lite
« Reply #2 on: May 18, 2011, 03:49:12 pm »
Many thanks again Mark - that worked like a dream :)
now got Flash 10.3r181 in FF4 add-ons

Offline mako6

  • Full Member
  • ***
  • Posts: 232
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Updating flashplayer on Acer Aspire One running Linpus Lite
« Reply #3 on: September 06, 2011, 06:16:52 pm »
the latest flashplayer is 183.7  (install_flash_player_10_linux.tar.gz). Are isntructions on that all the same?

Offline Mark Greaves (PCNetSpec)

  • Hero Member
  • *****
  • Posts: 18277
  • Karma: 477
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • Awards
Re: Updating flashplayer on Acer Aspire One running Linpus Lite
« Reply #4 on: September 06, 2011, 07:03:29 pm »
Yup they should do... but if you follow the instructions here:
http://linuxforums.org.uk/netbooks/acer-aspire-one-linpus-lite-flash-player/msg62581/#msg62581

you'll end up with 10.3.183.7 ... I updated the version in my dropbox a couple of days ago ;)

All you are aiming to do is extract the new libflashplayer.so and put it in ~/.mozilla/plugins overwriting the one already there.

Then restart Firefox.
« Last Edit: September 12, 2011, 03:19:35 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

 


SimplePortal 2.3.3 © 2008-2010, SimplePortal