Author Topic: running 3G on Linux  (Read 6824 times)

0 Members and 1 Guest are viewing this topic.

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 18267
  • Karma: 476
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: running 3G on Linux
« Reply #15 on: April 22, 2010, 12:59:56 pm »
You are trying to install the 3connect WINDOWS software onto a Linux PC, it's not going to work, and is not needed.

In 10.04

Open a terminal and type:
Code: [Select]
sudo gedit /etc/wvdial.conf
gedit will open and you should see something like -
Quote
[Dialer Defaults]
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Modem Type = Analog Modem
Baud = 460800
New PPPD = yes
Modem = /dev/ttySL0
ISDN = 0
; Phone = <Target Phone Number>
; Password = <Your Password>
; Username = <Your Login Name>
Change it so it reads:
Quote
[Dialer Defaults]
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Modem Type = Analog Modem
Baud = 9600
New PPPD = yes
Modem = /dev/ttyUSB0
ISDN = 0
Phone = *99#
Password = Anything
Username = Anything
and save it.

Now press Alt + F2 (keycombo), and when the Run Application box opens, type:
Code: [Select]
wvdial Defaults
and click the Run button (notice the capital D in this command)

You should be connected now.

Now open the package manager (synaptic) and install gnome-ppp, and use the settings above to configure it.

From now on, use GNOME-PPP to connect to the internet.

Or you can continue to use the Alt + F2 and wvdial Defaults method.

BTW for screenshots, can you use -
Applications->Accessories->Screen shot
and put the tick in Select area to grab to keep the picture size down a bit, or just copy and paste the text.
« Last Edit: April 22, 2010, 01:16:49 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline Toolless

  • Jr. Member
  • **
  • Posts: 21
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: running 3G on Linux
« Reply #16 on: April 22, 2010, 01:21:59 pm »
I can use anything at the moment coz the screens blank
Please see the above photo

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 18267
  • Karma: 476
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: running 3G on Linux
« Reply #17 on: April 22, 2010, 02:16:54 pm »
Has the PC locked up completely, or can you open a console (a full screen terminal)... try Ctrl+Alt+F2... If it enters a terminal (bit like a dos prompt), you will have to type your username, then password to log in (remember password will show nothing as you type)... then try the following command:
Code: [Select]
sudo service gdm restart
and hit enter.
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline Toolless

  • Jr. Member
  • **
  • Posts: 21
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: running 3G on Linux
« Reply #18 on: April 22, 2010, 11:01:23 pm »
Has the PC locked up completely, or can you open a console (a full screen terminal)... try Ctrl+Alt+F2... If it enters a terminal (bit like a dos prompt), you will have to type your username, then password to log in (remember password will show nothing as you type)... then try the following command:

I dont think it did lock up copmletlly but I dont know what happened as im no expert but I think its a password issue
But its all working now
If it plays up again i'll have to post back


If you are running 10.04....

On the bar at the top of your screen, select: System > Preferences > Network Connections
Select the Mobile Broadband tab, and select Add... and it will walk you through the connection setup.


Well this time I have followed your instructions and it seems to have all worked out



Yes im on Ubuntu on the net
So job well done and thanks

 


SimplePortal 2.3.3 © 2008-2010, SimplePortal