Author Topic: Asus EeePC with Linux OS  (Read 4366 times)

0 Members and 1 Guest are viewing this topic.

Offline Robingreathead

  • Jr. Member
  • **
  • Posts: 3
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Asus EeePC with Linux OS
« on: July 21, 2011, 08:59:26 pm »
My netbook works fine on my router wirelessly but  am having problems accessing wifi hotspots. I can see them listed but when I click 'connect' a message immediately comes up 'failed'. It has not always done this. I did link up to my son's BT hub and have heard that that can sometimes reconfigure something or other. I have deleted his  from the list but no avail. Being over 70 I am not at all knowledgable in this arena. Any help would be greatly appreciated.

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 18231
  • Karma: 476
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Asus EeePC with Linux OS
« Reply #1 on: July 21, 2011, 09:44:22 pm »
Are you running the EeePC's default Linux distribution (Xandros) ?

I take it these are UNSECURED hotspots ?

This appears to be a known issue with the EeePC's default Linux distribution (Xandros)... as far as I can tell, there is NO fix, but there is a workaround.

If you see here:
http://forum.eeeuser.com/viewtopic.php?id=12998

The workaround appears to be to delete ALL saved wireless connections, and recreate them.

It *may* be that *if* you have connected to the hotspot before, all you have to do is delete *that* connection and try again.

BE AWARE, deleting ALL connections will mean you have to set up your home wireless connection again... if you don't know how to do this, don't delete the connections.

If you are unable (or don't want) to delete the connections... the next time you are at a hotspot you can't connect to... open a terminal and enter:
Code: [Select]
iwconfig
hit enter, and copy the output from that command, so you can post it back here when you get home.

and do the same thing with this command:
Code: [Select]
iwlist wlan0 scanning

That last command will ONLY work if your wireless network interface's "logical name" is wlan0
You should be able to get the logical name by entering:
Code: [Select]
sudo lshw -C network
then if it is something other than wlan0, adjust the command accordingly.
« Last Edit: July 21, 2011, 09:50:34 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline Robingreathead

  • Jr. Member
  • **
  • Posts: 3
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Asus EeePC with Linux OS
« Reply #2 on: July 22, 2011, 05:37:12 pm »
Many thanks for your advice. I will try deleting all on the list the next time I am at a WiFi hotspot and see if that does the trick. I have made a note of all the settings required for my router. I note that often one is recommended to open a terminal. I am afraid I do not understand how to access a 'terminal'. Could you please explain.
Thank you. Robin Greathead

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 18231
  • Karma: 476
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Asus EeePC with Linux OS
« Reply #3 on: July 22, 2011, 05:47:57 pm »
I'm not really familiar with the ASUS's "EeePC" implementation of Xandros, but you *should* be able to open a terminal by hitting Ctrl+Alt+T

And if this:
http://www.laptopmag.com/advice/tips/5-asus-eee-pc-customization-tips-youll-love.aspx?page=all
is to be believed, you can even get a bottom panel with "Start" menu, or a full "proper" KDE desktop if you wish ("Terminal" should then be in the menus somewhere)... but it must be said I cannot vouch for the accuracy of that article, so probably best to just use the Ctrl+Alt+T option for now... unless you're feeling particularly brave ;)

BTW, the first picture on the above link shows an open terminal, it's the black window where you can enter commands.
« Last Edit: July 22, 2011, 06:04:09 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline Robingreathead

  • Jr. Member
  • **
  • Posts: 3
  • Karma: 0
  • I've just joined!
    • View Profile
    • Awards
Re: Asus EeePC with Linux OS
« Reply #4 on: July 30, 2011, 07:59:38 pm »
To conclude this topic for anyone who might have the same problem. I followed Mark Greeve's advice and deleted the single entry on the list which related to my house router and in consequence was able to log on to a wifi hotspot successfully. However I had to delete this entry [not just disconnect] before I could connect up to my router again. Not a problem, just change the setting, WEP to WPA, and put in the password. Problem solved. Thanks.

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 18231
  • Karma: 476
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Asus EeePC with Linux OS
« Reply #5 on: July 31, 2011, 12:07:16 am »
Not a perfect solution by any means... but workable for now I suppose... if I find anything better I'll let you know.

Thanks for the feeback :)
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

 


SimplePortal 2.3.3 © 2008-2010, SimplePortal