Updates:

Similar topics mod installed, currently shown at the end of a topic

Left click drag drop and highlight

Started by RichKelley, December 10, 2011, 09:46:31 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

RichKelley

Hi there, since installing ubuntu on my laptop i have lost some features of my keyboard and touch pad. The one that hurts most is the left click, drag n drop and highlight  text fields seem to be disabled. Can anyone help please?

Mark Greaves (PCNetSpec)

#1
I'm sorry but you'll have to explain the issues a bit better, I'm not sure what you mean ?

Are you saying left-click on the mouse/trackpad isn't working at all ? .. ie. left-clicking the desktop or a file/folder gives you no menu, etc.

You cannot drag and drop files and folders at all ?

And you cannot highlight text ?

Surely these are all right-click operations, not left-click ? <-- future readers ignore this, just me being an idiot and mixing up my left and right .. how embarrassing  :-[

Which text fields seem to be disabled ?

Can you also tell us which version of Ubuntu you are running, and which desktop .. and preferably the make/model of laptop.
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk


RichKelley

Yeah sorry. i used to be able to hold down the left click and drag or highlight text using the touchpad.

Mark Greaves (PCNetSpec)

Darn .. I'm getting my left and right mixed up  ::)

Does it work with a mouse .. ie. is it a trackpad driver issue, or an issue with left-click itself ?

It would still help to know your Ubuntu version, which desktop evironment, and make/model of your laptop :)
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

RichKelley

Vaio fz21s and ubuntu 11.10. The pad seems to be fine its the left click. I dont have an usb mouse to try sorry.


Mark Greaves (PCNetSpec)

#5
Try this ..

Open a terminal and enter:
sudo modprobe -r psmouse
then
sudo modprobe psmouse proto=imps

Does your touchpad work correctly now ?

If it DOESN'T work .. a reboot will revert the driver back to where you are now (ie. undo the changes).




IF IT DOES .. to make this permanent ..

In a terminal enter:
sudo gedit /etc/modprobe.d/psmouse.conf

When gedit opens an empty file, add this line to the file -

options psmouse proto=imps

(above text enlarged only for clarity)

SAVE the file, and exit gedit.

Now it should still work after a reboot.
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

RichKelley

I lost my pad after the 1st code. My pad is working fine its just the left click thats the trouble

Mark Greaves (PCNetSpec)

#7
You WILL loose the pad after the first command (you are unloading the driver) .. you'll get it back after the second command (you're reloading the driver with an option).

Did you enter the second command ?
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

RichKelley



Mark Greaves (PCNetSpec)

OK, lets see if this has anything to do with compiz

Open a terminal and run:
sudo apt-get install gnome-session-fallback

once that command has completed, and left you back at an $ prompt ..

Log off

Now at the login screen .. click the little cog icon (by where you enter your password) and select Gnome Classic (No Effects) .. now log in.

Does the trackpad work properly now ? .. ignore the different desktop, you can always switch back, it's just a test to see if the (No Effects) desktop fixes the issue .. if it does, it likely a compiz issue, and we can look for a fix.
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Mark Greaves (PCNetSpec)

Does this make a difference:
sudo modprobe -r psmouse
then
sudo modprobe psmouse proto=exps
?

Remember, you'll loose the touchpad after the first command, and get it back after the second .. if it works, let me know and I'll tell you how to make it survive a reboot.
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

RichKelley

No need for that Mark, I dont know why but i decided to click the other side of the button and it worked. must be the effects of age on the poor thing. thx all the same Mark.  :)

Mark Greaves (PCNetSpec)

#12
Heh .. no worries :)

Thinking about it, I should have got you to run:
xev
and checked if clicking the left button was registering an event at all .. FIRST.
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk