Author Topic: Netbook lost volume  (Read 3211 times)

0 Members and 1 Guest are viewing this topic.

Offline Toonman

  • Hero Member
  • *****
  • Posts: 904
  • Karma: 15
  • Freeing the World form the Microsoft scurge!
    • View Profile
    • Awards
Netbook lost volume
« on: February 16, 2012, 05:53:57 pm »
My Samsung NC10 has lost its volume.  :(

It has a valid Volume active applet and volume is on max and not ticked to mute.  I have tried it with youtube, and every format I have including music MP3........nothing..at all.

Samsung NC 10 using Ubuntu 10.04
Life is for living.  RIP Keith Floyd.   ;)

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 18231
  • Karma: 476
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Netbook lost volume
« Reply #1 on: February 16, 2012, 09:19:55 pm »
You haven't been messing with the sound device in sound settings have you ?

Nothing unticked in alsamixer ?

Maybe time to consider a change to something like Peppermint ?
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline Toonman

  • Hero Member
  • *****
  • Posts: 904
  • Karma: 15
  • Freeing the World form the Microsoft scurge!
    • View Profile
    • Awards
Re: Netbook lost volume
« Reply #2 on: February 18, 2012, 07:57:51 am »
I do not know what alsamixer is and I have not messed with the settings.  My only beef with putting on another distro is I have a nice setup  with all my programs I like and Ubuntu 10.04 has a low resource demand.  what would you suggest about which distro of Peppermint to use? I only have 1gb of ram the netbook is dual boot so I do not want to install on the wrong partition.


Thanks

PS  Have you got your broadband yet?
Life is for living.  RIP Keith Floyd.   ;)

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 18231
  • Karma: 476
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Netbook lost volume
« Reply #3 on: February 18, 2012, 12:08:47 pm »
Yup, I've got broadband back .. thank god, and thanks for asking :)

alsamixer is a command line mixer for ALSA (Advanced Linux Sound Architecture), believe it or not ;)

PeppermintOS (Two) is actually less resource hungry than 10.04 as it uses the LXDE desktop (which is why I love and recommend it on low resource systems) .. it runs on an Acer Aspire One netbook perfectly, and the AA1 has less RAM than your NC10 (only 500mb) and the same CPU (Atom N270) .. that said, if you're happy with 10.04 lets try to fix that .. PeppermintOS (Two) is based on Ubuntu 11.04 so support is likely to run out before support for 10.04 does (10.04 being an LTS release), but I would guess there will be a new version of Peppermint out before then.

Anywho .. troubleshooting ..

Did the sound stop working after installing anything, or after running a system update ?

Here's the standard test for sound - with the volume on MAX and unmuted, open a terminal and enter:
Code: [Select]
aplay /usr/share/sounds/alsa/Front_Center.wav
hit enter .. did you hear anything ?

Try creating a new user account .. does sound work if you log on as the new user ?

What is the output from:
Code: [Select]
sudo aplay -l

Do you get a long listing of .ko files when you run:
Code: [Select]
find /lib/modules/`uname -r` | grep snd

What is the output from:
Code: [Select]
lspci -v | grep -A7 -i "audio"
« Last Edit: February 18, 2012, 12:34:15 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline Toonman

  • Hero Member
  • *****
  • Posts: 904
  • Karma: 15
  • Freeing the World form the Microsoft scurge!
    • View Profile
    • Awards
Re: Netbook lost volume
« Reply #4 on: February 20, 2012, 12:45:02 pm »
Still no volume.

Here is the output from the first request

**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC272 Analog [ALC272 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

There are no .ko files

laptop:/$ find /lib/modules/`uname -r` | grep snd

And finally

laptop:/$ lspci -v | grep -A7 -i "audio"


I may consider Mint.  I have this netbook as a dual boot but do not know why.  I have not used Windoze on this since........I can't remember.


Ok just booted into Windows partition ( now I need a shower  ;)). No sound!  Must be a fault on my netbook :-[




« Last Edit: February 20, 2012, 12:56:23 pm by Toonman »
Life is for living.  RIP Keith Floyd.   ;)

Offline BkS

  • BkS Media Founder
  • Hero Member
  • *****
  • Posts: 1691
  • Karma: 49
  • Gender: Male
  • sudo service reality-check start
    • View Profile
    • BkS Media
    • Awards
Re: Netbook lost volume
« Reply #5 on: February 20, 2012, 02:12:18 pm »
I have two possible conclusions here.

A) Your laptop speaks have popped from either being played loud for long periods of time, or something has been spilled on them. (Listen for the distorted sound. Wait you can't.. XD)

B) The wires connecting the speakers have melted, from a large burst of currents in the wires and lots of heat.


If you have headphones, test to see if the work in the jack sockets. If you get sound your sound card is dead yet.
If you try to look through Windows, you can see what the person is doing.
If you try to look through a Penguin, it WILL bite you.

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 18231
  • Karma: 476
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Netbook lost volume
« Reply #6 on: February 20, 2012, 08:35:28 pm »
First, check you haven't somehow disabled the sound card in the BIOS.

If:
Code: [Select]
lspci -v | grep -A7 -i "audio"
returned nothing .. your sound hardware isn't being seen by the OS



Also, are you SURE that:
Code: [Select]
find /lib/modules/`uname -r` | grep snd
returned nothing ?

If nothing is returned by the above command, run:
Code: [Select]
sudo apt-get install --reinstall linux-generic

Once that's finished, REBOOT.

Now see if your sound works .. if not, check that alsamixer is installed:
Code: [Select]
alsamixer
did alsamixer start ?

If so (in alsamixer), make sure "PCM" and "Front" are unmuted.

If not run:
Code: [Select]
sudo apt-get install alsa-utils gnome-alsamixer
REBOOT and test again.

Let me know how you get on.
« Last Edit: February 20, 2012, 09:24:08 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline Toonman

  • Hero Member
  • *****
  • Posts: 904
  • Karma: 15
  • Freeing the World form the Microsoft scurge!
    • View Profile
    • Awards
(Resolved) Re: Netbook lost volume
« Reply #7 on: February 21, 2012, 10:31:18 am »
Re-instaled the mixer as per Mark's instructions, went into properties and found that the Analogue headphone was checked (no idea why!) Unchecked and hey presto!

Thanks Mark.  :)  I still may upgrade to Peppermint as there are a few niggles that keep arising lately.
Life is for living.  RIP Keith Floyd.   ;)

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 18231
  • Karma: 476
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Netbook lost volume
« Reply #8 on: February 21, 2012, 10:40:18 am »
Let me know if you do, because I'm interested in peoples opinion of Peppermint as an every day workhorse .. specially in comparison to Ubuntu/Mint.
« Last Edit: February 21, 2012, 10:41:51 am by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

Offline Toonman

  • Hero Member
  • *****
  • Posts: 904
  • Karma: 15
  • Freeing the World form the Microsoft scurge!
    • View Profile
    • Awards
Re: Netbook lost volume
« Reply #9 on: February 21, 2012, 10:45:46 am »
Yes I will let you know Mark.  I'm will be moving over to Peppermint on this Netbook and deleting the Windows partition.  I will also look at Putting Peppermint onto my main laptop but I will have to keep the Windows partition on that as some of my photography programs will not work with Wine and 'The Gimp along with others has not kept up.....yet!

What would be the best version of Peppermint for my netbook?  Samsung NC10 1gb ram
also my Toshiba Equium 2gb ram?

Thanks
Life is for living.  RIP Keith Floyd.   ;)

Offline Mark Greaves (PCNetSpec)

  • Administrator
  • Hero Member
  • *****
  • Posts: 18231
  • Karma: 476
  • Gender: Male
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
    • Awards
Re: Netbook lost volume
« Reply #10 on: February 21, 2012, 10:57:17 am »
If you're talking about compatibility, I can't say for sure, but I'd start by trying the latest PeppermintOS (Two) .. if you run into problems, we'll attempt to sort them out :)

Meanwhile, I'll have a look around the interweb and see if I can find out if anyone has any info on Peppermint on an NC10.

As PeppermintOS (Two) is based on Ubuntu 11.04 I doubt if there will be many problems, and if they're fixable in Ubuntu, they'll be fixable in Peppermint :)

Something to bear in mind is that PeppermintOS (One) and PeppermintOS (Ice) were based on Ubuntu 10.04 LTS and therefore will receive updates until 10.04's end of life (April 2013) .. whereas PeppermintOS (Two) will only receive updates until 11.04's end of life (Oct 2012) .. Though I'm guessing that PeppermintOS (Three) will be out by then and will probably be based on Ubuntu 12.04, which as a Long Term Support (LTS) release will be supported for 3 years.

Ubuntu Release (and life) Cycle
« Last Edit: February 21, 2012, 12:20:23 pm by Mark Greaves (PCNetSpec) »
WARNING: You are logged into reality as 'root'
logging in as 'insane' is the only safe option.
pcnetspec.co.uk

 


SimplePortal 2.3.3 © 2008-2010, SimplePortal