11.10 problem

Hi all… (sorry not Linux literate yet… so be gentle)…
I have 11.10 installed on my Aspire laptop. All was well until an update the other night. Now it will not recognise my display settings or allow me to update the Nvida card and is only showing quite low resolution settings.
It allowed me to load a previous version, pre update, last night and all was well again. However I dont know how I got to that screen.
How can I solve the problem please?
Many thanks

Hi cagey thoughts, and welcome to the forum.

Have you been playing with the display resolution in:-
System Settings > Display
Nvidia Settings

Does this get to where you were before in Unity … click the applications lens (on the sidebar, looks like a little magnifying glass with a + in it) … in the “search” box, enter additional drivers … click on the “Additional Drivers” icon ?

You shouldn’t have to change the drivers at each bootup ???

@Mark: He is talking about the kernel update that was released last night.

@Cagey - If you start up your laptop, after the “Acer” BIOS screen disappears, hold shift until you see:

GRUB Loading…

You’ll be presented with kernels installed on the machine, selected "previous versions.

You should now be able to select an older version of the kernel your running.

If you can do that, we can either fix the issue regarding the update, OR we can adjust the GRUB config file so that it boots up in the previously selected kernel automatically.

What I don’t get though is that it was only a patch for kernel 2.6.38. So I’m unsure why he isn’t getting a display on the update. Perhaps the broke something with X11?


If you’re referring to the kernel update that was released to fix the vulnerabilities … as you said, that was for kernels < 2.6.38-14

Which applies to 11.04, not 11.10 … 11.10 used a later kernel from the get-go

The reason the graphics drivers also need updating (or indeed all third-party kernel modules) is because of “an unavoidable application binary interface (ABI) change”

See here:

I’m not arguing with your solution … they may indeed have just updated the 11.10 kernel too … and booting an earlier kernel is definitely worth checking :slight_smile:

I’m not talking about Natty though. I’m talking about Oneiric. My brother got the update last night too.

See the bit I added to my last posting … your mention of 2.6.38 is what threw me, as 11.10 doesn’t use 2.6.38

Mind you if he’s using the nvidia drivers from the repo’s, I would have expected those to have been updated at the same time ???

If he was using the proprietary drivers however … I’d expect they’d need to be manually updated.

Oh, crappy. I get confused sometimes. :frowning: I forgot Oneiric used the 3.0.0 kernel.

I’d suggest you update to the NVIDIA 295.33 drivers. There’s a thread in the tips & tricks section I made on how to go about doing that.

I’d still suggest your idea of booting an earlier kernel first … if the driver works properly with an earlier kernel, we can take things from there.

Thanx everyone… much appreciated…
did the shift key and came up with…

“Ubuntu with Linux”
etc… selected “Previous Linux Versions”…

top of the list was version 19… but below was version
this seems to work ok. It allows the resolution to be back at 1920x1080… rather than the 1280x768 of version 19. Also version 17 allows the additional drivers to see the Nvida drivers and says that he recommended one is Active.

when i allowed it to boot back into ver 19 and tried Update Manager… it says “failed to download repository information” and “the package was last updated 56 days ago”… In Additional Drivers when I tried to Activate… it went through the motions of downloading the drivers but eventually said “sorry the installation of this driver failed”… and told me to see “/var/log/jockey.log”. Although I cant seem to find this on a search…

hope the above info helps?

Many thanx

Are you saying that when booted to the latest kernel, the update manager doesn’t work ?

If when booted to the newest kernel ( you open a terminal (Ctrl+Alt+T) and enter:

sudo apt-get update && sudo apt-get upgrade

hit enter, and your password when asked … what is returned in the terminal ?

Hi Mark…
This may be too much info for you… soz if it is…

keith@keith-Aspire-8930:~$ sudo apt-get update && sudo apt-get upgrade
[sudo] password for keith:
Ign http://extras.ubuntu.com oneiric InRelease
Ign http://gb.archive.ubuntu.com oneiric InRelease
Ign http://gb.archive.ubuntu.com oneiric-updates InRelease
Ign http://gb.archive.ubuntu.com oneiric-backports InRelease
Ign http://security.ubuntu.com oneiric-security InRelease
Hit http://extras.ubuntu.com oneiric Release.gpg
Ign http://gb.archive.ubuntu.com oneiric-proposed InRelease
Hit http://packages.medibuntu.org oneiric InRelease
Hit http://gb.archive.ubuntu.com oneiric Release.gpg
Hit http://gb.archive.ubuntu.com oneiric-updates Release.gpg
Get:1 http://security.ubuntu.com oneiric-security Release.gpg [198 B]
Hit http://extras.ubuntu.com oneiric Release
Ign http://ppa.launchpad.net oneiric InRelease
Ign http://ppa.launchpad.net oneiric InRelease
Ign http://ppa.launchpad.net maverick InRelease
Hit http://gb.archive.ubuntu.com oneiric-backports Release.gpg
Get:2 http://security.ubuntu.com oneiric-security Release [40.8 kB]
Hit http://ppa.launchpad.net oneiric Release.gpg
Hit http://gb.archive.ubuntu.com oneiric-proposed Release.gpg
Hit http://gb.archive.ubuntu.com oneiric Release
Ign http://ppa.launchpad.net oneiric Release.gpg
Hit http://gb.archive.ubuntu.com oneiric-updates Release
Hit http://ppa.launchpad.net maverick Release.gpg
Hit http://gb.archive.ubuntu.com oneiric-backports Release
Hit http://gb.archive.ubuntu.com oneiric-proposed Release
Hit http://ppa.launchpad.net oneiric Release
Hit http://extras.ubuntu.com oneiric/main Sources
Hit http://gb.archive.ubuntu.com oneiric/main Sources
Hit http://packages.medibuntu.org oneiric/free Sources
Ign http://ppa.launchpad.net oneiric Release
Hit http://extras.ubuntu.com oneiric/main i386 Packages
Ign http://extras.ubuntu.com oneiric/main TranslationIndex
Hit http://gb.archive.ubuntu.com oneiric/restricted Sources
Hit http://gb.archive.ubuntu.com oneiric/universe Sources
Hit http://gb.archive.ubuntu.com oneiric/multiverse Sources
Hit http://gb.archive.ubuntu.com oneiric/main i386 Packages
Hit http://ppa.launchpad.net maverick Release
Get:3 http://security.ubuntu.com oneiric-security/main Sources [36.6 kB]
Hit http://gb.archive.ubuntu.com oneiric/restricted i386 Packages
Hit http://gb.archive.ubuntu.com oneiric/universe i386 Packages
Hit http://gb.archive.ubuntu.com oneiric/multiverse i386 Packages
Hit http://gb.archive.ubuntu.com oneiric/main TranslationIndex
Hit http://gb.archive.ubuntu.com oneiric/multiverse TranslationIndex
Hit http://gb.archive.ubuntu.com oneiric/restricted TranslationIndex
Ign http://ppa.launchpad.net oneiric/main TranslationIndex
Hit http://ppa.launchpad.net oneiric/main Sources
Hit http://ppa.launchpad.net oneiric/main i386 Packages
Ign http://ppa.launchpad.net oneiric/main TranslationIndex
Hit http://gb.archive.ubuntu.com oneiric/universe TranslationIndex
Hit http://gb.archive.ubuntu.com oneiric-updates/main Sources
Hit http://gb.archive.ubuntu.com oneiric-updates/restricted Sources
Hit http://gb.archive.ubuntu.com oneiric-updates/universe Sources
Hit http://gb.archive.ubuntu.com oneiric-updates/multiverse Sources
Hit http://gb.archive.ubuntu.com oneiric-updates/main i386 Packages
Hit http://gb.archive.ubuntu.com oneiric-updates/restricted i386 Packages
Hit http://gb.archive.ubuntu.com oneiric-updates/universe i386 Packages
Hit http://gb.archive.ubuntu.com oneiric-updates/multiverse i386 Packages
Hit http://packages.medibuntu.org oneiric/non-free Sources
Hit http://ppa.launchpad.net maverick/main i386 Packages
Ign http://ppa.launchpad.net maverick/main TranslationIndex
Hit http://gb.archive.ubuntu.com oneiric-updates/main TranslationIndex
Get:4 http://security.ubuntu.com oneiric-security/restricted Sources [1,959 B]
Get:5 http://security.ubuntu.com oneiric-security/universe Sources [13.3 kB]
Get:6 http://security.ubuntu.com oneiric-security/multiverse Sources [1,646 B]
Get:7 http://security.ubuntu.com oneiric-security/main i386 Packages [97.8 kB]
Hit http://gb.archive.ubuntu.com oneiric-updates/multiverse TranslationIndex
Hit http://gb.archive.ubuntu.com oneiric-updates/restricted TranslationIndex
Hit http://gb.archive.ubuntu.com oneiric-updates/universe TranslationIndex
Hit http://gb.archive.ubuntu.com oneiric-backports/main Sources
Hit http://gb.archive.ubuntu.com oneiric-backports/restricted Sources
Hit http://gb.archive.ubuntu.com oneiric-backports/universe Sources
Hit http://gb.archive.ubuntu.com oneiric-backports/multiverse Sources
Hit http://gb.archive.ubuntu.com oneiric-backports/main i386 Packages
Hit http://gb.archive.ubuntu.com oneiric-backports/restricted i386 Packages
Hit http://packages.medibuntu.org oneiric/free i386 Packages
Hit http://gb.archive.ubuntu.com oneiric-backports/universe i386 Packages
Hit http://gb.archive.ubuntu.com oneiric-backports/multiverse i386 Packages
Hit http://gb.archive.ubuntu.com oneiric-backports/main TranslationIndex
Hit http://gb.archive.ubuntu.com oneiric-backports/multiverse TranslationIndex
Hit http://gb.archive.ubuntu.com oneiric-backports/restricted TranslationIndex
Hit http://gb.archive.ubuntu.com oneiric-backports/universe TranslationIndex
Hit http://gb.archive.ubuntu.com oneiric-proposed/restricted i386 Packages
Hit http://gb.archive.ubuntu.com oneiric-proposed/main i386 Packages
Hit http://gb.archive.ubuntu.com oneiric-proposed/multiverse i386 Packages
Hit http://gb.archive.ubuntu.com oneiric-proposed/universe i386 Packages
Hit http://gb.archive.ubuntu.com oneiric-proposed/main TranslationIndex
Hit http://gb.archive.ubuntu.com oneiric-proposed/multiverse TranslationIndex
Hit http://packages.medibuntu.org oneiric/non-free i386 Packages
Hit http://gb.archive.ubuntu.com oneiric-proposed/restricted TranslationIndex
Hit http://gb.archive.ubuntu.com oneiric-proposed/universe TranslationIndex
Hit http://gb.archive.ubuntu.com oneiric/main Translation-en_GB
Hit http://gb.archive.ubuntu.com oneiric/main Translation-en
Hit http://gb.archive.ubuntu.com oneiric/multiverse Translation-en_GB
Hit http://gb.archive.ubuntu.com oneiric/multiverse Translation-en
Hit http://gb.archive.ubuntu.com oneiric/restricted Translation-en_GB
Hit http://gb.archive.ubuntu.com oneiric/restricted Translation-en
Hit http://gb.archive.ubuntu.com oneiric/universe Translation-en_GB
Get:8 http://security.ubuntu.com oneiric-security/restricted i386 Packages [3,939 B]
Get:9 http://security.ubuntu.com oneiric-security/universe i386 Packages [32.1 kB]
Hit http://gb.archive.ubuntu.com oneiric/universe Translation-en
Hit http://gb.archive.ubuntu.com oneiric-updates/main Translation-en
Hit http://gb.archive.ubuntu.com oneiric-updates/multiverse Translation-en
Hit http://gb.archive.ubuntu.com oneiric-updates/restricted Translation-en
Hit http://gb.archive.ubuntu.com oneiric-updates/universe Translation-en
Hit http://gb.archive.ubuntu.com oneiric-backports/main Translation-en
Hit http://gb.archive.ubuntu.com oneiric-backports/multiverse Translation-en
Hit http://gb.archive.ubuntu.com oneiric-backports/restricted Translation-en
Hit http://gb.archive.ubuntu.com oneiric-backports/universe Translation-en
Hit http://gb.archive.ubuntu.com oneiric-proposed/main Translation-en
Ign http://extras.ubuntu.com oneiric/main Translation-en_GB
Get:10 http://security.ubuntu.com oneiric-security/multiverse i386 Packages [3,372 B]
Get:11 http://security.ubuntu.com oneiric-security/main TranslationIndex [73 B]
Get:12 http://security.ubuntu.com oneiric-security/multiverse TranslationIndex [72 B]
Get:13 http://security.ubuntu.com oneiric-security/restricted TranslationIndex [71 B]
Get:14 http://security.ubuntu.com oneiric-security/universe TranslationIndex [73 B]
Ign http://packages.medibuntu.org oneiric/free TranslationIndex
Err http://ppa.launchpad.net oneiric/main Sources
404 Not Found
Hit http://gb.archive.ubuntu.com oneiric-proposed/multiverse Translation-en
Hit http://gb.archive.ubuntu.com oneiric-proposed/restricted Translation-en
Hit http://gb.archive.ubuntu.com oneiric-proposed/universe Translation-en
Ign http://extras.ubuntu.com oneiric/main Translation-en
Hit http://security.ubuntu.com oneiric-security/main Translation-en
Err http://ppa.launchpad.net oneiric/main i386 Packages
404 Not Found
Hit http://security.ubuntu.com oneiric-security/multiverse Translation-en
Hit http://security.ubuntu.com oneiric-security/restricted Translation-en
Ign http://packages.medibuntu.org oneiric/non-free TranslationIndex
Get:15 http://security.ubuntu.com oneiric-security/universe Translation-en [23.0 kB]
Ign http://ppa.launchpad.net oneiric/main Translation-en_GB
Ign http://ppa.launchpad.net oneiric/main Translation-en
Ign http://ppa.launchpad.net oneiric/main Translation-en_GB
Ign http://ppa.launchpad.net oneiric/main Translation-en
Ign http://ppa.launchpad.net maverick/main Translation-en_GB
Ign http://ppa.launchpad.net maverick/main Translation-en
Ign http://packages.medibuntu.org oneiric/free Translation-en_GB
Ign http://packages.medibuntu.org oneiric/free Translation-en
Ign http://packages.medibuntu.org oneiric/non-free Translation-en_GB
Ign http://packages.medibuntu.org oneiric/non-free Translation-en
Fetched 255 kB in 2s (91.5 kB/s)
W: Failed to fetch http://ppa.launchpad.net/unity-team/hud/ubuntu/dists/oneiric/main/source/Sources 404 Not Found

W: Failed to fetch http://ppa.launchpad.net/unity-team/hud/ubuntu/dists/oneiric/main/binary-i386/Packages 404 Not Found

E: Some index files failed to download. They have been ignored, or old ones used instead.

Firstly … if I were you I’d disable those PPA’s (unity-team) as they no longer seem to be active.

Then we have 2 options here -

  1. attempt to install the latest proprietary drivers from NVIDIA


  1. set the 3.0-17 kernel as the default kernel to boot into.

Whch route would you prefer ?

thanx Mark…
The update manager did work in ver 19 because it asked for two flash updates to be installed.
but, probably set the ver 17 kernal to boot into? … I’m in your hands… LOL …
(would this mean I would get loads of “out of date” messages? LOL)

how do I disable the PPA’s that are not active please?

OK … I’ll do the PPA stuff tonight, and the changing the default kernel stuff tomorrow … as I’m off to bed soon :slight_smile:

Search through your application lens for “Software Sources” and start it … or you can start it by opening a terminal and running:

gksudo software-properties-gtk

However you start it … when the software Sources window opens … select the “Other Software” tab … look for the 2 lines that begin with:-


and remove the ticks from the little boxes at the biginning of those 2 lines.

Click the “Close” button.

Now back in a terminal, run:

sudo apt-get update

and check that those 2 lines -

W: Failed to fetch http://ppa.launchpad.net/unity-team/hud/ubuntu/dists/oneiric/main/source/Sources 404 Not Found
W: Failed to fetch http://ppa.launchpad.net/unity-team/hud/ubuntu/dists/oneiric/main/binary-i386/Packages 404 Not Found

are no longer reported.

Xclent… many thanx… 2 x PPA’s… vamouse…
off to bed too… soz if I kept you up?

Nah mate … nobody keeps me up, I go when I go :wink:
(except maybe the missus, and definitely the kids … OK, ignore the above)

I’ll post the other stuff tomorrow … if you have any problems, weell I’m always on here :slight_smile:


As BkS suggests, it will probably be easier/better to try the 295.40 drivers from the “Ubuntu-X” team PPA:
first … which hopefully will allow you to keep the latest kernel.

First lets make sure ppa-purge is installed (just in case we need to reverse the changes)… open a terminal and run:

sudo apt-get install ppa-purge

Now to add the PPA to your software repos:

sudo apt-add-repository ppa:ubuntu-x-swat/x-updates

Next update the package cache:

sudo apt-get update

Run a software upgrade to make sure your system is up to date:

sudo apt-get upgrade

Install the updated driver:

sudo apt-get install nvidia-current

Now, check in Additional Drivers to see if it says you have the 295.40 drivers activated.

If so … does your graphics run as expected ?

Hi Mark… thanx for all that info… it is much appreciated :slight_smile:
I didn’t realise that you were staying up… I would have hung around…LOL

I have gone through it all, but ‘additional drivers’ is not showing that the 295.40 drivers activated and the display is still stuck at a lower resolution.

soz to be on so late again… been working on a birthday cake… LOL

Which drivers are available in “Additional Drivers” ?

and which is activated ?


Can you also open a terminal and run:

dpkg -l | grep nvidia

and post the output back here

At the very top of the Additional Drivers window it says … No propriety drivers are in use on this system
below it there are 4 listed:

NVIDA accelerated graphics driver (version 173)

NVIDA accelerated graphics driver (post release updates) (Version 173-updates)

NVIDA accelerated graphics driver (version current) [Recommended]

NVIDA accelerated graphics driver (post release updates) (version - current updates)