3g dongle and linux os netbook

Please can someone help me? I have read so many posts/blogs and followed unpteen links and instructions :o but I still cannot get my 3 network 3g dongle to work on my Acer aspire one A110-ab running linux linpus lite.
here are a couple of links I followed
I am very confused as one of the other posts I read said not to upgrade to Ubuntu 10.04 as it has losts of problems, so as you maybe able to tell I realy am lost with Linux :cry:
Perhaps I should just leave it to the experts and go back to windows :-\
Anyone want a netbook :-[

how far did you get when you followed the instructions at:

Follow those instructions, and when you get to something you don’t understand or a problem, post back, but try to be specific and provide as much detail as possible.

But if you are thinking of installing Ubuntu instead of Linpus Lite, use Ubuntu 9.10 (karmic) not 10.04 (lucid)
or Linux Mint 8 (not mint 9 as this is based on Ubuntu 10.04, mint 8 is based on Ubuntu 9.10)
IMO Mint 8 tends to be a bit easier for ex-windows users to get along with than Ubuntu.

If you do replace Linpus Lite with Ubuntu or Mint, you can follow the instructions (starting at step 11) here:
these instructions are NOT for Linpus Lite.

I did all of it but I cannot seem to get the blue 3g connmgr symbol to appear, but I went ahead with the live update and I now have the mobile partner installed but when I put in the dongle I cannot get to disc1 it just shows "Removable:///3connect

I will have ago at putting the linux mint 8 you recomended on a pen drive, then I can install it if I need to.

This is more than likely a silly question but I wondered if as there is no 3g connmgr on my netbook whether it is able to support a 3g dongle and if putting on a diff linux on will make any difference.

What is the model of your dongle… I’ve never had a problem with them in Mint/Ubuntu… they “just work”… as you say first try Mint on a LiveUSB stick, make it persistent so you can save your network settings, and if it works… you can then decide if you want to install it permanently on your Hard Drive.

Hi the 3 network dongle has ZTE on the front and the box has ZTE MF112 Dongle on it I also have Huawei K3565 that I was given and told it was ‘Unlocked’ but I could not get it to work on my laptop so gave up.

I am afraid you have a real novice hear so first question …how do I make a liveUSB stick ‘Persistent’ ? and would it be best to try it on my descktop, laptop or the netbook??

I have been to www.pendrivelinux.com and the LiveUsbPendrivePersistent page on Ubuntu but I did not understand much of it…I have created a Usb Pendrive but it’s anyone’s guess if its ‘Persistent’ (I created it on using my desktop running XP)

When you ran the Linux Live USB Creator, at some stage (if you had a 2gig or larger pendrive) it should have offered you the option to make it persistent, and given you some options as to the size of the persistent partition such as 1gb, 2gb, 4gb.

If you didn’t add a persistence partition, you will not be able to save any changes you make to any configurations… the changes will be lost when you reboot back to the pendrive… effectively the USB stick will behave like a non-writable CDROM

you need to test it on the Netbook… don’t worry booting from it will make no changes to your netbook, and you will be able to “test drive” Linux to see if you can configure the 3g dongle to work.

No harm in running it on any of your PC’s though… it makes no changes to the hard drive of ANY system it is booted on.

be aware that runnng Linux from a USB stick is a lot slower than running it from a hard drive installation, so don’t let how slow it is be your deciding factor.

Once you’ve booted the netbook from the USB, and are at the desktop (Don’t click the “Install” icon yet) just try to configure your dongle by following these instructions, starting at Step 11:
if you are using Mint instead of Ubuntu, where in step 12 it says “(top right)” read (bottom right)

Can I add though that if you are unable to get the dongle to work on a Windows PC, it’s probably either broken, still locked to an account, or you are in a weak signal area… that said, it won’t hurt to try :slight_smile:

I used the installer that the download site www.linuxmint.com suggested from - www.pendrivelinux.com - Univeral-USB-Installer-v1.6.6.exe - but it did not ask me to choose the size of the partition or anything and as far as I know the pendrive is 4gb (but I could be wrong)

I am going out now (to escape the football) so will try to carry out your instructions later, and I will not worry if I cannot save anything as I think I need the practice to do it all again if it works.

I have a pen drive supplied to me by my netbook supplier so I can re-install the limpus lite if I make a real pigs ear of it.

Thanks for hanging on in there with me, your patience is much appreciated

Pendrivelinux suggest Univeral-USB-Installer-v1.6.9.exe, which “should” offer you persistence…

up to you though…

I have created the pendrive with persistent partition and Mint8 - It’s booted from USB and I have clicked the link provided http://old.linux.co.uk//docs/center/how-to/recommended-3g-netbook-solution - Starting at step 11, I inserted the Dongle…

Then what the instructions said would happen didn’t … no “New 3G Broadband” window was to be seen, but all is not lost I thought, because right there under the ‘Install Linux Mint 8’ icon was a ‘3Connect’ so I clicked on it and…nothing it opens a file browser…clicking on the files just opened more files :o

Back to instructions but that did not help because I had not filled in the options on the first window that did not appear…

I am beginning to feel like a Hamster/Rabbit cross stuck on a wheel that is generating the power for the oncoming Headlights!!!

So still just about being of sound mind I have decided I will persevere with the Mint 8 (as the netbook would need a RAM upgrade to run windows), but as to 3g dongles, I will consign them to the ‘I’m on the wrong side of the hill to waste time on this’ bin

All is not lost though BT have just dropped data limits for ‘Openzone’ and ‘Fon’ and I don’t have to do anything they are already there in the wireless networks bit

Thank you for all your help…and patience…I’m off to the seawall to see if Openzone works there…now how do I download a browser???;D

The Firefox (web browser) should already be installed

Don’t give up on the 3g dongle yet, you’re nearly there…
Take a look down by your clock (bottom right)… you will see 3 icons a speaker, a padlock, and your network manager…
right-click the Network manager icon
select Edit Connections
click the Mobile broadband tab
click Add
select the device in the drop down menu, or leave it as “Any Device”
click Forward
Select Britain (UK)
click Forward
select 3
click Forward
select Internet as the plan, and 3internet as the APN
click Forward
click Apply.

(if at any time you’re prompted for a “keyring password”, leave it blank… even if it complains)

Now carry on from step 11
step 19 says to “right-click” the Network manager icon… I think it should just read “click” the Network manager icon.
also, on the first picture it shows the Password field as blank… you need to enter three as the Password (as well as the Username).

To download and install software in Mint… (here we’ll take a look at the Opera web browser)
Click MenuPackage Manager, enter your root password… when the Synaptic package manager starts, enter what your after (such as opera, or browser) into the Quick search box… in the right-hand window you will find a list of alternatives…find opera, and click the little box next to it… select Mark for installation… select Apply (on the toolbar).
the software will be downloaded and installed for you.

Hint: if you click on the word opera (not the box) the bottom panel will display a description of what the software is.

Can you also make sure you have usb-modeswitch installed… in the synaptic package manager, enter usb-modeswitch into the quick search box, and check to see if the little box is green… if not, install it… you may need it for the 3g dongle to work.

For a hint as to why the “3Connect” icon on your desktop opens a file browser, read the description of usb-modeswitch in synaptic :slight_smile:

BE AWARE: you are going to have to have some kind of internet connection to be able to install usb-modeswitch (if needed), so if necessary connect your netbook to a router with an ethernet cable… or go back to the seawall :slight_smile:

It’s really nice here on the seawall 8)

I have followed your new instructions but 3 does not show - I tried the dongle on my laptop in the living room and the 3g worked, but here in the study (there’s posh for you…it’s an old caravan in the garden but that don’t sound so good) no 3g just the green light. and to cap it all the allowance is nearly used up and I don’t want to waste money on a topup.

I am even more confused because the laptop connected me to the internet via the dongle and the light is green! and it’s in the ‘Study’

I may re-install and start again… I must have done something incorrectly…if I knew more I would not have slavishly followed those instructions so perhaps that’s what I’ve done…hell I chasing my own tail here…Must take break - have Beer - talk to the animals - anything but This!!! :-\ :cry: :o ;D

Just one more little thing…why is my padlock icon in the bottom r/h corner broken…(only joking)

is usb-modeswitch installed?
have you got any way to get the netbook connected to the internet?

Yes I have got an internet connection through my BT hub…so have been online using Firefox

I get the distinct impression you are not going to let me give up are you?

So alright I have installed the usb-modeswitch v1.0.2-1

I will now try the dongle again…there were too many mozzies on the seawall anyway!!

Three is now showing in the ‘Mobile Broadband’ tab in network connections…but when I click on list it does not show

Ooop’s the little screen just went black and now I cannot turn it off…right just took the battery out that stopped it

I don’t think the poor little thing deserves this kind of treatment…OK it seems the battery only lasts about 2hrs…I thought it was longer but thats a 6cell and they come with 3cell…sometimes I don’t like manufactures much, but I suppose they get lots of extra money as 2hrs ain’t no good to man nor beast…sorry got a rant on there and slid of the subject

I have shoved the dongle into my desktop and it loaded drivers automatically and up came the 3 connect wizard…so the dongle works…but I was beginning to think it is that and not linux as I have done what was asked several times over as I have now started from scratch 4 times but still no Three

I cannot find anything on this dongle ZTE MF112…I’m clutching at straws now am I not…time to take a break

Whenever you’re ready…

With the dongle plugged in, can you open a terminal (Menu->Terminal), and enter this command:


hit enter, and post back the results.

Did you put a tick in the “Available to all users” box?
see pictures on right -

you might want to tick the “Connect automatically” box too (then it should just connect every time you plug the dongle in)

Also if at any time during setting up the connection it asks for a “Keyring” password… leave it blank.

You can get rid of any settings you’ve saved, and start afresh, by “Deleting” anything listed on the network managers “Mobile Broadband” tab… then clicking “Add” to enter new settings… or click “Edit” and change what you’ve already entered.

In reply too your enquiry about “keyring” passwaords…well of course I put one in ??? …and now I cannot find out how to remove/change it :cry:

I will be back after I have clean installed and got as far as your last post…without all my mistakes and in the right order…he he…sorry just made me think of Eric Morecombe and Andre Previn, but I expect your too young too know who I’m on about.

I remember it well… Eric Morcombe and “Andrew Preview”… I’m playing all the right notes, but not necessarily in the right order.
Unfortunately I’m not as young as you think :slight_smile:

If you delete all entries under the “Mobile Broadband” tab, this will clear ALL setting for the dongle (including keyring password) and then you can enter them again.

When this B**D dongle connects I will lend you my zimmer frame and race you to the PUB ;D

Right I have opened a terminal…am I supposed to see a joke and a (I think it is) cow???

Now I am not sure about this so be patient…do I type in “Code:[select]1susb” (without quotes)…i know this is old hat for you but my computing started after the Dos time and it was what kept me from Linux in the first place as I do not have a clue when it comes to Dos :-[

No…just the stuff between the grey lines, and that isn’t a 1 it’s a small L… so it’s LSUSB but in lower case, it MUST be in lower case as Linux commands are case sensitive.

you won’t find DOS here… BASH, ZSH etc. but not DOS :slight_smile:
Nearly all of this stuff CAN be done in the GUI, but it’s easier for someone at the forum to give you CLI commands… takes less typing, and I’m lazy be nature :slight_smile:

Really it’s because there is less room for misinterpretation.

Right a bit of a delay as this silly touch pad is really annoying…so have found mini mouse (no not Mickey’s friend, a mini mouse)

So I have a list … so what is it I am looking for??