A live USB with more than one Linux distro? [not quite SOLVED]

I occasionally try out a distro just for interest and always think how wasteful it is to reserve a whole 32GB USB drive just for one distro. To try another Linux version I either have to wipe the old one or buy a new USB stick.

I have read somewhere that it’s possible to have several distros on the same “Live USB”. If it’s easily possible, how can I do that?

Your advice would be appreciated.


Perfect! Just what I need.

Many thanks,

Sorry if I’m coming across as a pain but could you mark this as [SOLVED] please.


Not a pain at all - thank you for reminding me.
In fact I haven’t tried it yet as the sun is out, and no doubt I shall have further questions. But I have marked it as solved.


Ah, well - not quite solved.

It was easy enough to load Ubuntu and Lubuntu onto a USB stick using the MultibootUSB software but when I tried to use it, the system booted into the existing Ubuntu installation without the expected display of a choice of actions.

I abandoned things at that point in favour of urgent DIY but with an impending visit to a lady who wants to view a couple of different Linux distros, is would be really useful if I could crack this problem. A brief browse of the interweb revealed other users with the same problem and a common response was along the lines of “use Unetbootin unless you are an expert at Linux”. Hmm! Possibly accurate but not helpful.

If the solution is indeed complicated then I shan’t bother to pursue the multiboot method, but if there is a simple solution then I would be very glad of advice.
Unetbootin works well for me so it would not be the end of the world if I have to carry several USB sticks around with me.


You may have better luck with:

Although not tried it myself, it looks simple enough to do.

Thank you, Sezo.

The instructions appear to be clear, and I shall have a go tonight and report back.

Following the instructions on the link, I got to Double Click install-depot-multiboot.sh from your desktop and select the option to “Run in Terminal”, but double-clicking just opened the file in gedit.

The file has execution status (755) so I’m a bit surprised that I wasn’t given the option to run it.

Any ideas?

misread your problem, sorry!

It’s probably not marked as executable … if it’s on your desktop, try running:

chmod +x ~/Desktop/install-depot-multiboot.sh

now try double-clicking it.

Or running it from the commandline with:



bash -c ~/install-depot-multiboot.sh

Thank you Mark.
The file was indeed marked as executable (755), as I mentioned, but I used your command anyway, which didn’t change anything.

Your installation command worked a treat, although the file name is “…-multisystem” despite installing as “multiboot”. But I worked it out.
Following the on-line instructions:
. I plugged in my USB (/media/keith/USB21) and started Multiboot,
. Highlighted the USB
. Clicked on “confirm” (not “validate” as in the instructions)
but then I had a warning message: Disconnect/reconnect your USB drive as the mount point does not match the label!

I tried re-connecting, but to no avail.

I am guessing that the label referred to is my USB21, and it would seem that the system has a different mount point name.
Can you advise me how to match them?

[EDIT] the Properties list in Nautilus says:
Name = USB21
Volume = USB2

Helpful link?:

I used GParted to change the USB volume name to match the mount point name and that seems to have done the trick.
Multisystem then asked to confirm that GRUB2 is loaded on the USB device - I had no idea but clicked “yes” anyway and it seemed happy to continue - and I installed successfully both Peppermint 7 and LUbuntu on the USB stick.

Rebooting the machine resulted, as before, in just booting into the resident Ubuntu 16.04, so I am no further forward.

On-line searches indicate that others with the same problem have resorted installing a customised GRUB on the USB stick, but that’s quite beyond my comprehension and abilities.

Did you select the USB at machine boot time to allow it to boot from it thus giving you the choice which distro to start?

Since live USBs created with UnetBootin boot up correctly when starting the laptop, I assumed that the boot order was correctly defined to begin with a USB, if present. I have set up my desktops that way. But your post prompted me to check and you were right - I needed to press F12 to select the USB. How embarrassing is that!?

Multiboot started up OK. I have both LUbuntu and Peppermint 7 present and Lubuntu works fine but trying Peppermint resulted in an error - something about having to load the kernel first. I gave up on that. Then I tried loading Ubuntu 16.04 onto the USB but Multiboot showed an error for about 1usec and reverted to the menu. Trying other Linux ISOs had the same result.

So: the result is that Multiboot doesn’t work for me at present, which is a shame, although I shall keep trying.
For now I shall have to use Unetbootin and separate USBs.

My thanks to all contributors for your help.