A refresher please on EUFI bios's for USB boot ??

I’ve lost myself fiddling with the settings I’m sure . . . . .

In a nutshell - I’ve got mint 16 on my HDD, sole OS - I want to boot from a TAILS usb I made a while back and I can’t get it to boot off the USB but I did when I managed to install mint ! What are the settings I need?

Fast boot off? EUFI on or should I choose ‘other OS’, I dragged the USB icon to the right so it was 1st in the list for boot order, can’t remember what else I did?
either way I can boot off the hard drive but I can’t remember what I changed to boot off the USB, mint is 64 bit but the USB is 32 bit although I don’t imagine that’s relevant.

It seemed so easy when it was all blank and I was doing a fresh install! I’ll need to know for when LM17 comes out . . . .

TIA - Dave

Dunno … depends on the UEFI BIOS

According to the Ubuntu wiki

In your BIOS, disable QuickBoot/FastBoot and Intel Smart Response Technology (SRT). If you have Windows8, also disable FastStartup.