AA1 peppermint and a battery mystery

Having consulted weather my battery was kaput due to undue loss of charge and having received desktop messages to that effect - I bought a new one.Its bigger and when charged indicated a life of 6hrs. After unplugging it caved in well under that.On restart it indicated 40% power left. So…can anyone advise?

I can’t say I’ve had a problem with the battery or battery indicator.

That indicated 6 hours to discharge is just a guesstimate, so how far out was it … and more importantly did it change as the battery discharged.

Battery discharge times will also be heavily dependant on what you were doing … ie. play a flash video and watch your systems temperature rise which means it’s using more power.

I’m wondering what is different between your AA1 and mine… is yours an AOA110L (aka ZG5) ? … which BIOS version are you using ?

If you hit Alt+F2 then type gnome-power-statistics and hit enter … then go to Laptop Battery>Details what are the :-

Energy when full
Energy (design)

ratings ?

you can also leave that running, and check “History” to watch the power drain … I don’t know how accurate tat is though.

If you install acpi:

sudo apt-get install acpi

then run:


does it agree with your battery indicator panel applet ?

its a ZG5 ok
I,m stumped about the BIOS though!


and acpi agrees - its full charged

I,m going to watch it discharge, last time it was not worked at all.

The BIOS version can be found by hitting F2 at bootup … it will be listed in there somewhere :slight_smile:

or an easier way is to open a terminal and run:

dmesg | grep DMI


dmesg | grep AOA119

You should see a line similar to:-

[ 0.000000] DMI: Acer AOA110/ , [b]BIOS v0.3301[/b] 05/09/2008

I’ve highlighted the bit you’re after in red.

can you run:


a few times as the battery discharges, and see if it always agrees with the battery indicator panel applet.

will do - I need a while to read up though.

system version v0.3109
UGA intel V1585

I’m wondering if it’s BIOS version related, your BIOS is quite a few versions older than mine, and there appear to have been some fixes that were battery related, there have also been a TON of C4 state timing fixes.

C-states are CPU power saving modes … for more info, see here:

BIOS fixes contained in different versions are listed here:

Now normally I don’t like suggesting BIOS updates, because there is always a small risk of bricking the PC … the general rule of thumb is DON’T update your BIOS unless there is a specific NEED.

Only you can answer if you consider this a NEED, and are willing to take the small but significant risk of ending up with a door-stop.

I must also add, that the AA1 mitigates the risk to a certain extent by having a built-in BIOS recovery routine that should recover a BIOS update that has gone wrong … I have used this function, and it worked for me, but there are no absolute guarantees.

So, I’ve given you all the info, and I won’t be held responsible if things go wrong.

Now with that in mind … do you want to attempt a BIOS update ? … your call.

Unplugged it last night and it had 70% in the tank this a.m.
I’m curious enough to read up on your advice but will decline grappling with a Bios for the moment. Its been saved from doorstop once (thanks to you) and I’m too fond of it to risk it.
cheers Brian