[ABANDONED] Need help creating a dual-boot laptop (Win10 & Kubuntu14.04)

I did try and piece together other peoples forum posts on dual-booting with Window$ & Ubuntu but got lost.

I have an HP Pavilion Intel Core i5-7200U 2.50Ghz 2.71Ghz

I have created a Multiboot USB stick and I’d like to make my laptop a dual-boot with Kubuntu 14.04.
My HD is 1Tb and the OS is on a partition sized at 917Gb, the rest is used for recovery.

What should I do first?

Read my post I had a very similar problem all working now except for a few minor niggles with the touchpad

Thanks for the help there Paul.

Mark, I noticed this in Paul’s post; HERE

Does that go for Kubuntu 14.04 too?

I managed to sort out the UEFI/Legacy boot and was greeted with the Kubuntu desktop.
I booted to Kubuntu and then tried to resize the Window$ partitin but in the installation of Kubuntu, the ‘resize’ option is greyed out.
I even tried using KDE Partition Manager but that also had the resize option greyed out.
I cant install GParted as I’m running Kubuntu from my USB Stick.

I’m stuck at what to do now!!!

I MAY have solved the problem, I have found GParted LIVE - A USB executable ISO.
I just hope it will let me resize the Window$ partition…

It was all going so well…
That was until I got an error message…

Unable to configure GRUB
Executing ‘update-grub’ failed
This is a fatal error.

What do I need to do?

Hi,
I installed Linux mint following the instructions in the link I sent. When I installed I went to something else in the install menu and installed from there. My laptop gave me the option where to install the boot file so I put it on the same partition as Linux. That was linux mint cinnamon very sluggish I thought so I downloaded mint xfce which seems a good bit faster. It even upodated the kernel but still no touchpad

What do you mean as there is nowhere else to go in the insyall menu of Kubuntu.

My laptop gave me the option where to install the boot file so I put it on the same partition as Linux.

I thought GRUB and other boot files had to be on the same location. On a dual boot, the same location as a Window$ boot file.

I absolutely cannot follow this topic at all … I have no idea who it belongs to, or who’s asking what about which distro?

The title is “Need help creating a dial-boot laptop (Win10 & Kubuntu14.04)

If the issue is now NOT precisely about installing Kubuntu alongside Win10 can you start a new topic … otherwise, can you explain precisely where you are now and what the issue is.

TIA.

It’s MY thread and I’m having problems installing Kubuntu as a dual-boot with Window$.
The first hurdle I had was with UEFI/Legacy stopping the USB stick from installing Kubuntu.
Now, I am getting this;

Unable to configure GRUB
Executing ‘update-grub’ failed
This is a fatal error.

I don’t know exactly where in the installation process GRUB is installed, I’d guess near the end, so assuming that, Kubuntu was installed but GRUB wasn’t. I will submit this post then go and check on the partitions to see if one is named Kubuntu.

Just checked and the partition name is still blank, but saying that, I’m sure I saw that 10Mb had been used, so Kubuntu might have been installed.

So, any idea what’s wrong?
How do I solve the issue of GRUB not being written?

You know when you install linux and you get several options including install alongside windows, take over the drive etc. Further down the list is the something else button when you select this you get all the drive info, mine installed Linux eventually but it doesn’t show as as separate drive.

That’s the option I had to choose to create a dual-boot, so I can install Kubuntu on the partition which was the whole partition for Window$ (951Gb or a similar size), I halved it.

I think the problem is something to do with the partition which has the MBR on ( i know NEVER to touch the MBR). But where does Kubuntu place the GRUB file. I’ve turned off fast-boot and enabled legacy, so, what could the problem be?

Can you boot the LiveCD/LiveUSB and post the output from:

sudo fdisk -l

and

sudo blkid

Hi Mark, sorry for taking such a long time to get on with this.

Heres’s the results you required.

sudo fdisk -l

WARNING: GPT (GUID Partition Table) detected on ‘/dev/sda’! The util fdisk doesn’t support GPT. Use GNU Parted.

Disk /dev/sda: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders, total 1953525168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x916d7395

Device Boot Start End Blocks Id System
/dev/sda1 1 1953525167 976762583+ ee GPT
Partition 1 does not start on physical sector boundary.

Disk /dev/sdb: 125.1 GB, 125061562368 bytes
255 heads, 63 sectors/track, 15204 cylinders, total 244260864 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00034972

Device Boot Start End Blocks Id System
/dev/sdb1 * 64 244260863 122130400 c W95 FAT32 (LBA)

sudo blkid

/dev/loop0: LABEL=“Kubuntu 14.04.4 LTS amd64” TYPE=“iso9660”
/dev/loop1: TYPE=“squashfs”
/dev/sda1: UUID=“F278-E036” TYPE=“vfat”
/dev/sda3: LABEL=“Windows” UUID=“B0DE0ED6DE0E94AE” TYPE=“ntfs”
/dev/sda4: LABEL=“Windows RE tools” UUID=“48520F8A520F7BC6” TYPE=“ntfs”
/dev/sda5: LABEL=“RECOVERY” UUID=“9CA0BFDCA0BFBADA” TYPE=“ntfs”
/dev/sda6: UUID=“3bef93e3-009e-4af0-acc2-f2aaf0860c17” TYPE=“ext4”
/dev/sda7: UUID=“bd7838f8-8ac0-456a-99bf-0a001eb445e6” TYPE=“swap”
/dev/sdb1: LABEL=“MULTISYSTEM” UUID=“70C6-7CFF” TYPE=“vfat”

sdb1 is my USB Multiboot
sda6 is my Kubuntu partition

Okay, first of all you’re using the 64bit version of Kubuntu 14.04 right ?

Secondly, disable “legacy BIOS” mode but also disable “Secureboot” … Kubuntu 14.04 64bit is capable of installing in UEFI mode.

Yes, I am using the 64bit version and I thought I HAD disabled Legacy as when I first tried to install Kubuntu, I couldn’t.
Then I I switched off Legacy as I could install Kubuntu.

I’ll have another look.
[EDIT]
according to the setting info, legacy should be on but I could be wrong, also, secure boot was disabled.
I booted back into the Multbot USB and Kubuntu WAS installed but I don’t get the option to boot into either Win10 or Kubuntu, it goes straight to Win10.

I found UEFI boot manager in the UEFI section and changed it to boot into Kubuntu but when it boots, it boots into GRUB.

How do I fix it so that it boots into the OS, Kubuntu instead
&
How do I enable the boot option screen.

Kubuntu will boot to GRUB because it’s the Linux bootloader … then you should be able to choose Kubuntu from GRUB.

It is possible to hide GRUB, but then what would you do if you wanted to choose Windows ?

Just minimise the timeout before GRUB automagically continues booting Kubuntu.

Sorry Mark, I meant the GRUB TERMINAL.