Acer Aspire One AO150

My netbook won’t open the browser. It was working fine and then just stopped. It connects to wireless internet fine and still picked up emails and updates. I have run recovery disk and updates but not worked. Acer support have said to erase the default profile and create a new one but can’t tell me how as they don’t have linux expertise.
Can anyone help please?

Fixed in chat.
The fix was to rename the ~/.mozilla directory.

Open a terminal… you can do this by hitting Alt+F2 and then typing terminal and clicking the Run button.

In the terminal enter:

mv ~/.mozilla ~/.mozilla-old

then hit Enter

Firefox then opened without issue.

BE AWARE… you will lose your Firefox bookmarks/cusomizations.

Hi all, tried your solution to fix a similar problem on my acer, received the following message after using the enter button "mv:missing destination file operand after/.mozilla /.mozilla-old. Would appreciate any assistance you can offer. ::slight_smile:

If you entered that command correctly, it should have worked… by the fact it wants a “destination” I’m gonna guess you missed out the space between the “a” and the ~ … as in: mv ~/.mozilla ~/.mozilla-old

But you could always do it from a GUI by doing this:

  1. Open a terminal… you can do this by hitting Alt+F2 and then typing terminal and clicking the Run button

  2. In the terminal enter:


and hit enter.

  1. When thunar opens hit Ctrl+H to display hidden files. (files/folders that start with . are hidden by default)

  2. Look for the folder called .mozilla

5 Right-click the .mozilla folder, select “Rename”… and change its name to .mozilla-old

Thanks for your help so far. However having done the rename, the browser opens. however when I close the browser and attempt to reopen we are back to square one. no response from the browser until I repeat the rename action. any thoughts?

Ahhh… I’ve come across this before in Linpus Lite… it appears to be due to an incompatibility between the new GoogleToolbar addon and Firefox 2 (as used in Linpus Lite).

Where you asked anything about a google toolbar when Firefox started?

The fix is to delete the ~/.mozilla/firefox/xxxxxx .default/GoogleToolbarData directory, and the ~/.mozilla/firefox/xxxxxx.default/extensions/{long giberish name} directory.
(where “xxxxxx” is a bunch of letters and/or numbers)

Or you could try starting Firefox in “safe mode” then deleting or disabling the GoogleToolbar addon.
(I haven’t tested this method, so can’t say for sure that it works).

First reboot your PC (to kill any already running firefox processes), but when it starts, DON’T attempt to open Firefox normally… insted, follow these instructions.

To open Firefox in SAFE MODE…

Hit Alt+F2… in the resulting dialogue (text) box enter:
firefox -safe-mode
now click the Run button.
(don’t miss out the space between the “x” and the “-”, and it MUST be all lower case)

In the resulting dialogue, put a tick in “Disable all addons” (or similar)… then click “Continue in safe mode” (or similar).

Then if Firefox starts… Go to Tools>Addons>PlugIns (or Extensions), and delete or disable the GoogleToolbar plugin/extension.

Close Firefox, and restart it normally.

It may be better to disable the addon rather than delete it, as it may get reinstalled if you delete it… but that’s for you to discover, I haven’t got an AA1 so I can’t test it. :wink:

for a more complete set of instructions, see here:

Hi Mark, removed the directories as suggested. All is now back on line. You are a genius. Many many thanks for your patience and assistance.