Acer Aspire One blank screen at power on

Hi Mark,

Thanks for posting this… I had Peppermint 3 up and running beautifully… First time in ages I had been able to use my Acer One Aspire to access so many web sites… Then I switched it off and now it won’t boot up again. I did used to have this problem when running the manufacturer-installed OS (I am a real novice with computers so forgive the lack of terminology) - the netbook would suddenly refuse to boot up - something I had to fix by flashing bios (a fix I found on a forum).

Any ideas what I can do next gratefully received?! Hope the answer isn’t don’t mess around with your computer if you don’t know what you’re doing… I am trying to learn a bit more…

I didn’t think it would make any difference but I couldn’t get one of the installation steps to work? The one about the SD card…

Thanks so much!


Hi Betty, and welcome to the forum :slight_smile:

Can you explain what you mean by “it won’t boot” … what exactly happens when you turn it on ? … do you see the Acer logo ? or do you just get a black screen ? … does the light come on on the power button ?

Hope the answer isn't don't mess around with your computer if you don't know what you're doing... I am trying to learn a bit more...

You’ll never be told that here … and learning is half the fun :slight_smile:

Thanks for replying! :slight_smile:

I mean the screen is black but I can hear the fan and the power button lights up green. Even if I leave it for ages nothing happens with the screen… Hope that is clearer? Thanks again.

If you don’t get to see the “Acer Empowering People” screen, but the power button lights up green … Yes you’re going to have to do the BIOS recovery procedure again.

As you suggest, this is nothing to do with Peppermint (or Linpus Lite for that matter) it’s an issue with the AA1 hardware, luckily Acer included a BIOS recovery routine … it’s happened to me a few times too, but is easily recoverable.

Do you have a spare USB stick ?

Do you have the BIOS files you need ?

Do you remember the procedure ?

I can upload the files if you wish … and write up the procedure :slight_smile:

Thanks for confirming it is the same issue :slight_smile: - I didn’t want to do anything else in case it made it worse…

I have the bios and have done the procedure that worked before several times now but it hasn’t worked so far. Is it just a case of repeating it until it takes/the timing of releasing Fn + alt and pressing the power button is right?

There seems to be a little confusion on this pressing the power button a second time.

And it’s Fn+Esc … not Fn+Alt :wink:

All you should need to do is …

make sure both power lead and battery are connected

insert the USB stick that contains the FLASHT.EXE and ZG5IA32.FD fies.

Hold Fn+Esc … and whilst holding them press the power button … keep holding the Fn+Esc for about 5 seconds then release them, the power button should start to flash … you should see the light on the USB stick start to flash as its accessed.

Now wait till the AA1 reboots on its own.

There should be no need to press the power button a second time.

Aha… That worked! :smiley: Must have remembered the key sequence wrong :-S

Thanks so much!

You’re most welcome :slight_smile:

Give us a shout if you want to sort out the SD card issue … though that probably would be best asked in the Peppermint Three Installation Tutorial:

I also had the blank screen problem today, how strange! First I thought I had a doorstep but then I downloaded the files then flashed the bios and it worked, but the bios supervisor password was still the same so does this reset the bios or not?

The BIOS recovery routine doesn’t AFAIK flash the BIOS with the fies on the USB stick … I have the latest BIOS 33.10 on the USB stick, yet my BIOS is at 33.09

When I run the BIOS recovery, it’s still at version 33.09, so I can only assume that it’s forcing the BIOS to be updated from an on chip backup somewhere.

The routine for a FULL flash (upgrade) of the BIOS is a totally different procedure that requires you to make the USB stick a bootable DOS disk, then flash the BIOS from the DOS command line.
(I wouldn’t advise this unless it’s absolutely necessary … if a FULL flash goes wrong, you WILL brick your system)

I just thought it would reset the password after reading this.

Anyway do you know what the cause of this black screen is?

I really can’t answer either of those … I’ve never applied a BIOS password.

And have no idea why the BIOS screws up every now and again.