Acer Aspire One Fan

Now that my AA1 is using the wonderful Peppermint and no longer crashing every 5 minutes it has stayed on all day for a change. However, I now find I have ringing in my ears - the fan. It is driving me mad. Does anyone have a proper fix for it that they can talk me through? Or a link to the right place for the fix?

I have read quite a lot of various forums but am keen not to “break” my machine now that it is working well at last. Any help welcome please.

Karen

Have you still got the LiveUSB you created ?

The reason I ask is because MY AA1 (AOA110L aka. ZG5) doesn’t run the fan any quicker than it did in Linpus Lite … so I’m wondering, does it spin the fan quickly when booted to the LiveUSB … if it doesn’t, maybe something we did as part of the post installation tasks caused it.

If you have still got the LiveUSB … can you boot to it, and check if the fan still runs flat out.

If it still runs flat out from the LiveUSB, we’ll find a solution :wink:

Can you also post the exact model number of your AA1.

Thanks for replying so quickly. I ran the LiveUSB for over 10 minutes and it was roughly the same, perhaps a little quieter but still running continuously.

My AA1 is the AOA150-Ab ZG5 with 120gb HDD.

The fan has always been noisy and has never changed.

Try this …

Open a terminal and enter the following commands:

sudo su

then

echo "options acerhdf kernelmode=1" >> /etc/modprobe.d/local.conf

then

exit

then

sudo modprobe -r acerhdf

then

sudo modprobe acerhdf

Did the fan slow down … if YES … check it survives a reboot.

If NO … let me know.

OK entered all the codes. The fan went silent! Rebooted and fan still off. So far, it has come back on twice for about a minute or so then stopped again. It is certainly better so far and I am getting some peace.

Do I need to do anything else or check the temperature of the AA1?

Every now and again for the time being you can check the temperature by running:

cat /sys/class/thermal/thermal_zone0/temp

Just to be safe, but it should be fine … if it ever FEELS too warm, check the temp, then close down if above say 55C (shown as 55000)

Mine has been on for hours, and is holding a steady 46C (46000), even though it’s been running a lot of flash video … that’s the kids for you :slight_smile:

[EDIT]

It is possible to adjust when the fan comes on if it is running too hot.

Checked temp and it was 61000! The fan came on at that point and continued until it was down to 58000. Then 30 seconds later it was back to 61000. Should I turn it off?

That’s not stupidly high … it’s safe … I’ll go check the acceptable operating temps for the n270 CPU and get back to you shortly

Up to you if you want to turn off, but as long as the fan is kicking in at 60 ish it should be OK.

It seems I was being overly conservative … You’re fine at 61C … according to this datasheet:
http://www.intel.com/content/www/us/en/mobile-computing/mobile-atom-n270-single-core-datasheet-.html

the N270 has an operating range of -41C to +90C … and it contains a thermal sensor of its own that should automatically power off at a critical temp of 125C … though I wouldn’t like to see a CPU at 125C

As long as the fan is keeping it around 60C your OK.

If we lower the temp at which the fan cuts in … it may be back to being on permanently.

Yours is probably running slightly hotter than mine because it also has the heat from the hard drive to contend with … there is nearly NO heat generated from an SSD

Actually … that’s perfect …

the fanon temp is SUPPOSED to be 60C
and the fanoff is SUPPOSED to be 55C

so it’s working as it should :slight_smile:

Sorry for the delay - busy sorting food out again!

Thanks Mark for all your help and research once again.

It is good to know it will be OK and I am happy with the result of less earache.

No problem … that’s what we’re here for, and I enjoy helping, or I wouldn’t do it :wink:

Hi,
from Germany I am also a late user having changed from Linpus to another distribution (Ubuntu netbook remix). BUT: The constantly running noisy Fan!
I learned about acerhdf (is loaded and I can activate/deactivate it), learned how to show temperatures etc. etc. I can switch off the fan completely or restart it, but cannot make ist controlled by temperature. When acerhdf (version 0.5.20, came with distrib.) is enabled, it does not seem to be able to read fanoff/fanon values. After having read about “configure modprobe options to enable Acer Aspire One Fan driver fan control” in the Ubuntu documentation and typing “root@juergen-laptop:~# sudo modprobe acerhdf” I received:

WARNING: All config files need .conf: /etc/modprobe.d/local, it will be ignored in a future release.
FATAL: Error inserting acerhdf (/lib/modules/2.6.32-38-generic/kernel/drivers/platform/x86/acerhdf.ko): Unknown symbol in module, or unknown parameter (see dmesg)and again: Not possible to control the fan!!

Now I read the same procedure in your forum (see following quote) - any help for me possible?
I would really appreciate it,
Regards
Juergen


If possible, can you provide links to what you have tried so far … so I can see if anything needs undoing.

Did you need to compile the acerhdf.ko module, or was it included as part of your kernel ?

Can you send the output from:

ls /etc/modprobe.d

and

cat /sys/class/thermal/thermal_zone0/temp

and

modinfo acerhdf

also can you post the contents (if any) of these 3 files

gedit /etc/modprobe.d/local.conf

and

gedit /etc/modprobe.d/acerhdf.conf

and

gedit /etc/modules

Ever considered a move to PeppermintOS :wink: … IMHO, by far the best distro for the AA1

Hi Mark,
thanks for answering; I will try to do what you proposed. First

root@juergen-laptop:~# ls /etc/modprobe.d
acerhdf.conf blacklist.conf blacklist-modem.conf libpisock9.conf
alsa-base.conf blacklist-firewire.conf blacklist-oss.conf local
blacklist-ath_pci.conf blacklist-framebuffer.conf blacklist-watchdog.conf local.conf

root@juergen-laptop:~# cat /sys/class/thermal/thermal_zone0/temp
cat: /sys/class/thermal/thermal_zone0/temp: Datei oder Verzeichnis nicht gefunden
(Was before temperature readout, but broken now.)

root@juergen-laptop:~# modinfo acerhdf
filename: /lib/modules/2.6.32-38-generic/kernel/drivers/platform/x86/acerhdf.ko
alias: dmi::Packard Bell:pnDOA:
alias: dmi::Packard Bell:pnAOA:
alias: dmi::Gateway:pnAOA:
alias: dmi::Acer:pnAOA:
description: Aspire One temperature and fan driver
author: Peter Feuerer
license: GPL
srcversion: 140A4EBE32B3560E3204F99
depends:
vermagic: 2.6.32-38-generic SMP mod_unload modversions 586
parm: kernelmode:Kernel mode fan control on / off (uint)
parm: interval:Polling interval of temperature check (uint)
parm: fanon:Turn the fan on above this temperature (uint)
parm: fanoff:Turn the fan off below this temperature (uint)
parm: verbose:Enable verbose dmesg output (uint)
parm: force_bios:Force BIOS version and omit BIOS check (string)
parm: force_product:Force BIOS product and omit BIOS check (string)

root@juergen-laptop:~# gedit /etc/modprobe.d/local.conf

options acerhdf kernelmode=1

options acerhdf kernelmode=1

gedit /etc/modprobe.d/acerhdf.conf

fan control for acer aspire one fan

according to: http://piie.net/files/acerhdf_README.txt

check status with: dmesg|grep acerhdf

read temperature with: cat /sys/class/thermal/thermal_zone0/temp

options acerhdf interval=5 fanon=60000 fanoff=55000 kernelmode=1

root@juergen-laptop:~# modinfo acerhdf
filename: /lib/modules/2.6.32-38-generic/kernel/drivers/platform/x86/acerhdf.ko
alias: dmi::Packard Bell:pnDOA:
alias: dmi::Packard Bell:pnAOA:
alias: dmi::Gateway:pnAOA:
alias: dmi::Acer:pnAOA:
description: Aspire One temperature and fan driver
author: Peter Feuerer
license: GPL
srcversion: 140A4EBE32B3560E3204F99
depends:
vermagic: 2.6.32-38-generic SMP mod_unload modversions 586
parm: kernelmode:Kernel mode fan control on / off (uint)
parm: interval:Polling interval of temperature check (uint)
parm: fanon:Turn the fan on above this temperature (uint)
parm: fanoff:Turn the fan off below this temperature (uint)
parm: verbose:Enable verbose dmesg output (uint)
parm: force_bios:Force BIOS version and omit BIOS check (string)
parm: force_product:Force BIOS product and omit BIOS check (string)

gedit /etc/modules

/etc/modules: kernel modules to load at boot time.

This file contains the names of kernel modules that should be loaded

at boot time, one per line. Lines beginning with “#” are ignored.

lp

((I have also a file called local that contains
options acerhdf kernelmode=1 conf
options acerhdf kernelmode=1 conf
options acerhdf kernelmode=1 conf ))

((when I do

dmesg | grep acerhdf
I now get the output
[ 1498.040769] acerhdf: Unknown parameter `conf’

before this last failure/mixing up ocurred I could see with this command if fan was enabledor disabled, when it was disabled, fan ran constantly, when enabled 3 seconds fan, 3 seconds pause etc., no consideration of fanon/fanoff values.))

Hope this helps. (It is hard for me to do, as I normally use a MS PC, have no real printing attaches and not the experience about window-handling -know hardly anything about Linux - but will start to find out about Peppermint).

regards
Jürgen

OK, you’re attempting to load 3 sets of options … lets temporarily move local and acerhdf.conf to you home directory (for safe keeping):

Opena terminal and run:

sudo mv /etc/modprobe.d/local ~/local

and

sudo mv /etc/modprobe.d/acerhdf.conf ~/acerhdf.conf

Now reboot.

Now what happens when you run:

cat /sys/class/thermal/thermal_zone0/temp

Thanks,
I need some time as I need to learn first how to change rights so I can move the files … patience please, I will be back ::), Gnil

Erm … those first 2 commands will move them :slight_smile:

oh … because of …“have to learn how to move” … :cry:
ah … the proposed line gives me the temperature again (as earlier the days)=47000 presently!!
Very good - still not what I had originally trier and hoped to get; but I feel cared for very good by the expert.
Any further ideas?

So what is the problem ? … the fan should come on if/when the temperature reaches 60C-65C and go off again at 55C.