Acer Aspire One Linpus keyboard problem

I have an Acer Aspire One, running Linpus.

The problem is that when typing at any reasonable speed, the cursor jumps back to an earlier place :frowning: and really mucks up your typing!

It is like an ‘early days of programming’ thing, where someone forgot to save a vital register in an interrupt routine.

I recently installed Ubuntu 11.10. And YES! it cured the problem :slight_smile: :slight_smile: :slight_smile: . The trouble is my poor little old Aspire isn’t really up to running it and my much loved 15 sec start time extended to over a minute.

This type of keyboard problem is well documented on my diddy CnM too where it was put down to an ‘old as dust’ 2.4 kernel.

I wonder if anyone has climbed inside the kernel or keyboard drivers for Linpus and Ubuntu and found the differences? I believe Linpus is a variant of Redhat Ferodo (?). Or has anyone tried Linpus Lite 1.4?

Any clues gratefully appreciated

Linpus Lite (as installed on the AA1) is a customised and trimmed down version of Fedora 8 which is no longer receiving any updates.

I tried Linpus Lite 1.4 (in a VM) a while ago and it had a totally different desktop environment to the AA1’s version (KDE 3.5 I think) but have no idea which kernel it ran … and at the time didn’t have an AA1 to test it on.

I’ll chuck it in with the other distro’s I’m testing on the AA1.

What are the main things you are looking for is a distribution … the “must haves” ?

Thinking about it, it should be possible to update the AA1’s kernel which may fix the issue …

So far I haven’t been able to replicate the jumping cursor (probably my slow typing) … does it do it in ANY application ?

Hello again Mark!

(Don’t you ever go off duty?) :wink:

Just thought I would log this as a separate fault instead of leaving it hiding inside our earlier threads!

It certainly happens in: Sylpheed 2.47 and OpenOffice 2.3

You need at least 6-8 lines with a few blank lines in the text, but just hammer away at the keys - you don’t have to make works if you can’t type fast. Sometimes the fault lies low for a while, and then you can’t seem to type anything in the right place.

Thanks for your interest in this.

Let me know how you get on

Sorry Mark - Missed your first question

Must haves?

Very subjective, but for me…

  • Firefox
  • Sylpheed (Thunderbird didn’t work too well when I tried it on Acer)
  • OpenOffice
  • ability to read pdfs
  • support for Vodafone dongle (not that their network coverage is much good in rural Suffolk)
    (Three gives me 3G here but I don’t have their dongle!)

So far, Peppermint Linux seems to run pretty quickly on the AA1, but hasn’t got OpenOffice installed by default (nor sylpheed, nor Firefox … it has Chrome by default), not that it will be a problem to install any of these as it’s based on Ubuntu 11.04 so has access to all the Ubuntu software … I’ll try installing them and see if it slows it down any.

Peppermint uses the LXDE desktop which is much lighter than the full GNOME of standard Ubuntu, which explains the speed :slight_smile:

BUT, I’ve noticed a major drop in how long the battery lasts (seems to be a kernel regression) … there is supposed to be a fix for this, haven’t tried it yet.

I also plan on testing Lubuntu and Xubuntu, as these are both based on Ubuntu but use the Lighter LXDE and Xfce desktops respectively.

Yup … I’ll let you know my findings … if any of these run well and I can solve the battery issue, they should solve the software and keyboard issues :slight_smile:

RIP Jimmy Savile - the original “Fix it” man, DJ, and general cigar puffing eccentric.

Funny you should mention battery life. It seemed to me that my battery lasted longer when running Ubuntu, but I didn’t check it out.

Damn … wish you hadn’t said that, now I don’t know if it was all in my head and am going to have to reload Linpus, fully charge it and test before I can be sure :o

Srry! But it does give you another chance to try and reproduce the keyboard fault…

Have you tried turning touchpad “Tapping” off whilst you are typing … it seems to have cured it for me, though I must add that I haven’t tested it too well.

Not an ideal fix, more of a workaround … and you’ll obviously need to use the mouse/touchpad button for “insert” etc.

Go to Settings > Touchpad > Tapping (tab) and remove the tick from “Enable Tapping”

If that works for you … it might be worth experimenting with the tapping speed and sensitivity, and see if you can arrive at a happy compromise.

Please let me know if this is a solution or not, as though I can reproduce the jumping cursor, it doesn’t happen very often (for me) so I’m not 100% sure it worked :slight_smile:

Thanks for all the time you have spent on this, but I feel such a fool. Before I tried your mod I thought I should make sure I still had the problem, but try as hard as I could I wasn’t able to bring the fault up in sylpheed or office!
But as soon as I started typing here in mozilla it started jumping all over the place
I have now turned tapping off and will see how I get on. It may be a while before I can draw a conclusion but I think/hope you may have cracked it
Maybe a bit of Heizenberg’s uncertainty principle?
Thanks again
If you now have no use for that Acer my wife might be interested :wink:

Yeh, let me know how you get on, if it doesn’t work I’ll keep looking :slight_smile:

Nah, it will never be for sale … it was donated to help others, so that’s what it will do :slight_smile:

And yes, I’d say with a fair degree of certainty, the uncertainty principal is at work here :o … but it’s impossible to be sure.


Question … were OpenOffice and Sylpheed still open when it started playing up in Firefox ?

Oh dear oh dear this is getting to be rather embarrasing!

With touchpad tapping enabled I have spent about an hour and a half with Sylpheed, Open Office and Mozilla all open, hammering away, going from program to program trying to reproduce the fault but to no effect. All that happened was that Mozilla screen momentarily went all stripey and filled with 45 degree lines (but I don’t want to go there!)

Then I googled: acer enable tapping

Well, I have large hands and as a two finger typist maybe I am a bit sloppy

So, with tapping enabled and a setting about a third from the left, I then purposely allowed my fingers to brush over the touchpad, and YES - up came the fault! At one point the cursor even jumped to the ‘To’ box in Sylpheed.

So maybe that explains it on the Acer - my large hands and sloppy typing!

Certainly it has been much more difficult to bring the fault up on the Acer, whereas on the CnM (where it is a well documented fault) It is to do with the kernel and comes up all the time.

So, thank you Mark for your insight - I have now disabled tapping and get along fine. Sorry to have taken up so much of your time. But (again) thanks for all your work on Mozilla and Flash - as I said before - you have saved this Acer from going to landfill… (and pleased my wife with getting iPlayer back - so that is no mean feat!)

Maybe that’s why I was having trouble reproducing the problem … smaller fingers :slight_smile:

Luckily I noticed the cursor jump when I accidentally hit the touchpad with my thumb … I’ve obviously got more of a thumb issue going on :wink:

Coming back to this subject…

  1. Still using Linpus (because I like the fast start up). But I have continued to have irregular cursor jumps when typing moderately fast. I wonder if this is related to the fact that the Touchpad ‘enable tapping’ option seems to get set ‘ON’ every start up. (Any ideas how to turn it OFF permanently?)

  2. I bought another AA1 / ZG5 on eBay to experiment with varieties of Linux. But it has Windows 7 installed so I decided to give it a whirl. To my surprise the cursor jumping is far worse that under Linpus - I cannot type a line without the cursor jumping to some previous place!

I cannot imagine that there is much common code between Linpus and Win 7. Does this point to something in the Kernel or BIOS?

Later additions…

  1. Googling: Windows 7 disable tapping
    shows this is a MEGA problem - not just for the AA1

  2. Neat solution for Windows users - TouchFreeze is a brilliant little app that solves this problem. It disables the touchpad temporarily the moment a keystroke is pressed and enables it back when the typing is stopped.

If only there was something like this for Linux!