Acer Aspire One with Linpus Lite Linux

Using your instructions I upgraded my Firefox from version 2 to 7.0.1 and all has been fine for a year.

Thank you for your help.

I upgraded because Hotmail advised me to.

Now Hotmail has recently changed to Outlook and it is advising me to upgrade Firefox.

Kindly advise me what I have to do.

Thank you.

Hi woodward, and welcome to the forum :slight_smile:

Firstly, my advice would be to ditch Linpus Lite in favour of PeppermintOS 3 which will give your AA1 a completely new lease of life and allow easy access to all the latest software … there’s a tutorial for doing that here:
http://linuxforums.org.uk/index.php?topic=10313.0
Seriously, you won’t regret it … more likely you’ll wonder why you hadn’t done this sooner :wink:

If you decide you must stick with Linpus Lite … There was a major issue with Firefox version 8 in Linpus Lite but I’ve been told later versions were OK … now I don’t use Linpus Lite anymore (I use Peppermint) so I have no way of testing that, but we can try backing up Firefox 7 and installing Firefox 19 if you’d like … no promises it’ll work though (it works in Peppermint, and like any other software can be installed with a few mouse clicks or a single command).


WARNING - These instructions are ONLY for people running Linpus Lite on an Acer Aspire One, and ALREADY have Firefox 7 installer

Instructions for backing up Firefox 7, and installing Firefox 19 -

All commands given need to be entered into a terminal… to open a terminal, hit Alt+F2 … in the input field enter terminal and click the Run button… a terminal will open… When the terminal opens, enter the following commands (hitting Enter after each command to ‘run’ it)
(also remember Linux commands ARE case sensitive so enter exactly as shown, or even better copy and paste).

OK first to backup Firefox 7 … open a terminal and run:

sudo mv -v /opt/firefox /opt/firefox7

then

cp -vr ~/.mozilla ~/.mozilla7

OK, that’s the backing up done … we can remove the backups later if Firefox 19 works.

Now use wget to download Firefox 19.0.2:

wget "https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/19.0.2/linux-i686/en-GB/firefox-19.0.2.tar.bz2"

(Non en-GB versions can be found here:
https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/19.0.2/linux-i686
but you’ll have to adjust the wget command accordingly … if you’re unsure how, just ask)

Extract the just downloaded file to /opt:

sudo tar -jxvf firefox-19.0.2.tar.bz2 --directory /opt

Create a plugins directory:

sudo mkdir /opt/firefox/plugins

[EDIT]
Skip the next command, and continue after the “END EDIT” if you don’t want Firefox to automatically update itself.

Change the /opt/firefox directory owner to user:

sudo chown user -R /opt/firefox

[END EDIT]

Now, link all old plugins to the new firefox/plugins directory:

sudo ln -s /usr/lib/mozilla/plugins/* /opt/firefox/plugins

Close ALL running instances of Firefox … and reopen it.

That’s it … hopefully Firefox 19.0.2 will now be working … if it does, can you let me know so I can type up a new tutorial for other AA1 users to replace the old one for 7.0.1 … thanks in advance.

If it doesn’t work … let me know and we’ll either fix it, or go back to Firefox 7.0.1


Once you’re happy Firefox 19 works properly, you can delete the firefox7 backups to save space by running:

rm -vr ~/.mozilla7

then

sudo rm -vr /opt/firefox7

But don’t do that till you’re 100% SURE you won’t need to go back to firefox 7

Help!?!?! it didn’t work and I need to go back to firefox 7 where I could actually open my browser?!?!?! was worth the try though

Can you post the output from:

ls /opt

it just says

Adobe firefox firefox7 GKxdatacard

exactly like that

That’s what I hoped for :slight_smile:

Can you tell me if there’s any output from:

ls ~/.mozilla7

extensions firefox plugins

Great :slight_smile:

Now would you like to immediately go back to Firefox 7, or try the latest Firefox 32 ?
(If 18 didn’t work, I doubt if 32 will … but can’t hurt to try if you’d like)

I’d just like to go back to 7 and then possibly look at a version which does work. do you know of the latest version to work on my os? and thanks for this your a legend!!!

I haven’t got a clue which is the latest to work in Linpus Lite … I ditched it ages ago in favour of Peppermint which runs all the latest software.

Anyway, to go back to Firefox 7, (with Firefox CLOSED) run these commands in sequence:

sudo mv -v /opt/firefox /opt/firefox19

If that command finishes without error, (if it errors, STOP now and tell me the error) run:

sudo mv -v /opt/firefox7 /opt/firefox

then test firefox and tell me if it works … if it does we’ll clean up.

it has worked!!! :slight_smile: :slight_smile: :slight_smile: :slight_smile: :slight_smile: :slight_smile: :slight_smile: what a legend!!! how do I clean up please? and is there any other tips or tweaks or mods you can give me to allow my system to run smoothly?

OK, run:

sudo rm -R /opt/firefox19

then

rm -R ~/.mozilla7

Seriously … the best advice I could give you for Linpus Lite is “replace it” … sorry I know that’s probably not what you want to hear, but it’s just too old and unsupported now.

Peppermint is my OS of choice for the AA1 … it’s what I run on mine … there’s an installation tutorial for putting PeppermintOS on an AA1 on here somewhere.

Thank you for that anyway pal is it ok to message you if i need to know anything else?

Sure feel free, but if it’s a support question (where any response may benefit others) I’ll likely only ask you to post it to the forum :wink:

and you’re most welcome.