ADDING A NEW HARD DRIVE IN SUSE 11.3

hello to you all
new boy in town
been playing with linux for a while but a teeny problem
the answer is probably staring me in the face

i was given a 500gig sata that i plugged in
yast2 finds it in hardware search
i do what i always do in fstab but it just wount mount - not found

can some one run through what should be done
its a wdc… 500 gig with ntfs

cheers

Can you send us the output from:

fdisk -l

run as root.

and the contents of your /etc/fstab

and let us know where you are trying to mount the drive/partition.

developments
not that i understand

since playing around it has started being mounted again as USBHDD which was what it appeared as
when it was in its usb caddy and plugged in.

can any one explain that to me?

out of its caddy and wired up on a sata connection
appears in hardware search as sda1
mounts as USBHDD as previous
only after me screwing up in fstab

i’m lost

cheers

Can’t help unless you answer my questions :wink:

It will still be being mounted in the same place if the fstab entry is using UUID’s… after all, the partitions UUID hasn’t (necessarily) changed.

fstab:-
/dev/disk/by-id/ata-ST3402111A_4PF01C6V-part1 swap swap defaults 0 0
/dev/disk/by-id/ata-ST3402111A_4PF01C6V-part2 / ext4 acl,user_xattr 1 1
/dev/disk/by-id/ata-ST3402111A_4PF01C6V-part3 /home ext4 acl,user_xattr 1 2
/dev/disk/by-id/ata-MAXTOR_STM3160212A_9LS4K0DC-part1 /windows/C ntfs-3g users,gid=users,fmask=133,dmask=022,locale=en_GB.UTF-8 0 0
/dev/disk/by-id/ata-Maxtor_6L160M0_L307VFKG-part1 /windows/D ntfs-3g users,gid=users,fmask=133,dmask=022,locale=en_GB.UTF-8 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0

Do the /windows/C and /windows/D directories actually exist ?

ls /windows

should tell you what is contained in the /windows directory.

if not, in a terminal enter

su
mkdir /windows/C
mkdir /windows/D

hit enter after each line, and your root password when asked… then if either of those commands DOESN’T return a “File exists” error, reboot and see if the ntfs drive/partitions get mounted.


Are the NTFS drives/partitions mounted if you log in as root ?

Are either of the NTFS partitions mounted ? (ie. is ntfs-3g installed)

Which one of the 2 ntfs drives are you having problems with ?

BTW, there are 4 questions there… can you answer them ALL.

It would also be handy if you’d answer my 2 previous questions -

what is the output from:

fdisk -l

run as root.

and where you are trying to mount the drive/partition… /windows/D ?


What is returned if you try to mount it manually?

open a terminal and enter:

su
mount -t ntfs-3g /dev/disk/by-id/ata-Maxtor_6L160M0_L307VFKG-part1 /windows/D

hit enter after each line, and your root password when asked.

if it doesn’t mount, send us the output from the last command.

yes the windows both exist and are mounted
the c drive is mounted at /windows/C
the d drive is mounted at /windows/D

the problem was that i had put in another sata drive that was in a usb caddy
when connected it appeared as /USBHDD and all worked fine - till it stopped working
so i took it out of the caddy and connected it up to the spare sata

it all worked and was recognised during the startup and when doing a hardware detection in yast2
but i wasnt able to use it as it wasnt being mounted

so i started twiddling with fstab with no sucess… to start with
then all of a sudden it started to be mounted as /USBHDD like it was when it was removable
so all was fine

but why?..

why isnt it being mounted when connected up as a sata drive?

why is it now being mounted but at /USBHDD when in hardware detectiom it is assigned /sda1?

just wondering

i am also a new here and i lost my hard doing all that stuff :frowning: its still not fixed… hope you find the solution…