Adobe Flash player out of date on Chromium Solved

As we know Adobe have stooped updating flash for Linux thus when I go to sites that want the latest flash version I get the drop down menu telling me flash is out of date.

Is there any way to stop the warning as it will never be possible to get an update?

Thanks.

Couple of questions …

Which Linux distribution/version/architecture … eg. Ubuntu 12.04 64bit

Which version of Chromium are you using ?

Which version of Flash are you running ? … you can find this out by opening Chromium, and entering this into the address bar:-

chrome://plugins/

and hitting enter … then looking for “Shockwave Flash”, which will be followed by a version number.

Linux Mint
Release: 13 (maya)
Edition: MATE 64-bit
Chromium Version 20.0.1132.47 Built on Ubuntu 12.04, running on LinuxMint 13 (144678)
Flash 11.0r1

can you send the output from:

sudo find / -name libflashplayer.so

it will take that a short while to complete.

userone@office2 ~ $ sudo find / -name libflashplayer.so
[sudo] password for userone:
/etc/alternatives/libflashplayer.so
/usr/lib/mozilla/plugins/libflashplayer.so
/var/lib/dpkg/alternatives/libflashplayer.so
/opt/mint-flashplugin-11/libflashplayer.so
userone@office2 ~ $

mkdir ~/.mozilla/plugins

then

cd ~/.mozilla/plugins

then

wget http://fpdownload.macromedia.com/get/flashplayer/pdc/11.2.202.238/install_flash_player_11_linux.x86_64.tar.gz

then

tar -xvf install_flash_player_11_linux.x86_64.tar.gz libflashplayer.so

Now close ALL web browser instances, and restart Chromium. ← this is IMPORTANT

in Chromium, go to this address:- chrome://plugins/

Scroll down the list of plugins and see if there’s one listed called Shockwave Flash 11.2 r202

If there is … disable ALL OTHER versions of Shockwave Flash (click the blue “disable” writing) versions, so that’s the ONLY one enabled … and restart Chromium.

If there isn’t a version 11.2 r202 in the list … let me know and we’lll try the 32bit flashplayer.


This is for my future reference if needed … the address of the 32bit flashplayer:

That’s cracked it though I thought they had stopped updates for Linux systems.

Thanks.

Now in need of the 32bit version.

Latest 32bit version -

mkdir ~/.mozilla/plugins

then

cd ~/.mozilla/plugins

then

wget http://fpdownload.macromedia.com/get/flashplayer/pdc/11.2.202.251/install_flash_player_11_linux_i386.tar.gz

then

tar -xvf install_flash_player_11_linux_i386.tar.gz libflashplayer.so

Now close ALL web browser instances, and restart Chromium. ← this is IMPORTANT

in Chromium, go to this address:- chrome://plugins/

Scroll down the list of plugins and see if there’s one listed called Shockwave Flash 11.2 r202

If there is … disable ALL OTHER versions of Shockwave Flash (click the blue “disable” writing) versions, so that’s the ONLY one enabled … and restart Chromium.