Another help request!!

Hi - I’m having problems with my eeepc again, I think it may be related to memory space again?
I opened a memory stick that I use regularly and all of the folders except one had disappeared. They reappear when I open it on a different pc. I am able to save new files from my eeepc hard drive onto the pen but they are nowhere to be found when I open the pen on a different pc. I’ve tried using other pens with same results. I can’t find any more applications to delete (got rid of a blue soleil bluetooth one) and am in process of uploading all photos of hard drive to “photobox” online. What could be causing this??

Also, have finally got round to attempting to update my internet browser on the eeepc, I’ve not been able to send emails on it for ages. I think I have downloaded the firefox update succesfully and restarted it but when I go to hotmail it still says I need to update browser… very frustrating as I can’t add attachments to email…please help - got loads of work to do and I’m stuck! (My other laptop is windows and I can’t edit Word documents on it but thats another story!!

Thanks in advance.

Try this …

Open a terminal and enter:

sudo apt-get clean

hit enter, and your password when asked.

and see if that free’s up any space.

Can you also send the output from:

df

so we can see if it is related to drive space.

And preferably the exact model of your EeePC … so I can check to see if it can use an SD card as a drive expansion (like the Acer Aspire One).


Once we’ve freed up some space … I’ll tell you how to install a newer version of Firefox.

Hi - I inputted the first command and hit enter as follows, but it didn’t ask for password?

/home/user> sudo apt-get clean
/home/user>

/home/user> df
Filesystem 1K-blocks Used Available Use% Mounted on
rootfs 1454700 1362428 18376 99% /
/dev/sda1 1454700 1362428 18376 99% /
unionfs 1454700 1362428 18376 99% /
tmpfs 254164 16 254148 1% /dev/shm
tmpfs 131072 24 131048 1% /tmp

I can’t find anything other than eeepc4g on computer but I’ll see if I can find box later - (I seem to remember when buying that you could get the extra memory)…Thankyou!

Yup, drives full again … we need to find something to remove.

Can you start your web browser ? … if so, try clearing its cache.

run:

sudo apt-get autoclean

does copying to the USB stick work now ? … if it does, I’d consider making a backup EVERYTHING yo need to keep, and doing an F9 system restore.

what’s the output from:

df -h

after doing the 2 things above ?

Hi - I’ve done the first step - I opened a browser and then input this into console window, was that right?

/home/user> sudo apt-get autoclean
Reading package lists… Done
Building dependency tree… Done
/home/user>

Have tried saving to pen and it saves but doesn’t show up on other pc. The other files on the pen are still missing when I open it on linux pc. I’ll keep removing photos and save everything then try the next step. Thanks!

I've done the first step - I opened a browser and then input this into console window, was that right?

No, the browser cache needs to be cleared from inside the browsers settings … which web browser/version does the EeePC use ?

If its Firefox … Open Firefox and hit Ctrl+Shift+Del (at the same time) … then depending on the version you want to select “Cache” and “Everything” (if exists), then click “Clear Now” … this may vary depending on Firefox version.

==============

The files that appear to be missing on a Linux PC … their names don’t start with a full stop (.) do they ?

Hi - Happy new year to you!
Afraid I’m still stuck with this memory thing, have tried clearing the cache, I ticked the boxes as follows: browsing history, cache, authenticated sessions, but not cookies and saved passwords. Then clicked ‘clear private data now’.

I’ve removed nearly all my photos to photobox online, I can’t back anything up though because I can’t save to pens…any suggestions?
I’ve also got about 20 short video clips which I guess take up alot of space, any recommendations of places to upload online?

The model specs are ASUS eeePC 4GB hard drive handheld computer, 512 MB internal memory.

The missing files are .doc

Thanks for your help and patience!

Have you tried uploading them to Dropbox ?

Dropbox give you 2GB free.

But there are other free “cloud” storage provuders.

Hi - thanks for the tip about cloud storage, didn’t know about this before!

I used Adrive to upload all data (50mb free) and did F9 system restore.

All data now removed - but when I insert USB, depending which stick I use it either says “You do not have enough permissions to read /home/user/ USB flash drive” or File Manager detects it at first and asks do I want to open in File or photo etc manager but then it just doesn’t appear.

I looked online and found this advice on asus support forum;
launch terminal and enter …
sudo -i
mkdir /media
exit

The first time I did this it worked and I was able to open a USB stick, but when I shutdown and tried stick again I got same error message. Tried inputting same thing again as follows:

/home/user> sudo -i
eeepc-anitaanum:/root> mkdir /media
eeepc-anitaanum:/root> mkdir /media
mkdir: cannot create directory `/media’: File exists
eeepc-anitaanum:/root> exit
logout
/home/user>

You asked for the following output:

/home/user> df -h
Filesystem Size Used Avail Use% Mounted on
rootfs 1.4G 95M 1.3G 8% /
/dev/sda1 1.4G 95M 1.3G 8% /
unionfs 1.4G 95M 1.3G 8% /
tmpfs 249M 12K 249M 1% /dev/shm
tmpfs 128M 20K 128M 1% /tmp
/home/user>

A list appears in File manager when I try to open stick (tried to cut and paste but couldn’t) which says USB owner / group is root, whilst my documents and trash are both listed as user.

I think I’m nearly there with this but it’s starting to drive me slightly mad! Please help!
Thanks

can you open a terminal and (with the USB stick inserted) enter:

mount

hit enter, and post the output back here.

/home/user> mount
rootfs on / type rootfs (rw)
/dev/sda1 on / type ext2 (ro)
unionfs on / type unionfs (rw,dirs=/=rw:/=ro)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw)
tmpfs on /dev/shm type tmpfs (rw)
tmpfs on /tmp type tmpfs (rw)
usbfs on /proc/bus/usb type usbfs (rw)
/dev/sdc1 on /media/partition1 type vfat (rw,nosuid,nodev,noexec,fmask=0111,dmask=0000,codepage=cp850,iocharset=utf8,shortname=mixed)
/home/user>

thanks

WITHOUT the USB stick inserted, can you open a terminal and send the output from:

ls -al /media

then plug in the USB stick and run:

ls -al /media

again, and send the output.

As I’m not 100% familiar with the eeepc file manager … when you say it displays the USB stick in a list, does it display a path such as /media/Partition1 when you hover the mouse over it ?

/home/user> ls -al /media
ls: /media: No such file or directory
/home/user> ls -al /media
total 44
drwxr-xr-x 3 root root 4096 2012-04-02 07:49 ./
drwxr-xr-x 22 root root 4096 2007-12-11 18:50 …/
-rw-r–r-- 1 root root 69 2012-04-02 07:49 .directory
drwxrwxrwx 16 root root 16384 1970-01-01 01:00 partition1/
/home/user>

Hi the list has only appeared a couple of times seemingly at random so I don’t know how to get to it!
Thanks

From what I’m reading Xandros (as used on the EeePC) has some weird mounting mechanism for mounting removable media.

Try this …

sudo chown -R user:user /media/Partition1

other than that, the USB stick is being mounted, but you may have to manually navigate to it at:-
/media/Partition1

From what I’m reading Xandros normally assigns mount points as drive letters (similar to Windows), eg. D, E, F, etc. … and either drops a symlink into your home directory … or mounts them directly into your home directory … is this correct ?

Where did you see the “fix” of creating the /media directory ?

Hi
/home/user> sudo chown -R /media/Partition1
chown: missing operand after /media/Partition1' Try chown --help’ for more information.
/home/user>

I’ll have to take a few minutes later on to get my head round the query about Xandros but I’ll let you know!

Here’s the link
http://vip.asus.com/forum/view.aspx?id=20080302120702000&board_id=20&model=Eee+PC+4G%2FLinux&SLanguage=en-us&page=1
Thankyou.

My apologies … I missed out the user:group operands … I’ve fixed the command in my last response, but here it is again:

sudo chown -R user:user /media/Partition1

BTW, this command must be run with the USB stick plugged in.

All that command is doing is recursively changing the owner and group of the /media/Partition1 directory (which is the mount point of your USB stick) to “user” rather than “root”.

Hi
/home/user> sudo chown -R user:user /media/Partition1
chown: cannot access `/media/Partition1’: No such file or directory
/home/user>

I’m not really sure about the symlink / direct query - sorry - all I can tell you is that the USB used to come up as D and is accessed (I think) via Home.

Ongoing thanks!

Ok, take the stick out, count to 10, stick it in, count to 10, then do “cd /media/Partition1”.
Now type “dmesg” and paste in the last 20 lines or so as a reply …

Hi again - I admitted defeat and gave up on my eeepc - got an iPhone instead! But now unfortunately I need to get it up and running again - thanks for your last reply and instructions which I must admit I didn’t get round to attempting as I had lost the will - but your help was appreciated! I emailed pc world recently to see what storage upgrade they recommended and they said that due to the small form factor, the eeepc 701’s storage cannot be upgraded by any other way than an SD card. However - I also rang supergps and if I understood correctly - they said I could either get 2GB ram for approx £25, or a solid state drive SD card which was permanent (?) storage and started around £12.

Am confused as usual … Would extra storage solve the problems and if so which option would be best?

Many thanks in advance.

is this the 4GB model ?

A lot of people have installed Peppermint onto a 4GB EeePC 901 … with a slight modification to a single file, so it should work on the 701 if it has 4GB

it doesn’t leave a huge amount of room for installing applications or saving files to the SSD … but you can always use an SDcard for storage.

As an aside … I’d be seriously surprised if they say they can “upgrade” the 4GB SSD for £12 … they probably just mean adding an SDcard.