Another "which is best for me"

Good afternoon and a Happy New Year to you all here.

Firstly I want to say Hello to everyone as this is my first thread here however I don’t intend to be a stranger :smiley:

Into it then… I’m using an Asus router at home and have it set up for media sharing. The router is Linux based and for that reason I want to use a Linux partitioned attached HDD as opposed to an NTFS.

For a while I’ve wanted to try and move to Linux and now is the perfect opportunity to do so. For initial use I’ll be using Linux to access the routers HDD for connected operation because sometimes I’ll be moving around so much stuff that connecting via local FTP isn’t going to be preferable.
I really need a Distro that has a progress indicator and preferably transfer rate while copy files around and a couple that I’ve tried to use didn’t seem to have that.

The other problem I faced on a previous attempt was that whilst copying approximately 1tb in relatively large files from the now ext4 HDD on to my laptop the whole system came to a stop and was unusable until the process had finished. The laptop is an i7 with 16gb of ram and a 2tb so I don’t think it was the hardware that was to blame.

Any help and suggestions here would be great and as I say, although it’ll be mainly file moving at the moment I will be migrating to Linux full time as most of anything I do from day to day is on my phone.

Thanks for your time all and I hope to hear something from you :slight_smile:



Which Linux distros have you tried ?

Mint’s nemo file manager has a progress bar.

Hey Mark,

So far I’ve tried Zorin, Netrunner, Ubuntu Gnome, Cent and a couple of others that I can’t remember the name of. Now to be faif I found out after the first few that I was inadvertently looking for Windows and maybe didn’t give them a real go before even noticing the file copy progress. I did however notice it on Ubuntu Gnome when trying to copy files to the desktop, which is my preferred location because the rest of the file system layout is new to me.

Today I’m on Manjaro Cinnamon and another problem that I noticed before, but forgot to put in to my first post is that whilst copying files it must be showing a cached copy rate indicator because after the copy shows a much higher and preferable copy speed than I get in Windows 10 I have to wait for quite a while after the bar gets to the end and the pending transfer time indicator reads 0 seconds.

Is this enough info or is there anything I’m missing mate?

Cheers again Mark,


It’s a hard question to answer because I’ve never really looked for how accurate the file transfer dialog is

Maybe try something with Xfce such as MX Linux

or maybe give PeppermintOS a go.